Welcome to the North American Subaru Impreza Owners Club Thursday October 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > STi Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Old 07-11-2003, 10:14 AM   #1
Burke
Scooby Newbie
 
Member#: 38939
Join Date: Jun 2003
Vehicle:
2004 STI
Black w/ Gold Rims

Default Second Break in?

I just finished my break in and am now finally able to romp on it. I noticed something strange though. The car seems to pull really hard up to 5k then it seems to level off a bit. Does it take time for the engine to break in at these new revs before it can pull all the way up to 7k?

Maybe I am just used to my bikes that pull hard all the way to the limiter.
* Registered users of the site do not see these ads.
Burke is offline  
Old 07-11-2003, 11:47 AM   #2
Impreza01
Scooby Specialist
 
Member#: 152
Join Date: Aug 1999
Vehicle:
2002 Impreza WRX
WRB

Default

Quote:
Burke
I just finished my break in and am now finally able to romp on it. I noticed something strange though. The car seems to pull really hard up to 5k then it seems to level off a bit. Does it take time for the engine to break in at these new revs before it can pull all the way up to 7k?
I'm guessing this is your first turbocharged car, eh? In most production turbo cars, the turbo boost drops before redline and thus the peak boost is 2 or 3k rpms before the redline. Hence you'll feel a tapering of power before 7k.

The only way to get around that feeling and power tapering is to tune the car's ecu or to use a boost controller.
Impreza01 is offline  
Old 07-11-2003, 01:32 PM   #3
VVVV
Scooby Newbie
 
Member#: 37205
Join Date: May 2003
Chapter/Region: RMIC
Location: Colorado
Vehicle:
2004 STI
WRB

Default

Or from what the tuners are saying so far, you need to buy a bigger turbo.
VVVV is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Second drop in RPM after already in 4th gear nardvark Transmission (AT/MT) & Driveline 6 12-13-2007 12:48 PM
Anything going on in the city or NNJ second weekend in Sept GeoffM Tri-State Area Forum 0 07-28-2007 01:01 PM
Warning: in_array() [function.in-array]: Wrong datatype for second argument in /searc Sephro Off-Topic 5 01-22-2007 01:53 PM
To break-in or not to break-in ... that is the question ! Extraze STi Forum Archive 13 06-04-2003 08:36 PM
Is my WRX breaking, or just breaking in. Faiz One Newbies & FAQs 5 12-12-2001 08:48 PM


All times are GMT -4. The time now is 07:05 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.