Welcome to the North American Subaru Impreza Owners Club Thursday April 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-16-2005, 12:17 PM   #1
elohdaeh78
Scooby Specialist
 
Member#: 61395
Join Date: May 2004
Location: North NJ
Vehicle:
2005 WRX
CGM

Default oil leaking issue

I have an 05 wrx. I have 9k miles on it and i have changed the oil 3 times. Everytime i go to change it i notice that oil is leaking out of the oil pan plug. When i first changed the oil i didn't notice a crush washer on the oil plug, what i thought may have been the washer sat deep in a groove on the face of the plug but it was soo smashed in there that i coudln't even fit a razor blade inbetween it, i showed it to my brother who has a 02 wrx and he said thats not how his looks. My question is does the washer fit in a groove in the plug or does it just sit flush on the lip. I have been putting crush washers from subaru on it each time i change the oil and each time it still leaks, i am wondering if it already has a washer on it and its just soo crushed inside the plug that i can't get it out.
* Registered users of the site do not see these ads.
elohdaeh78 is offline   Reply With Quote
Old 01-16-2005, 12:58 PM   #2
jac04
Scooby Specialist
 
Member#: 49895
Join Date: Dec 2003
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
09 Forester
06 Legacy 2.5i Wagon

Default

I just looked at the drain plug that I removed from my 05 when I installed the factory gauge pack. The flange on the plug should have a flat surface that the crush washer sits against. There is no groove. The crush washer is very noticeable.

Now, I just noticed that my 05 seems to weep a little from the oil drain plug (which is now actually the drain plug/sending unit). I used a new crush washer and tightened the plug to 30 ft-lbs. I tightened the plug a little more today to see if that takes care of the problem. At my next oil change, I plan to inspect the pan a little more closely to see if there is something on the pan side causing the problem.

I hope this helps a little.
-Jeff
jac04 is offline   Reply With Quote
Old 01-16-2005, 05:36 PM   #3
elohdaeh78
Scooby Specialist
 
Member#: 61395
Join Date: May 2004
Location: North NJ
Vehicle:
2005 WRX
CGM

Default

Quote:
Originally Posted by jac04
I just looked at the drain plug that I removed from my 05 when I installed the factory gauge pack. The flange on the plug should have a flat surface that the crush washer sits against. There is no groove. The crush washer is very noticeable.

Now, I just noticed that my 05 seems to weep a little from the oil drain plug (which is now actually the drain plug/sending unit). I used a new crush washer and tightened the plug to 30 ft-lbs. I tightened the plug a little more today to see if that takes care of the problem. At my next oil change, I plan to inspect the pan a little more closely to see if there is something on the pan side causing the problem.

I hope this helps a little.
-Jeff
Thanks for the response so that means my car didn't have a crush washer on it from the factory, i tightened the **** out of the drain plug this time, if it still leaks i have some sort of issue and subaru will be fixing it. Thanks again.
elohdaeh78 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Two leaking rear main seals in a year?? Leaking Head Gasket...Oil Pressure Issues??? jsavage Factory 2.0L Turbo Powertrain 4 05-21-2010 11:06 AM
Oil leak issue, help me stop freaking out. 08 WRX TheBrandon Factory 2.5L Turbo Powertrain 28 04-01-2010 01:58 PM
oil leak issue alwu Factory 2.0L Turbo Powertrain 3 11-05-2009 07:43 PM
New oil leak issue sidewayz Factory 2.0L Turbo Powertrain 2 03-15-2008 01:14 AM
Oil Leak issue help simonbsays Newbies & FAQs 6 10-06-2007 05:16 AM


All times are GMT -4. The time now is 04:56 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.