Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-13-2003, 09:33 PM   #1
smacksube
Scooby Specialist
 
Member#: 4067
Join Date: Feb 2001
Vehicle:
01 2.5 rs
silver

Default help with my aftermarket FPR

i bought vishnu rails and it came with the 1:1 adjustable FPR. i installed everything but fuel won't go past the FPR. There are 3 nozzles on the unit, one on bottom and 2 on the side. the diagram says to hook up the bottom one to fuel feed, and the 2 sides to the fuel rails. well...i prime the car but no fuel goes into the rails. i take off the feed line and fuel bloooows all over the place. i tried screwing in the adjuster screw all the way and then taking it out, but still no go. do i need to be starting the car to get fuel to the injectors? the only thing i can think of is that the fpr NEEDS to see vaccuum/boost to work? is this right? it's not seeming right that i can't prime the fuel pump and get fuel past the fpr....i've had a long day..please help...thanks
* Registered users of the site do not see these ads.
smacksube is offline   Reply With Quote
Old 07-14-2003, 03:31 AM   #2
kaos200
Scooby Guru
 
Member#: 2692
Join Date: Oct 2000
Chapter/Region: SCIC
Location: SoCal
Default

wha?
the feed splits and one goes to each rail
then one line from each rail to the sides of the regulator
then the bottom of the regulator to the RETURN!

Quote:
Originally posted by smacksube
i bought vishnu rails and it came with the 1:1 adjustable FPR. i installed everything but fuel won't go past the FPR. There are 3 nozzles on the unit, one on bottom and 2 on the side. the diagram says to hook up the bottom one to fuel feed, and the 2 sides to the fuel rails. well...i prime the car but no fuel goes into the rails.
kaos200 is online now   Reply With Quote
Old 07-14-2003, 11:33 AM   #3
smacksube
Scooby Specialist
 
Member#: 4067
Join Date: Feb 2001
Vehicle:
01 2.5 rs
silver

Default

what the hell....that makes sense..becauzes everyone was all like put your FP guage after the FPR, and i was like....that makes no sense...whoo, thanks for clearing that up..my fuel pump will love you for it.
smacksube is offline   Reply With Quote
Old 07-14-2003, 10:09 PM   #4
kaos200
Scooby Guru
 
Member#: 2692
Join Date: Oct 2000
Chapter/Region: SCIC
Location: SoCal
Default

no prob bob
kaos200 is online now   Reply With Quote
Old 07-14-2003, 10:34 PM   #5
WRX 555 STi
Scooby Specialist
 
Member#: 8042
Join Date: Jul 2001
Location: Elmwood Park, IL
Vehicle:
MY00 WRS - '04 WRX
2002 Dragon slayer :)

Default

This is my setup. Vishnu rails and FPR. Make sure you route them the same way i have.


~Anthony.
WRX 555 STi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stock side feed rails with a aftermarket FPR ???? help mojosti Factory 2.5L Turbo Powertrain 6 12-13-2009 02:28 AM
Need some help with my SZ49 with boost falling off at redline.. j87w Factory 2.5L Turbo Powertrain 11 07-24-2007 08:58 PM
Is something wrong with my aftermarket exhuast? BlowDro Newbies & FAQs 19 07-10-2006 04:09 PM
I need help with my 02 Wagon Suspension! Hate my Teins natoli4 Brakes, Steering & Suspension 50 03-23-2006 08:21 PM
I need Help with my install! HELP! mrubino83 Factory 2.0L Turbo Powertrain 4 04-08-2004 01:11 AM


All times are GMT -4. The time now is 09:04 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.