Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > SVX Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Old 04-21-2001, 02:20 PM   #1
KEVINL
Scooby Newbie
 
Member#: 3525
Join Date: Jan 2001
Location: Prescott Az
Vehicle:
2004 Duramax W/500HP
And Want another STi

Post How do you tell if a SVX oil pump is worn out

I think the SVX's is oil pump is worn out. I start it in the morning and makes unpleasant noises for a couple of minutes which I think that it shouldn't take so long the engine sounds great after its running for a couple minutes. What gives?

Thanls in advance
* Registered users of the site do not see these ads.
KEVINL is offline  
Old 04-21-2001, 03:16 PM   #2
kastle
Frank Army
 
Member#: 1457
Join Date: May 2000
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
1999 Outback Sport
Steel Blue Mica

Post

Why don't you ask Robert?
kastle is offline  
Old 04-21-2001, 03:22 PM   #3
KEVINL
Scooby Newbie
 
Member#: 3525
Join Date: Jan 2001
Location: Prescott Az
Vehicle:
2004 Duramax W/500HP
And Want another STi

Post

He says its normal which may be true but I wan't second opinions it just doesn't seem right
KEVINL is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you tell if a WB 02 Sensor is bad? Krang Engine Management & Tuning 3 05-16-2009 10:14 PM
How do you tell if Oil pump is Primed? Turbo Oil Line? Hayaboosted Factory 2.5L Turbo Powertrain 3 06-25-2008 01:55 AM
How Do You Tell if an AFR/O2 Sensor is Broken? williaty Service & Maintenance 4 08-24-2007 08:03 PM
How do you tell if there is an exhaust leak?? silvscorp Factory 2.0L Turbo Powertrain 3 07-21-2003 12:30 PM
How do you tell if your car is running lean? Sub25RSDTown Normally Aspirated Powertrain 7 09-28-2002 01:17 AM


All times are GMT -4. The time now is 03:09 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.