Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-17-2003, 09:02 PM   #1
AWJunkies
Scooby Specialist
 
Member#: 32934
Join Date: Feb 2003
Location: Dallas
Vehicle:
99 2.5RS JDM WRX
silver

Default Need help turbo now sputers and check engine light is on!

I was stoped waiting to make a left and went then stopped and forgot to take out of gear and car died. Check engine light came on. I headed home another 2 blocks and let the car sit without battery hooked up to reset ECU. It worked the check engine light went off when I started it the next day. But when I went on the freeway it turned on again. From then on my turbo sputers. It pumps and jumps. Can somebody please help me trouble shoot this.
* Registered users of the site do not see these ads.
AWJunkies is offline   Reply With Quote
Old 07-17-2003, 11:20 PM   #2
STi-Nismo Dood
Scooby Specialist
 
Member#: 4149
Join Date: Feb 2001
Chapter/Region: SCIC
Location: Frisco/Diego/LosAngeles
Vehicle:
MY93 Impreza 6MT
GC8.6 Aspen White

Default

why don't you list your parts on your kit? maybe that can help us... how long have you been driving with this setup?
STi-Nismo Dood is offline   Reply With Quote
Old 07-18-2003, 01:21 AM   #3
AWJunkies
Scooby Specialist
 
Member#: 32934
Join Date: Feb 2003
Location: Dallas
Vehicle:
99 2.5RS JDM WRX
silver

Default

I have EJ20 JDM swap full complete with tranny, ECU, engine, rear diff, cluster. Everything! TDO5 turbo! all stock with invidia DP. been all on for 300km no problems!
AWJunkies is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My 2002 WRX check engine light is on and is overheating. SUBY1305 Newbies & FAQs 17 01-15-2010 01:26 PM
Went into a ditch now a "rear diff temp" check engine light is on?? bloopsta26 Factory 2.5L Turbo Powertrain 19 01-01-2007 05:03 PM
installed Titek noncatted DP.. now check engine light is on. aznmc16 Factory 2.5L Turbo Powertrain 28 11-06-2006 05:46 PM
help my check engine light is on! Dr. J Normally Aspirated Powertrain 2 06-09-2003 09:14 PM
Need Help-Check Engine light is on AndyHidley Technical Forum Archive 3 05-19-2000 01:35 PM


All times are GMT -4. The time now is 08:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.