Welcome to the North American Subaru Impreza Owners Club Sunday August 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-18-2003, 12:01 AM   #1
boysetsfire
Scooby Specialist
 
Member#: 6218
Join Date: Apr 2001
Chapter/Region: SCIC
Location: Agoura, California
Vehicle:
2001 2.5rs-t
silverthorn metallic

Default Oil leak

I seem to have a lot of oil coating the intake pipe close to the turbo and the turbo itself. I havent felt any loss in power and have not seen any smoke coming out of the exhaust. It seems a decent amount of oil also has been coming out of my bov. Anything this could be or anyone have some ideas of what i can do to see where the oil is coming from? I just drove from california to utah and this is when i noticed the oil. I have pictures but no where to host them.

thanks

-Marc

EDIT:
The kit has been on for about 2 years and about 20,000 miles. This is the first sign of oil leakage/consumption.
* Registered users of the site do not see these ads.

Last edited by boysetsfire; 07-18-2003 at 12:07 AM.
boysetsfire is offline   Reply With Quote
Old 07-18-2003, 06:03 PM   #2
yebokmj
Scooby Specialist
 
Member#: 2213
Join Date: Aug 2000
Chapter/Region: South East
Location: Raymond, NH USA
Vehicle:
1995 Impreza w/EJ257
Brilliant Red

Default Oil=bad

As you know oil that isn't where it's supposed to be is not a good sign so in that interest send your pictures to yebokmj@hotmail.com. Please have them small sized and properly cropped so that my email will except them and I can post them easily for you.
Joshua
yebokmj is offline   Reply With Quote
Old 07-18-2003, 07:57 PM   #3
milkman
Scooby Specialist
 
Member#: 8066
Join Date: Jul 2001
Chapter/Region: MWSOC
Location: Indiana,
Vehicle:
Y2K RSt
Sedona Mars Red Pearl

Default Oil catch Tank?

Do you run one is it full?

What side of the turbo is the oil on?
milkman is offline   Reply With Quote
Old 07-18-2003, 08:03 PM   #4
boysetsfire
Scooby Specialist
 
Member#: 6218
Join Date: Apr 2001
Chapter/Region: SCIC
Location: Agoura, California
Vehicle:
2001 2.5rs-t
silverthorn metallic

Default

No i dont run a catch can. Its on the compressor side on the bottom half and some on the intake pipe closest to the turbo.

-Marc
boysetsfire is offline   Reply With Quote
Old 07-18-2003, 10:10 PM   #5
WRX 555 STi
Scooby Specialist
 
Member#: 8042
Join Date: Jul 2001
Location: Elmwood Park, IL
Vehicle:
MY00 WRS - '04 WRX
2002 Dragon slayer :)

Default

Chances are:
1: The engine is blowing oil in from the valve cover vents to the intake (which will not make sense for it to appear on the compressor)
2:Loose oil line feed fitting nut. Make sure everything is tight man.
3:Maybe you blew a seal on the compressor side and you're leaking oil through the compressor to the intake charge.

Just my opinions.

~Anthony.
WRX 555 STi is offline   Reply With Quote
Old 07-19-2003, 12:14 AM   #6
yebokmj
Scooby Specialist
 
Member#: 2213
Join Date: Aug 2000
Chapter/Region: South East
Location: Raymond, NH USA
Vehicle:
1995 Impreza w/EJ257
Brilliant Red

Default Picture


Joshua
yebokmj is offline   Reply With Quote
Old 07-19-2003, 12:36 AM   #7
Hondaslayer
Purified Dick
Moderator
 
Member#: 4562
Join Date: Feb 2001
Chapter/Region: NWIC
Location: Auburn, WA
Vehicle:
1995 Legacy LSi
1998 Forester, lifted.

Default

Blow-bye,The oil is starting to get past the conector there,

get a catch can.
Hondaslayer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
possible oil leak and radiator leak MachinesWRX Factory 2.0L Turbo Powertrain 7 03-18-2006 07:23 PM
weird oil leak/AC leak? NateDogg Service & Maintenance 2 05-03-2004 04:23 PM
Oil leak just above oil filter Big_Hitter Factory 2.0L Turbo Powertrain 7 02-28-2003 09:57 AM
New Omori Oil temp install and oil leak mhbrown Factory 2.0L Turbo Powertrain 6 01-22-2003 07:10 PM
oil leak from front of engine, oil pump? drftsub Legacy Forum 14 01-06-2003 07:44 PM


All times are GMT -4. The time now is 06:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.