Welcome to the North American Subaru Impreza Owners Club Thursday October 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-20-2003, 12:18 AM   #326
STiBro
Scooby Newbie
 
Member#: 39546
Join Date: Jul 2003
Location: Colorado Springs, CO
Vehicle:
'04 WRX STi
Black/Gold

Default

Quote:
Originally posted by ZenBoy


Just ballparking it - the first shipments started arriving locally around the third week of May, and AFAIK the second shipments were arriving around July 4th. Maybe there was one more in there ... who knows?

Zen
Hmmm...My car was delivered to the dealer June 24th (saw it on the truck heading to the dealer on the freeway as I drove to work that day...kind of cool). So I wonder if it's first allocation or second. P.S. Pinging on 91, no pinging on 94.
* Registered users of the site do not see these ads.
STiBro is offline   Reply With Quote
Old 08-20-2003, 07:21 AM   #327
PocketEmpty
Scooby Newbie
 
Member#: 41925
Join Date: Aug 2003
Default

Anyone here has a dyno chart of a stock car? I'm curious to see what the spike is at 4,000rpm that you mentioned
PocketEmpty is offline   Reply With Quote
Old 08-20-2003, 09:23 AM   #328
davidm_sh
Scooby Specialist
 
Member#: 5994
Join Date: Apr 2001
Location: Fort Collins, CO
Vehicle:
2004 Impreza WRX STi
Java Black

Default

Quote:
Originally posted by PocketEmpty
Anyone here has a dyno chart of a stock car? I'm curious to see what the spike is at 4,000rpm that you mentioned
Goto turboxs.com and read about the 'STi 101 article'.
davidm_sh is offline   Reply With Quote
Old 08-20-2003, 02:04 PM   #329
RichQY
Scooby Specialist
 
Member#: 31948
Join Date: Jan 2003
Location: SoCal
Vehicle:
2004 STi
Aspen White

Default

Quote:
Originally posted by z3coupe
Well, Irvine Subaru just sent my ECU in to New Jersey. No hassles, nothing. So hope to get my car back by Thursday. But I ALSO hope that there is no loss in power
please update after you get it back

and if i may ask. what RPM are you guys knocking on?

and what do you "hear"

i just wanna double check if i am actually pinging rather than some piston noise.

me=paranoid
RichQY is offline   Reply With Quote
Old 08-20-2003, 06:19 PM   #330
all-trubo [STi]
Scooby Newbie
 
Member#: 41738
Join Date: Aug 2003
Chapter/Region: SCIC
Location: rancho cucamonga. ca/so cal
Vehicle:
04 jbp sti
twinscroll

Default

Quote:
Originally posted by z3coupe
Well, Irvine Subaru just sent my ECU in to New Jersey. No hassles, nothing. So hope to get my car back by Thursday. But I ALSO hope that there is no loss in power
yeah i called irvine as well...im bringing mine in on tuesday the 26th...and they say that i get a rental. i should have my car back by thursday, so im relieved.
all-trubo [STi] is offline   Reply With Quote
Old 08-21-2003, 02:07 AM   #331
z3coupe
Scooby Specialist
 
Member#: 13540
Join Date: Dec 2001
Location: Dallas
Vehicle:
2006 MKV GTI
Black

Default

I was getting ping around 4000 rpm, and during various loads.

Will report on how the car feels when I get it back. But I can tell you this! I used to think my old 02 WRX was fast. But now, I keep having to check if the parking brake is on! And that is why I did not need a loaner - am driving the old car for a bit yet. UGH!
z3coupe is offline   Reply With Quote
Old 08-21-2003, 01:40 PM   #332
gills
Scooby Specialist
 
Member#: 11316
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2004 STi
'90 E30 S54 swap project

Default

I'm getting pinging as low as 2300 rpm up to 4000rpm. Anyone else experiencing pinging this low?
gills is offline   Reply With Quote
Old 08-21-2003, 02:20 PM   #333
RichQY
Scooby Specialist
 
Member#: 31948
Join Date: Jan 2003
Location: SoCal
Vehicle:
2004 STi
Aspen White

Default

Quote:
Originally posted by gills
I'm getting pinging as low as 2300 rpm up to 4000rpm. Anyone else experiencing pinging this low?
i do,

very audible in the high 2000 range.. lower if in 6th gear.

seem to go away at 3400 rpm, i ve never reved above 4K.

various load, various throttle position, various fuel..

same sound always come up.
RichQY is offline   Reply With Quote
Old 08-21-2003, 04:00 PM   #334
mfisch
Scooby Newbie
 
Member#: 28591
Join Date: Nov 2002
Default

Quote:
Originally posted by Porter


I think you'll like the results Rich.

hmmmm, it was 2 weeks yesterday that i got my ecu back from SOA

porter, am i supposed to be running 93 octane on the reflashed ecu? 'cause the ping is back with a vengance. seems like with my driving characteristics, 2 weeks is the "learn" time on the ecu.

oh well, back to the dealer...

crap.
mfisch is offline   Reply With Quote
Old 08-21-2003, 04:16 PM   #335
Porter
NASIOC Supporter
 
Member#: 486
Join Date: Nov 1999
Chapter/Region: MAIC
Location: Roanoke, VA
Vehicle:
2004 Forester XT
bug spattered

Default

None of the folks who have had the reflash here have reported a reoccurrence of ping. I'm not sure what to tell you.

Have you dyno'd the car? A tuner should be able to tell you exactly what's going on.

[edit] And yes, you ARE supposed to be using 93 or better octane even after the reflash.

Last edited by Porter; 08-21-2003 at 05:28 PM.
Porter is offline   Reply With Quote
Old 08-21-2003, 05:31 PM   #336
stiski
Scooby Newbie
 
Member#: 34850
Join Date: Apr 2003
Location: NC
Vehicle:
'98 BMW M3
STi SOLD:(

Default Holy toilets batman, your ecu has been reflushed

I just got mine back from the dealer and so far so good (fingers crossed). I drove it today in 90+ heat with the ac on and no pinging. It would always ping around 4000 in that situation. I dropped it off on monday and got it back today. Pretty speedy. I cannot notice any power loss if there is any. The real test will be a nice cool humid evening to see how it feels in optiamal conditions. My car feels super strong when it is cool out. If yours pings get it reflashed.
stiski is offline   Reply With Quote
Old 08-21-2003, 08:43 PM   #337
mfisch
Scooby Newbie
 
Member#: 28591
Join Date: Nov 2002
Default

Quote:
Originally posted by Porter
None of the folks who have had the reflash here have reported a reoccurrence of ping. I'm not sure what to tell you.

Have you dyno'd the car? A tuner should be able to tell you exactly what's going on.

[edit] And yes, you ARE supposed to be using 93 or better octane even after the reflash.
yuda' man -

not particularly happy to be the first to have to report it, and may not have to - i've been running 91 octane.

really appreciate your input as the local service rep did not know if 93 was still required or not.

back to roll my own gas.

planning on dynoing the vehicle on the 30th (curious about the reflash) - there is a thread in the southwest forum area. hope they have gas up there by then.

soooo, i reckon the ecu has till then to relearn on the 93/94 homegrown. it took about 2 weeks before it started detonating on the 93/94 stuff last time.

again, thank you for the timely information.
mfisch is offline   Reply With Quote
Old 08-22-2003, 03:18 AM   #338
z3coupe
Scooby Specialist
 
Member#: 13540
Join Date: Dec 2001
Location: Dallas
Vehicle:
2006 MKV GTI
Black

Default

I just got my car back tonight from Irvine Subaru. They were AWESOME in getting the car back to me with minimal downtime.

Not having a dyno in my backyard, I can only say that it does not feel any different in power, yet NO PINGING! Of course, though, I had been driving my old WRX while waiting, and anything about the STi feels better. NO WONDER WHY most dealers won't give test drives in them! Cause a regular WRX pales in comparison.
z3coupe is offline   Reply With Quote
Old 08-22-2003, 09:02 PM   #339
all-trubo [STi]
Scooby Newbie
 
Member#: 41738
Join Date: Aug 2003
Chapter/Region: SCIC
Location: rancho cucamonga. ca/so cal
Vehicle:
04 jbp sti
twinscroll

Default

Quote:
Originally posted by Porter
None of the folks who have had the reflash here have reported a reoccurrence of ping. I'm not sure what to tell you.

Have you dyno'd the car? A tuner should be able to tell you exactly what's going on.

[edit] And yes, you ARE supposed to be using 93 or better octane even after the reflash.
well, i dont have the means to run 93 octane, living in cali i have 91. if you know of a substitutable octane booster or what not to get me to 93, then ill do it.
i just have a question...will subaru not do the reflash if i have an aftermarket intake on the car??about a week ago i put in my HKS megaflow on and since i set up my appt to get my reflash done, i wanna get it done without and headache. so will i beable to get this done with the intake in there or should i replace it with the original?
all-trubo [STi] is offline   Reply With Quote
Old 08-22-2003, 11:52 PM   #340
gills
Scooby Specialist
 
Member#: 11316
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2004 STi
'90 E30 S54 swap project

Default

Quote:
Originally posted by aLL-tRuBo [STi]

well, i dont have the means to run 93 octane, living in cali i have 91. if you know of a substitutable octane booster or what not to get me to 93, then ill do it.
i just have a question...will subaru not do the reflash if i have an aftermarket intake on the car??about a week ago i put in my HKS megaflow on and since i set up my appt to get my reflash done, i wanna get it done without and headache. so will i beable to get this done with the intake in there or should i replace it with the original?
As long as your dealer is cool with modifications and Subaru doesn't send a rep down to check the car out, you should be ok.

Tom
gills is offline   Reply With Quote
Old 08-23-2003, 10:18 AM   #341
CHARDWAY
Scooby Newbie
 
Member#: 40713
Join Date: Jul 2003
Location: LaGrange, KY
Vehicle:
2003 WRX
Blue

Default

I'm thinking about trading my 03 WRX on an 04 STi that just arrived at the dealer yesterday. Left a deposit and have until Monday to decide for sure. Are the most recently manufactured STi's pinging?

VIN is JF1GD70624L513809.

Anybody recently buy an STi that didn't need the reflash? Does anyone know if the newer ones got the reflash in Japan?

Thanks!
CHARDWAY is offline   Reply With Quote
Old 08-23-2003, 03:57 PM   #342
z3coupe
Scooby Specialist
 
Member#: 13540
Join Date: Dec 2001
Location: Dallas
Vehicle:
2006 MKV GTI
Black

Default

Chard, trust me - just gt the STi!!!!!!! My WRX was not stock (though never touched the engine or boost due to SCCA rules) and many who drove or rode in it thought it was fast. Well, after having the STi only for a FEW DAYS, then having to drive my old one while it got the reflash . . . . . . I kept looking at the parking brake thinking I had left it on! So if a reflash is all that is holding you back, DUH! Just get it done and don't worry. You will enjoy the STi the rest of the time. Huge grins while driving included.
z3coupe is offline   Reply With Quote
Old 08-23-2003, 05:32 PM   #343
all-trubo [STi]
Scooby Newbie
 
Member#: 41738
Join Date: Aug 2003
Chapter/Region: SCIC
Location: rancho cucamonga. ca/so cal
Vehicle:
04 jbp sti
twinscroll

Default

Quote:
Originally posted by gills


As long as your dealer is cool with modifications and Subaru doesn't send a rep down to check the car out, you should be ok.

Tom
well i really dont want to take that chance...so ill put the stock intake back on. and for anyone else who brought their car to irvine subaru, did you have any mods or anything??thats where im taking mine. and if i can save myself the trouble of switching the intake than i will.
all-trubo [STi] is offline   Reply With Quote
Old 08-23-2003, 07:01 PM   #344
z3coupe
Scooby Specialist
 
Member#: 13540
Join Date: Dec 2001
Location: Dallas
Vehicle:
2006 MKV GTI
Black

Default

Mine is stock, and I will be keeping it that way this time (SCCA reason LOL).
z3coupe is offline   Reply With Quote
Old 08-23-2003, 09:46 PM   #345
z
Scooby Specialist
 
Member#: 41762
Join Date: Aug 2003
Chapter/Region: International
Location: House of Pancakes
Vehicle:
04 STi
CT-DE-FL rinse+repeat

Default

I just got mine last week and haven't had a problem with pinging at all. Feels like 300hp to my butt dyno. 950 miles so far.
Used Sunoco 94, Mobil 93, Shell 93 - It's all good


GET IT!!!!!!!!!!!
z is offline   Reply With Quote
Old 08-24-2003, 12:44 AM   #346
horshack
Scooby Specialist
 
Member#: 19236
Join Date: May 2002
Vehicle:
Axis GT35/40R STi
Not back yet

Default

Quote:
Originally posted by zavigm
I just got mine last week and haven't had a problem with pinging at all. Feels like 300hp to my butt dyno. 950 miles so far.
Used Sunoco 94, Mobil 93, Shell 93 - It's all good


GET IT!!!!!!!!!!!

Where in DE are you?

I grew up there and am making a trip back for Pumkin Chunkin in Nov.
horshack is offline   Reply With Quote
Old 08-24-2003, 06:35 PM   #347
z
Scooby Specialist
 
Member#: 41762
Join Date: Aug 2003
Chapter/Region: International
Location: House of Pancakes
Vehicle:
04 STi
CT-DE-FL rinse+repeat

Default

Northern Delaware - Greenville.

Just moved here a couple years ago from Cali.

Connecticut originally.

Saw that Pumpkin Chunkin on Discovery channel...i've gotta check it out!

launch a pumpkin almost a mile out of a cannon!? crazy stuff.
z
z is offline   Reply With Quote
Old 08-24-2003, 10:02 PM   #348
horshack
Scooby Specialist
 
Member#: 19236
Join Date: May 2002
Vehicle:
Axis GT35/40R STi
Not back yet

Default

Quote:
Originally posted by zavigm
Northern Delaware - Greenville.

Just moved here a couple years ago from Cali.

Connecticut originally.

Saw that Pumpkin Chunkin on Discovery channel...i've gotta check it out!

launch a pumpkin almost a mile out of a cannon!? crazy stuff.
z
Sweet!!!!!

My family lives in Dover, I fly in Sat night Nov 1st, going to the finals on Sun Nov 2nd.

Will be in DE for the week. If you want to get up, PM me, I have a lot of automotive connections there still.
horshack is offline   Reply With Quote
Old 08-26-2003, 09:18 PM   #349
ANZAC_1915
Moderator
 
Member#: 456
Join Date: Oct 1999
Chapter/Region: NWIC
Location: Redmond, WA, USA
Vehicle:
2008 Forester XT
Steel Gray Metallic

Default

I got my car back today (after vacation) and no pinging, and it feels fine so far.

Glenn
ANZAC_1915 is offline   Reply With Quote
Old 08-27-2003, 03:18 AM   #350
Bimmerod
Scooby Newbie
 
Member#: 14761
Join Date: Jan 2002
Location: SoCal
Vehicle:
04 STi
Bye Bye EVO

Default Irvine Subaru is Mod friendly

Quote:
Originally posted by aLL-tRuBo [STi]


well i really dont want to take that chance...so ill put the stock intake back on. and for anyone else who brought their car to irvine subaru, did you have any mods or anything??thats where im taking mine. and if i can save myself the trouble of switching the intake than i will.

You will not have any issues with Irvine Subaru. They are very kewl about mods. My 02 had intake, exhaust, IC hoses when it got repaired for the clutch shudder prob. Just talk to Albert, he'll take care of ya.

Bimmerod
Bimmerod is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
AccessPort v2.0 Update Released mike91401 South West Impreza Club Forum -- SWIC 10 02-08-2007 04:30 PM
04 STi ECU reflash confirmed (ping fix)??? stealitall Engine Management & Tuning 10 12-12-2006 05:04 PM
WTB 02-03 STi I/C splitter and STi Aspen white hood scoop.Also need 04 STi ecm Hondaslayer Private 'Wanted' Classifieds 8 07-30-2005 09:58 PM
Anyone local have an STi ecm lying around? Hondaslayer Mid West Subaru Owners Club Forum -- MWSOC 3 04-01-2005 09:14 PM
Question for USDM STI ECM experts NMLegacy Subaru Conversions 3 11-16-2004 07:57 PM


All times are GMT -4. The time now is 12:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.