Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-24-2003, 08:22 PM   #1
IA Performance
NASIOC Vendor
 
Member#: 25194
Join Date: Sep 2002
Chapter/Region: RMIC
Location: Boulder, CO
Vehicle:
2008 Forester XT 5mt
Dark Gray

Default Am I crazy, coolant replacement Q

I can do every single other drainage neatly and without making a mess. When it comes to the coolant I end up with the green sea across my garage floor. I've emptied it 2 different ways. One is via the factory drain spout on the passenger side. The other way is to pull of the hose at the thermastat elbow pipe. Both seem to generate about the same mess. Not a big problem there.

The problem is always with draining all coolant from the motor. The second the thermastat comes out you better WATCH out I was able to capture most of it in the bin, but am I nutz. Am I missing a completely easy way to drain it other than prying out the old thermastat?
* Registered users of the site do not see these ads.
IA Performance is offline   Reply With Quote
Old 07-24-2003, 08:44 PM   #2
SJwrx
Scooby Specialist
 
Member#: 14970
Join Date: Feb 2002
Chapter/Region: BAIC
Location: San Jose, CA
Vehicle:
1997 GF8
multi

Default

my coolant is orange.... should I be conerned?

Rich
SJwrx is offline   Reply With Quote
Old 07-25-2003, 09:59 AM   #3
vile
Scooby Specialist
 
Member#: 32371
Join Date: Jan 2003
Location: formerly known as mem. # 10615
Vehicle:
'02 t-rex wagon
platinum

Default

yeah, if you're coolant is orange, you should be changing that puppy out, probably rusted something.....might wanna do you water pump too, hope that hasn't corroded

as for draining.....i used the drain plug at the radiator. before i open the drain plug, connect a piece of hose to it, so that you can direct it into the drain pan.......one complaint i had was, that drain plug is so darn small, takes forever to drain completely.

if you want it to drain quickly, you have to pretty much remove the plug completely, but then you'll have a mess, unless you want to take off the sub-frame assembly
vile is offline   Reply With Quote
Old 07-25-2003, 01:24 PM   #4
armand1
Scooby Guru
 
Member#: 10309
Join Date: Sep 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
'02 OBS 2-tone!
'95 Montego Miata

Default

I picked up a $2 small funnel from my auto parts store and shoved it in around the radiator drain. That got rid of almost all of the spillage.
Also, I think it's too much trouble to try to dry the entire cooling system (not just the radiator), so I just drain the radiator *every* year and refill w/50:50 coolant, figuring that doing that twice over two years is about the same as draining the whole system once every two years.
armand1 is offline   Reply With Quote
Old 07-25-2003, 06:07 PM   #5
IA Performance
NASIOC Vendor
 
Member#: 25194
Join Date: Sep 2002
Chapter/Region: RMIC
Location: Boulder, CO
Vehicle:
2008 Forester XT 5mt
Dark Gray

Default

Gotcha. I've drained a motor twice and both times needed to shower afterwards. I guess it is just the luck of the draw. A tube of some sort to go over teh thermastat as you pull it out would probably help.
IA Performance is offline   Reply With Quote
Old 07-25-2003, 09:09 PM   #6
Albert
Scooby Specialist
 
Member#: 3288
Join Date: Dec 2000
Location: San Diego, CA. USA
Vehicle:
1998 Impreza 2.5RS
Rally Blue Pearl

Default

Quote:
Originally posted by SJwrx
my coolant is orange.... should I be conerned?

Rich
Don't worry yet....

Mine is also orange but that because I purposely fliushed and filled with Prestone's extended life coolant.

-Mileage?
-Are you the original owner?
-If over 30k mls do you know if the coolant was replaced during the 30k mls service?
Albert is offline   Reply With Quote
Old 07-25-2003, 10:00 PM   #7
SJwrx
Scooby Specialist
 
Member#: 14970
Join Date: Feb 2002
Chapter/Region: BAIC
Location: San Jose, CA
Vehicle:
1997 GF8
multi

Default

Quote:
Originally posted by Albert
-Mileage?
-Are you the original owner?
-If over 30k mls do you know if the coolant was replaced during the 30k mls service?
Since 15K, but still running it. Its out this weekend
Yes
No idea...

Rich
SJwrx is offline   Reply With Quote
Old 07-25-2003, 10:24 PM   #8
WRallyBlue02
Scooby Newbie
 
Member#: 20157
Join Date: Jun 2002
Location: Westerville, OH
Vehicle:
0503 WRX STI & 03Wag
Asp White, Plat Silv Met

Default

Quote:
Originally posted by vile
yeah, if you're coolant is orange, you should be changing that puppy out, probably rusted something.....might wanna do you water pump too, hope that hasn't corroded
Bwahahahahahahahah! Have you changed your boost fluid yet? what color is that? Bwahahahahah!
WRallyBlue02 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
('93-'01) Am I crazy???? AudiGuy Impreza Forum 4 05-09-2001 08:16 PM
('93-'01) Am I crazy, or just dumb? RS-LOVER Impreza Forum 2 04-06-2001 05:06 AM
Am I crazy, or just dumb? RS-LOVER Normally Aspirated Powertrain 7 03-06-2001 09:22 AM
Am I Crazy? (kinda long) skyliner33v General Forum Archive 2 01-10-2001 05:53 AM
Bought Nitrous, Am I crazy? Eric SS Technical Forum Archive 6 08-02-2000 11:00 AM


All times are GMT -4. The time now is 10:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.