Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-01-2003, 10:31 PM   #1
Brian Broz
Scooby Specialist
 
Member#: 13783
Join Date: Dec 2001
Vehicle:
2008 2.5i Slow
WRB

Default Tons of Stupid UTEC Questions from a dumb loser!

Hi everyone,
I am now (finally) a full stage 4 setup with the APS SR40 (catless). My other engine mods are GFB BOV (set to 100% Vent now...just changed from 50/50) and Perrin Foam filter. I am currently running launch control w/fuel cut...but am gonna remove it this weekend. Too many POPS and backfires!!!
I'm the first to admit I'm a real noob, but I get knock on every map I've downloaded. I am running 94 octane, as well. Could it be the ECU adjusting for the STi injectors I put in last weekend?
The TXS base stage 4 map feels kinda slow to spool, but doen't knock as much...I have also used the Stage 4 19psi (closed loop) map for the 1820 (from WRXhackers)...and man it pulls a LOT harder and quicker (what I think the car should feel like)...It's unbelieveable!, but I get knock at 5200-6000 RPM! What is the best way to modify (the latter) map? Turn down the boost with a laptop (the ABC is already a 1/2 turn out) ? Or adjust fuel/timing (don't know what I'm doing!!)
Or is the best to work from the base stage 4 and adjust from there?
Anyone wlse running an SR40 or could help give me some tips, please feel free to comment! Not that it matters, but I have IC hoses and Perrin Shortram coming soon.
Should I try taking off the BOV (or back to 50/50) and take off launch control? Could those be part of the reason? Oh, and no 4Wheel dyno within thousands of miles :-(
Thanks again for any help!

Cheers

Broz
03 WRX Spec R1
TXS Stage 4 SR40
* Registered users of the site do not see these ads.
Brian Broz is offline   Reply With Quote
Old 08-01-2003, 10:51 PM   #2
ScreaminFast
Scooby Specialist
 
Member#: 24399
Join Date: Sep 2002
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2003 White WRX
89 240 / 90 240

Default

not to steal your thread, but what is the "spec R1" model of the WRX?
ScreaminFast is offline   Reply With Quote
Old 08-01-2003, 11:05 PM   #3
Brian Broz
Scooby Specialist
 
Member#: 13783
Join Date: Dec 2001
Vehicle:
2008 2.5i Slow
WRB

Default

120Units in Canada. Sonic Yellow limited paint. Both BBS RK17s w/S03s and Stock 16s w/RE92s. SpecR1 badging on rear and interior WOOO...(#21/120) Momo Air Race Shiftknob WOOO..."upgraded audio system"...fog light covers and I think that's it :-)
Once I find a web host I'll post some pics!
Cheers, now back to the topic at hand!!!


Broz
Brian Broz is offline   Reply With Quote
Old 08-02-2003, 12:38 AM   #4
JayC
Scooby Newbie
 
Member#: 32144
Join Date: Jan 2003
Location: Garner, NC
Vehicle:
2003 Impreza WRX
Sonic Yellow

Default

My friend in Toronto has #1. Bought it from a dealership in London.
JayC is offline   Reply With Quote
Old 08-02-2003, 11:49 AM   #5
Brian Broz
Scooby Specialist
 
Member#: 13783
Join Date: Dec 2001
Vehicle:
2008 2.5i Slow
WRB

Default

bump...anyone?
Brian Broz is offline   Reply With Quote
Old 08-02-2003, 01:43 PM   #6
motoxphil
Scooby Newbie
 
Member#: 5094
Join Date: Mar 2001
Location: Gaithersburg, MD, usa
Vehicle:
2002
11.96, 1.64, 115mph!

Default

Brian,

That particular turbo is very slow spooling but you should try starting with the STG4FMI map (I know you don't an FMI but trust me).

Your other option is to reduce timing at the load sites you knocked in while running the 1820 map. Run data logger #1 and record the knock event at 52-6K. The UTEC will tell you what load site you're in so you can tune out the knock by reducing timing. You may also need to add fuel but you will need at least an egt gauge to determine whether or not you need to add fuel or pull out timing.

Good luck.

Phil
TurboXS
motoxphil is offline   Reply With Quote
Old 08-02-2003, 05:05 PM   #7
Brian Broz
Scooby Specialist
 
Member#: 13783
Join Date: Dec 2001
Vehicle:
2008 2.5i Slow
WRB

Default

Ok Phil,
Thanks...the FMIC Closed Loop map works great! Much better now!!! (Of course I remembered to change the UTEC to closed loop mode)
It boosts to 15PSI in 1st 2nd and 3rd bang on (with the abc out 1 turn)...is it ok to turn the ABC out a few more turns until I start playing with boost levels on the UTEC? I heard this may be bad (PTFB?)
Also with the SR40 running catless, would you suggest changing the boost gain from 50 down to 42 or so? The car spools quicker with the FMIC map (than stock stg4), but I think it's capable of 15psi by 3600or so (now it's just under or around 4000rpm)
Any tips (from anyone) are appreciated.
Many thanks,

Brian Broz
Brian Broz is offline   Reply With Quote
Old 08-02-2003, 05:17 PM   #8
Mildmanneredman
Scooby Newbie
 
Member#: 29962
Join Date: Nov 2002
Location: Tucson
Default

You probably want the abc turned out 2-3 turns. That's what most people have.
Mildmanneredman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OK, I'm just dumb...stupid internet question inside. ScubaruImpreza05 Off-Topic 16 04-17-2010 12:56 PM
stupid noob question from a GOONru the real suby dude Interior & Exterior Modification 8 08-11-2009 04:03 PM
Pros/Cons of a WRX. Questions from a newb. prokhy007 Newbies & FAQs 57 09-07-2006 11:48 PM
Stupid DVR question from somebody who knows nothing about them HoRo1 Off-Topic 2 08-20-2006 03:52 PM
A ton of new pics up from Japan supermarkus North West Impreza Club Forum -- NWIC 5 05-26-2005 12:43 AM


All times are GMT -4. The time now is 03:18 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.