Welcome to the North American Subaru Impreza Owners Club Friday April 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-04-2003, 01:31 PM   #1
joltdudeuc
Scooby Specialist
 
Member#: 6119
Join Date: Apr 2001
Chapter/Region: BAIC
Location: Union City, CA
Vehicle:
1999 GM6
RBP

Default Kick Down is Hesitant/Slow after MAF recall?

So i went in for the MAF recall a few months ago, and got my MAF replaced. (which i've done before already, but this is a new part number)

Well, i noticed one change that day when i drove home, If i'm driving and i coming to a stop light, i put it in nuetral and cruise to the stop, my car keeps the revs up at about 1500, until, i come to a COMPLETE stop, and then it drops to 750. It's really weird. I thought maybe this was something that the ECU and MAF take careof?

I don't have Cruise Control.

Is this something you 99 guys are getting? am i having a freak of nature car here?

Thanks,

-Gagan
* Registered users of the site do not see these ads.
joltdudeuc is offline   Reply With Quote
Old 08-04-2003, 06:16 PM   #2
DarkScoobie
Scooby Newbie
 
Member#: 39550
Join Date: Jul 2003
Location: Ohio
Vehicle:
2001 25RS
Black

Default

My MY01 2.5 does something similar. When the engine is cold and it's cold outside (40deg or less) the engine doesn't like loosing speed. I have watched it sit at 3K for like 2 minuts before it started dropping. It has done this before and after I had the ECU recall performed.

And I think that it did seem to drop when I stopped, or at least hit the breaks.

Don't know the cause or a fix, just thought you might want to know you're not alone.
DarkScoobie is offline   Reply With Quote
Old 08-04-2003, 09:19 PM   #3
joltdudeuc
Scooby Specialist
 
Member#: 6119
Join Date: Apr 2001
Chapter/Region: BAIC
Location: Union City, CA
Vehicle:
1999 GM6
RBP

Default

Yeah, it just now seems wierd to me...

when cold, then engine will rev that high, all cold engines like ours do that to warm up. However, once warm it won't hold revs THAT high. However, my car does hold them to 1500, until i come to a stop.. i've coasted at like 1mph for 30 ft, and it was at 1500rpm, and as soon i stop, it comes down...

-Gagan
joltdudeuc is offline   Reply With Quote
Old 08-04-2003, 10:35 PM   #4
kasio
Scooby Newbie
 
Member#: 6489
Join Date: May 2001
Location: 510-Bay-Area
Vehicle:
01' GM6
Black

Default

Sorry can't help ya out here Gagan, but you could goto Carlsen and let CKevin-the master tech take look at ur sub. It will be sure worth the 2dollars bridge toll fee

-Jun
P.S-What happen to ur scooby specialist badge? haha... Hey, still wanna buy my rear differential protector? Shoot me back...
kasio is offline   Reply With Quote
Old 08-05-2003, 02:37 AM   #5
Ken
NASIOC Supporter
 
Member#: 34
Join Date: Jun 1999
Chapter/Region: VIC
Location: Burnaby, BC Canada
Vehicle:
2005 WRX STi
World Rally Blue

Default

I've had that happen, even on hot days. Don't know what it could be, but after I blip the throttle it seems to behave again. I don't recall it happened before I got the MAF replaced.
Ken is online now   Reply With Quote
Old 08-05-2003, 10:31 AM   #6
joltdudeuc
Scooby Specialist
 
Member#: 6119
Join Date: Apr 2001
Chapter/Region: BAIC
Location: Union City, CA
Vehicle:
1999 GM6
RBP

Default

Hmm, so i'm definitly not alone.

It's doesn't seem to bother the engine, and it seems that it's a new thing with the MAF recall.

-Gagan
joltdudeuc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Knocking on throttle down and lift after MAF scaling Fongers Open Source Reflashes 2 01-04-2009 06:17 PM
Car is acting funny after messing with MAF bendavi17 Factory 2.0L Turbo Powertrain 53 12-11-2008 03:21 PM
hesitation gone after ecm reprogram/recall Rick G Normally Aspirated Powertrain 2 09-01-2002 09:59 PM
'99 MAF Recall!! SCOOBER Normally Aspirated Powertrain 35 07-16-2002 05:16 PM
Strong rumor: MY99 MAF recall Fred Zaplitny Normally Aspirated Powertrain 26 07-10-2002 10:03 PM


All times are GMT -4. The time now is 06:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.