Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > STi Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Old 08-11-2003, 02:45 PM   #1
brunetmj
Scooby Specialist
 
Member#: 8023
Join Date: Jul 2001
Location: Way-upstate , NY
Vehicle:
2004 2.5 RS

Default Air conditioner

Today was the first time I used the air conditioner in the STI having previously driven the WRX . Unlike the WRX , who’s performance decreased dramatically , I noticed no change in car performance . It also seemed the blower motor is stronger. Is it just my imagination?
* Registered users of the site do not see these ads.
brunetmj is offline  
Old 08-11-2003, 03:24 PM   #2
ANZAC_1915
Moderator
 
Member#: 456
Join Date: Oct 1999
Chapter/Region: NWIC
Location: Redmond, WA, USA
Vehicle:
2008 Forester XT
Steel Gray Metallic

Default

The STi has a lot more torque at a lower RPM than the WRX, so I assume the AC load is a drop in the bucket.

Dunno about the blower motor, but I will say the semi-auto climate system is sweet --- it should be on all US high end models.
ANZAC_1915 is offline  
Old 08-11-2003, 03:26 PM   #3
STI 2 NV
Scooby Specialist
 
Member#: 31748
Join Date: Jan 2003
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
'15 WRB WRX

Default

i've actually noticed quite a bit of power loss with the a/c on.
STI 2 NV is offline  
Old 08-11-2003, 03:59 PM   #4
brunetmj
Scooby Specialist
 
Member#: 8023
Join Date: Jul 2001
Location: Way-upstate , NY
Vehicle:
2004 2.5 RS

Default

Quote:
i've actually noticed quite a bit of power loss with the a/c on.
At what speeds have you noticed the loss? I shifted through the gears up to 70 and did not feel any significant loss. I am
comparing it to the WRX where the difference was profound so I may not notice any small change.
brunetmj is offline  
Old 08-11-2003, 04:12 PM   #5
STI 2 NV
Scooby Specialist
 
Member#: 31748
Join Date: Jan 2003
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
'15 WRB WRX

Default

throughout all gears, but especially 1st-3rd or 4th.
STI 2 NV is offline  
Old 08-11-2003, 06:51 PM   #6
happasaiyan
Scooby Specialist
 
Member#: 37731
Join Date: Jun 2003
Chapter/Region: MWSOC
Location: Rolling Meadows, IL
Default

rpms drop like a brick with the a/c on. you better shift quick when its on...and even faster when the compressor kicks in.
happasaiyan is offline  
Old 08-11-2003, 11:57 PM   #7
TR11
Scooby Newbie
 
Member#: 35784
Join Date: Apr 2003
Location: Ontario Canada
Default

i was under the impression that the ecu disengages the ac when at WOT
TR11 is offline  
Old 08-12-2003, 11:28 AM   #8
MKIVSupra
Scooby Newbie
 
Member#: 4441
Join Date: Feb 2001
Chapter/Region: MWSOC
Location: Wheeling, IL
Vehicle:
2004 WRX STi
WRB and Gold

Default

You are correct. I believe it says so in the owner's manual. I even notice warmer air for a second coming out of the vents after I hammer on it.
MKIVSupra is offline  
Old 08-12-2003, 04:32 PM   #9
Monsito
Scooby Specialist
 
Member#: 40581
Join Date: Jul 2003
Chapter/Region: MWSOC
Location: Chicago
Vehicle:
04 STi
Blue

Default

Maybe something is wrong with your STi. The AC is supposed to shut down during aggressive driving. I've never had any complaints of power loss, and I beat the crap out of mine with the AC on all the time.
Monsito is offline  
Old 08-12-2003, 04:40 PM   #10
darthdiggler
Scooby Newbie
 
Member#: 23251
Join Date: Aug 2002
Vehicle:
2004 STi
silver

Default

Have him do WOT runs blindfolded to see if he can guess if the AC on on or off.


Last edited by darthdiggler; 08-12-2003 at 04:48 PM.
darthdiggler is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
air conditioner problem vvk Service & Maintenance 3 04-18-2002 12:58 PM
front mount i/c and air conditioner o00o Factory 2.0L Turbo Powertrain 2 01-22-2002 08:39 AM
('93-'01) air conditioner spits smoke! superwagon woman Impreza Forum 17 09-18-2001 11:35 AM
('93-'01) rally racing v. air conditioner condenser and radiator Damon Impreza Forum 4 06-01-2001 02:52 PM
help! Water from air conditioner? gumball Technical Forum Archive 6 09-05-2000 12:48 AM


All times are GMT -4. The time now is 08:12 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.