Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-21-2001, 04:10 PM   #1
Rich L
Scooby Specialist
 
Member#: 961
Join Date: Feb 2000
Chapter/Region: Tri-State
Location: near Atco(NJ) 13.566@100.64-
Vehicle:
1999 RS-Tw/ CobraMAF
Custom Rallispec kit/IC#1

Post Help: Please post your Tranny/Turbo problems or lack of problems!

Please briefly (or not so briefly) discribe what happend and perhaps your opinion on what went wrong.

I think that most ppl think... if you have a turbo... then you will have tranny problems. Can anyone confirm or deny this?
* Registered users of the site do not see these ads.
Rich L is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2.5rst link really cold start or lack of 25rstautoxr Engine Management & Tuning 7 01-13-2004 08:46 PM
Please post your experiences with Moriss Dampers...looking for good or bad! Sean Brakes, Steering & Suspension 3 08-22-2003 02:22 PM
RS Owners. Post your Tranny/Clutch problems. munkis Transmission (AT/MT) & Driveline 3 09-25-2002 09:03 AM
Dyno day results.. or lack of... crazyhorse South East Region Forum 7 09-16-2002 03:56 PM
Please post your pics of MY98 Rally Blue 2.5RS...! Loki Member's Car Gallery 6 04-13-2001 06:18 AM


All times are GMT -4. The time now is 09:05 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.