Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > STi Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Old 08-14-2003, 09:02 PM   #1
hatchy
Scooby Specialist
 
Member#: 36852
Join Date: May 2003
Location: North West
Vehicle:
2004 STI

Default 2 different ECUs for STIs?

I've heard that there are 2 different ECUs for the US STI. Not sure what the difference is, but apparently there is enough of a difference that it breaks some OBD functions. Does anyone know if this is true? Porter? Glen? AZ? Anyone?
* Registered users of the site do not see these ads.
hatchy is offline  
Old 08-15-2003, 02:07 PM   #2
Austin
Scooby Guru
 
Member#: 7089
Join Date: May 2001
Chapter/Region: NWIC
Location: Western Wa
Default Re: 2 different ECUs for STIs?

Quote:
Originally posted by hatchy
it breaks some OBD functions
Explain this further please.
Austin is offline  
Old 08-15-2003, 04:49 PM   #3
hatchy
Scooby Specialist
 
Member#: 36852
Join Date: May 2003
Location: North West
Vehicle:
2004 STI

Default

Can't read some CEL, but is able to clear it. Also affects the flashing cruise control light. I have a SCES installed, and when I had problems with my O2 sensor, the SCES was not able to read the CEL, but could clear it. It also caused the ECU *not* to throw the flashing cruise control light.

They said it was because there are 2 different ECUs on the STI, and I happen to have the "other" one.
hatchy is offline  
Old 08-15-2003, 06:18 PM   #4
Austin
Scooby Guru
 
Member#: 7089
Join Date: May 2001
Chapter/Region: NWIC
Location: Western Wa
Default

Quote:
Originally posted by hatchy
They said it was because there are 2 different ECUs on the STI, and I happen to have the "other" one.
"They" being the manufacturers of SECS?
Austin is offline  
Old 08-15-2003, 07:06 PM   #5
hatchy
Scooby Specialist
 
Member#: 36852
Join Date: May 2003
Location: North West
Vehicle:
2004 STI

Default

yes
hatchy is offline  
Old 08-15-2003, 09:17 PM   #6
Nivek-CA
Scooby Specialist
 
Member#: 41415
Join Date: Aug 2003
Default

Definitely in on this thread, bump!
Nivek-CA is offline  
Old 08-15-2003, 10:51 PM   #7
hatchy
Scooby Specialist
 
Member#: 36852
Join Date: May 2003
Location: North West
Vehicle:
2004 STI

Default

I am wondering if this is true because my car almost does not ping. I've only heard it ping 2 or 3 times, after driving for 40 minutes, parking in the hot sun for an hour, and then restart it for a quick drive. It would ping lightly until I've covered about an 1/2 mile of road, which I assume is the amount of time it requires the IC to cool down. After that 1/2, I can't get it to ping again. I am on 91 octane fuel at near sea level during 90-95F days.

Some of the people in my area, running on the same gas, ping all the time. Do we just have different ECUs?
hatchy is offline  
Old 08-16-2003, 12:17 AM   #8
Nivek-CA
Scooby Specialist
 
Member#: 41415
Join Date: Aug 2003
Default

A knowledgeable subaru user mentiond this in one his postings:

http://forums.nasioc.com/forums/show...&pagenumber=13
Nivek-CA is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Different Tires for STI Mike Burke Tire & Wheel 68 10-28-2005 01:05 AM
2 More Element ECUs for STi including 05 model in STOCK! WorldOne Engine/Power/Exhaust 1 03-07-2005 06:06 PM
ECUs for STI Engine swaps JakeInKY Subaru Conversions 4 01-10-2005 12:14 AM
FS: 2.5RS mudflaps for STI vapore0n Private 'For Sale' Classifieds 6 07-20-2004 12:09 PM
Are there 2 different blocks for the EJ22 motor? Young_Legacy_driver Newbies & FAQs 2 04-04-2004 11:26 AM


All times are GMT -4. The time now is 12:46 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.