Welcome to the North American Subaru Impreza Owners Club Wednesday June 29, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-21-2001, 09:40 PM   #1
TARMAC
Scooby Newbie
 
Member#: 5816
Join Date: Apr 2001
Location: USA
Vehicle:
02 WRX

Have a Nice Day? Blitz DSBC

Anyone running one of these in their WRX? Mine is make alot of noise. Where did you mount the solenoid box?

Going to install a fuel pressure riser.
* Registered users of the site do not see these ads.
TARMAC is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-21-2001, 10:36 PM   #2
BADWRX
Scooby Specialist
 
Member#: 3792
Join Date: Jan 2001
Vehicle:
2002 6MT almost GDB

Post

DeliciousSpeed is running one. I do not know of any issues exept for the 15 lbs of boost being to much(High EG temps). I think that you have a damn good unit there. I think that the dual solonoid is the best. I really want the Apex i avcr, but it does not have the DS unit. I hope that you are able to work out your problems.
SACTOWNREXMAN

[This message has been edited by SACTOWNREXMAN (edited April 21, 2001).]
BADWRX is offline   Reply With Quote
Old 04-22-2001, 04:59 AM   #3
DeliciouSpeed
Scooby Specialist
 
Member#: 3389
Join Date: Dec 2000
Location: ContraCosta, Ca
Vehicle:
07 STImpreza
Satin

Post

Yeah I have one, the solenoid is a little on the load side, clicking. Its the valve opening and closing. Remember there are two,the open and close fast. The lower the boost there more they will click. I am running .95bar 14psi. Are you totally stock? or do you have an intake mod? I can give you my settings.

Ken
DeliciouSpeed is offline   Reply With Quote
Old 04-22-2001, 11:43 AM   #4
TARMAC
Scooby Newbie
 
Member#: 5816
Join Date: Apr 2001
Location: USA
Vehicle:
02 WRX

Post

Engine check light comes on every once in a while. running about 14-15psi. Have been dialing it down though. Please give me your settings DeliciouSpeed. I have a ScoobySport rear silencer, and prototype Intake. Check Engine light was not coming on before the DSBC. I also live in Denver so altitude is probably causing problems. Friday I will put a fuel pressure riser in.
TARMAC is offline   Reply With Quote
Old 04-23-2001, 12:14 AM   #5
WRXGirl
Scooby Specialist
 
Member#: 881
Join Date: Feb 2000
Location: Margarita Ville
Vehicle:
2004 WRX
Grey

Post

We have this on our 93 WRX conversion. It is the best out there. The Rigoli's also run it.
(they hold the record for the fastest WRX)
I don't notice much noise with it.
Pam/WRXGirl
WRXGirl is offline   Reply With Quote
Old 04-23-2001, 06:40 AM   #6
Diz
Scooby Specialist
 
Member#: 874
Join Date: Feb 2000
Chapter/Region: RMIC
Location: Colorado Mountains
Vehicle:
2015 WRX STI
2004 Mazdaspeed MX-5

Talking

Is that you, Amhad? (I hope I spelled your name correctly...not likely) Anyway, my single solenoid is noisy, too. I also threw a CE light yesterday on a high boost run. I turned down the boost and have been running on the "low boost" setting ever since.

-Paul (Blue WRX, anthracite rims)

[This message has been edited by Diz (edited April 23, 2001).]
Diz is offline   Reply With Quote
Old 04-23-2001, 06:43 AM   #7
DeliciouSpeed
Scooby Specialist
 
Member#: 3389
Join Date: Dec 2000
Location: ContraCosta, Ca
Vehicle:
07 STImpreza
Satin

Post

I havent seen any Ces even at 1.05bar. I'll PM you with themn later today, can't remember what my gain setting is. But is you have other stuff right now, it prolly won't work well for you. All I have is Intake on right now. I'll have a turbo back exhaust on this weekend. Not looking forward to that install.

Ken
DeliciouSpeed is offline   Reply With Quote
Old 04-23-2001, 08:40 AM   #8
Diz
Scooby Specialist
 
Member#: 874
Join Date: Feb 2000
Chapter/Region: RMIC
Location: Colorado Mountains
Vehicle:
2015 WRX STI
2004 Mazdaspeed MX-5

Question

Ken -

Is that the BPM unit? I ordered mine (GT) from iSR and haven't heard anything.

-Paul
Diz is offline   Reply With Quote
Old 04-23-2001, 07:26 PM   #9
IMPREZIV
Scooby Specialist
 
Member#: 862
Join Date: Feb 2000
Location: NY
Post

I got a CE light at 1.35 Bar, and I have been running 1 Bar since then. Also the fuel cutoff kicked in at this point too.
Pete
IMPREZIV is offline   Reply With Quote
Old 04-23-2001, 07:46 PM   #10
Blugin
Scooby Specialist
 
Member#: 5270
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Arlington, TX
Vehicle:
2008 EvoX MR
Red

Have a Nice Day?

Do you realize that 1.35 bar is 19.58psi!!! Are you CRAZY? You definatly have balls though. How did the car feel at that high of a boost setting? I bet it was interesting... Keep us posted on this.
Blugin is offline   Reply With Quote
Old 04-23-2001, 07:56 PM   #11
WRXGirl
Scooby Specialist
 
Member#: 881
Join Date: Feb 2000
Location: Margarita Ville
Vehicle:
2004 WRX
Grey

Post

The BPM mufflers will be here this week. They rechecked the fit before they sent them out on the GT mufflers.
Pam
WRXGirl is offline   Reply With Quote
Old 04-23-2001, 08:01 PM   #12
DeliciouSpeed
Scooby Specialist
 
Member#: 3389
Join Date: Dec 2000
Location: ContraCosta, Ca
Vehicle:
07 STImpreza
Satin

Post

1.35bar! Are you sick? How did it like it?
How long did you run it at that?

Ken
DeliciouSpeed is offline   Reply With Quote
Old 04-24-2001, 12:39 AM   #13
ImprezaRS dot com
over boosted again
Moderator
 
Member#: 1458
Join Date: May 2000
Chapter/Region: RMIC
Location: Colorado Springs CO USA
Vehicle:
2015 Forester 2.0 XT
2005 2.5 RS, 2013 Tribeca

Post

My Blitz single solenoid SBC is totally silent. hmmm...

Paul, what are you gonna do about the CE light? Getting a EGT, Rich Lean gauge and boost gauge, then play from there?

The WRX has a three speed fuel pump right? So that means that will be harder to replace for more fuel. Could it be the USA model's fuel injectors are too small? Maybe No Fuel maps for over 15-16psi? Is it the intake and exhaust?

Lots of things to consider.
ImprezaRS dot com is offline   Reply With Quote
Old 04-24-2001, 12:45 AM   #14
doripreza
Scooby Newbie
 
Member#: 574
Join Date: Nov 1999
Location: Altadena,CA,USA
Vehicle:
99 Impreza RS
Black

Post

i was going to get one of those, but i wasn't sure if it was any good, so what do you guys think??
better than me getting an HKS ??

lemme know

doripreza is offline   Reply With Quote
Old 04-24-2001, 12:46 AM   #15
DeliciouSpeed
Scooby Specialist
 
Member#: 3389
Join Date: Dec 2000
Location: ContraCosta, Ca
Vehicle:
07 STImpreza
Satin

Post

Its a combo of the maps and that sorry little turbo, at that psi up top were just pumping in a little bit of hot air. It needs to be replaced badly.

Yes Im installing a BPM GT. Very nice piece. Be patient customs sucks.

Ken
DeliciouSpeed is offline   Reply With Quote
Old 04-24-2001, 06:24 AM   #16
Diz
Scooby Specialist
 
Member#: 874
Join Date: Feb 2000
Chapter/Region: RMIC
Location: Colorado Mountains
Vehicle:
2015 WRX STI
2004 Mazdaspeed MX-5

Talking

Tarmac -

Where did you mount the actuator unit? I think this may be the source of my noise. I'll move mine and let you know if that fixes it.

Pam - Thanks for the update. Much appreciated.

-Paul
Diz is offline   Reply With Quote
Old 04-24-2001, 06:39 AM   #17
DeliciouSpeed
Scooby Specialist
 
Member#: 3389
Join Date: Dec 2000
Location: ContraCosta, Ca
Vehicle:
07 STImpreza
Satin

Post

I mounted mine on the strut tower where I removed the solenoid for the DRLs.

Ken
DeliciouSpeed is offline   Reply With Quote
Old 04-24-2001, 06:26 PM   #18
TARMAC
Scooby Newbie
 
Member#: 5816
Join Date: Apr 2001
Location: USA
Vehicle:
02 WRX

Post

I been turning down the boost since Friday. Tryinh to avoid CELs. Max boost is .83 right now. No CEL so far since this afternoon.
TARMAC is offline   Reply With Quote
Old 04-24-2001, 07:06 PM   #19
Blugin
Scooby Specialist
 
Member#: 5270
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Arlington, TX
Vehicle:
2008 EvoX MR
Red

Post

You should really get the CELs pulled so you can see exactly why you are getting them. They may be unrelated or due to a failure of some sort.
Blugin is offline   Reply With Quote
Old 04-25-2001, 07:08 AM   #20
DeliciouSpeed
Scooby Specialist
 
Member#: 3389
Join Date: Dec 2000
Location: ContraCosta, Ca
Vehicle:
07 STImpreza
Satin

Post

.83bar is less than stock! Run 14 or .95bar.
I have no CEL, Never have.

Ken
DeliciouSpeed is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
install: blitz dsbc Evo-Killa Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 03-13-2002 12:47 AM
Blitz DSBC Install? Alxaguiar Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 11-15-2001 11:21 PM
Blitz DSBC or SBC-iD? jamz Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 11-05-2001 10:02 PM
Blitz DSBC Setting? JohnWad Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 05-21-2001 05:48 PM
Blitz DSBC settings MJSpiers Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 05-19-2001 12:08 AM

All times are GMT -4. The time now is 03:34 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.