Welcome to the North American Subaru Impreza Owners Club Monday September 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-25-2003, 12:56 AM   #1
q0Y0p
Scooby Newbie
 
Member#: 35903
Join Date: Apr 2003
Chapter/Region: NESIC
Location: Worcester
Vehicle:
99 R & 05BugShield I
RBP & PSM

Default check engine light blinking after installins safcII for 99 2.5rs

My friend and I were installing the s-afc yesterday, after we connected all the wires correctly except we connected the ground(brown and black) wire to ignition ground instead of oxgen sensor ground (we didn't know that until i found it in scoobymods.com).
After I turned the ignition to perform the initial set up, the engine light started blinking, we didn't know what went wrong so we disconnected all the wires and put everything back to normal, but the engine light remains blinking whenever i turn on the car, so
my friend used one of those computer to check the codes inside the computer, it said 3 somethings:
speedometer sensor at fault
front o2 senor, rear o2 sensor at fault
undocument code

the speedometer works fine and i can still drive the car without any abnormal behaviors except when i turn on to the ignition (without startin the car) the engine fans go on and off continously

if anyone knows what we did wrong and what we possibly broke( o2 sensers maybe?)...
and how we can fix this please help...

PLZ HELP ME

thx

Walt
* Registered users of the site do not see these ads.
q0Y0p is offline   Reply With Quote
Old 08-25-2003, 06:14 PM   #2
tmat3
Scooby Specialist
 
Member#: 2817
Join Date: Nov 2000
Location: NYC and Troy, NY
Vehicle:
2001 Impreza 2.5RS
BRP

Default

You put everything back to the original state, right? Reset the ECU first and see what happens.
tmat3 is offline   Reply With Quote
Old 08-26-2003, 08:59 PM   #3
q0Y0p
Scooby Newbie
 
Member#: 35903
Join Date: Apr 2003
Chapter/Region: NESIC
Location: Worcester
Vehicle:
99 R & 05BugShield I
RBP & PSM

Default

We fixed the problem after mulder taught me...my friend connected the green connector on the passenger side which is not supposed to be connected
now the safc runs fine
thx for helping, mulder

Walt
q0Y0p is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Check Engine Light + Blinking Cruise Control mindz0f1 General Community 3 02-15-2007 09:35 AM
Check engine light blinking!?! Chonojake Factory 2.0L Turbo Powertrain 30 03-11-2006 09:06 PM
check engine light blinking jimball21 Tri-State Area Forum 20 01-25-2005 12:31 AM
Check engine light blinking!!! rageatm007 Electrical & Lighting 5 07-26-2004 07:54 AM
check engine light blinking after installins safcII for 99 2.5rs q0Y0p Electrical & Lighting 5 08-26-2003 09:08 PM


All times are GMT -4. The time now is 06:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.