Welcome to the North American Subaru Impreza Owners Club Saturday May 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > General Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Old 10-18-2000, 09:22 PM   #1
kAn9ArOo
Scooby Newbie
 
Member#: 2294
Join Date: Sep 2000
Angry Problem Child Impreza...

my car is only 8mo. old. i took it in to the dealer last week, cuz my check engine was on.and my car was dying on me at stoplights. the techguy said he couldn't figure out what was wrong. he said he reset the codes in the computer. then he told me to drive it around and see what happens! and i still got the same problems, it died on me today too.it seems light my impreza is coughing and can barely breathe! what should i do.im gonna take it in again soon dammit
* Registered users of the site do not see these ads.
kAn9ArOo is offline  
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-18-2000, 11:10 PM   #2
ImprezaRS dot com
over boosted again
Moderator
 
Member#: 1458
Join Date: May 2000
Chapter/Region: RMIC
Location: Colorado Springs CO USA
Vehicle:
2015 Forester 2.0 XT
2005 2.5 RS, 2013 Tribeca

Post

Check the O2 sensor or fuel filter. Also, I had some cracked champion POS spark plugs that cracked by 10,000 miles! Look there too.

The filter and plugs may not explain the check engine light though.

Larry
ImprezaRS dot com is offline  
Old 10-19-2000, 06:06 AM   #3
spshultz
Scooby Specialist
 
Member#: 1415
Join Date: May 2000
Location: Anytown, USA
Vehicle:
2005 OBS 3.0R
'12 SantaFe

Post

Larry,

I found the same thing on one of my plugs. A hairline crack. If you wiggled it you could see it barely separate but not enough to cause a misfire. Also I had 32K on those plugs and they were worn down to .049. I couldn't believe it. I had 40K on my Dakota champions and they were only worn maybe .002 or so. Heck even the tips weren't rounded yet. In the Subie they were quite rounded. I guess this car loves Spark plugs.

Shawn
spshultz is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
what are the common problems- 99 Impreza Outback dusterbd13 Outback Forum 2 06-03-2007 09:12 PM
ej20 timing belt problem 99 impreza sublime Normally Aspirated Powertrain 10 08-14-2006 12:06 PM
Knock sensor problem 2000 Impreza RS billingsmc Service & Maintenance 2 08-05-2004 09:37 PM
02 WRX wagon problem child, advice? jasonb Warranty Issues & SOA Problems 7 02-03-2004 01:58 PM
Weird starting problem--1993 Impreza KUgrad Normally Aspirated Powertrain 8 03-07-2003 10:07 AM


All times are GMT -4. The time now is 03:09 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.