Welcome to the North American Subaru Impreza Owners Club Wednesday December 2, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > General Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 11-13-2000, 10:18 PM   #1
Scooby Newbie
Member#: 2915
Join Date: Nov 2000
Location: Santa Clara, CA, USA
Question Clutch noise?

Anyone have any issues with noise (scraping sound) when the clutch pedal is depressed ALL the way to the floor? Easing up just slightly stops the noise. I am wondering if this is something I need to have looked at or if it is normal. I just bought my RS three days ago, and just noticed this today, while waiting for a light to change.
* Registered users of the site do not see these ads.
Herman is offline  
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-13-2000, 10:56 PM   #2
Scooby Guru
Member#: 2237
Join Date: Aug 2000
Chapter/Region: TXIC
Location: DFW
2000 GC8 STi
2015 Ford Mustang GT

Thumbs up

Ok well if you press it all the way and it makes friction and sounds like rubbing...

It's probably the pivot point not being lubricated and maybe dirty due to it not being assembled properly...I had this taken care of 3 weeks ago....

Luckily you are under warranty...it would cost you like 300 otherwise.

they have to take out the whole transmission to get to the clutch in there Take it to the service dept...they'll give you arental and give it back to you at the end of the day

Bankheist is offline  
Old 11-13-2000, 11:09 PM   #3
Geb Firneisz
Scooby Newbie
Member#: 1469
Join Date: May 2000
Location: Eugene, Oregon

Ya i had that problem at 3500 miles. Dealer fixed it.
Geb Firneisz is offline  
Old 11-13-2000, 11:12 PM   #4
Scooby Newbie
Member#: 2915
Join Date: Nov 2000
Location: Santa Clara, CA, USA

Thanks for the input. I was hoping for a sanity check, but was afraid that this might be the answer. Off to the service department I go.
Herman is offline  
Old 11-14-2000, 09:18 AM   #5
Scooby Guru
Member#: 518
Join Date: Nov 1999
Chapter/Region: NESIC
Location: Trunkmonkey Racing
762 PGT Impreza L,
Silverado EXT, Yaris


Have them check your throwout bearing. I've been fighting with Subaru of America for the past two and a half years about this. Do you have an MY98 with a cable clutch?

Trunkmonkey is here! There is no cone...
Sean Sosik-Hamor < sean@trunkmonkey.com >
Epinions Automotive Reviews by `Sean
47STS MY98 Subaru Impreza Outback Sport
Sean is offline  
Old 11-14-2000, 11:40 AM   #6
Scooby Newbie
Member#: 2915
Join Date: Nov 2000
Location: Santa Clara, CA, USA
Have a Nice Day?

No, it's a 2001 RS with the hydraulic clutch.
Herman is offline  
Old 11-14-2000, 11:45 AM   #7
Greg I
Scooby Newbie
Member#: 384
Join Date: Oct 1999
Location: Vancouver, BC, Canada
2002 Acura RSX-S


The 1998 Impreza RS had a hydraulic clutch. My friend was bleeding something that looked, behaved, and felt shockingly like a hydraulic clutch in his '98 a few weekends ago -- he told me all about it.

Why do people think the '98 has a cable clutch?

Greg I is offline  

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
STI Clicking Clutch Noises at 12K? Two different noises MidnightSti05 Transmission (AT/MT) & Driveline 1 08-27-2005 02:57 PM
99 obs clutch noise and hatch noise only1agam Service & Maintenance 5 06-11-2004 01:00 AM
('93-'01) Clutch noise, did a search... Jazz95 Impreza Forum 3 05-12-2001 03:45 PM
Abnormal Clutch noises? jacksonww Normally Aspirated Powertrain 1 04-17-2001 03:53 PM
Disturbing clutch noises! akuhner General Forum Archive 5 05-17-2000 07:00 AM

All times are GMT -4. The time now is 02:12 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.