Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-06-2003, 05:25 PM   #1
vik
Scooby Newbie
 
Member#: 3160
Join Date: Dec 2000
Chapter/Region: MWSOC
Location: Cincinnati, OH
Vehicle:
05 9-2x
Artic Silver

Default SOS: Help removing sti engine mount

I decided to go back to my stock mounts. I am following the instruction on scooby mods and for some reason the when I raise the engine, it raises the whole car. The header bolts (6) have been removed. The pitch mount bolt has been removed (1). The engine mount bolts. The one in the middle and the one on each side, left and right have been removed. What am I missing ?
* Registered users of the site do not see these ads.
vik is offline   Reply With Quote
Old 09-07-2003, 10:46 AM   #2
S.G.D
Scooby Specialist
 
Member#: 36448
Join Date: May 2003
Chapter/Region: VIC
Location: Vancouver
Default

are your mounts for sale?!?!?!

and why are u returning to stock?

sorry for the unrelated questions


~SGD
S.G.D is offline   Reply With Quote
Old 09-07-2003, 09:10 PM   #3
RallyOttawa
Scooby Newbie
 
Member#: 14303
Join Date: Jan 2002
Location: Seattle, WA
Vehicle:
1999 Impreza RS 2.5
Black

Default

I'm also interested in why you are returning to stock...

I'm installing these mounts on Tuesday!

Sorry I cant be of help.
RallyOttawa is offline   Reply With Quote
Old 09-07-2003, 09:44 PM   #4
obyone
Scooby Specialist
 
Member#: 16523
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Inbetween Hesco's and T-walls
Vehicle:
JDM Maxxpro

Default Re: SOS: Help removing sti engine mount

Quote:
Originally posted by vik
I decided to go back to my stock mounts. I am following the instruction on scooby mods and for some reason the when I raise the engine, it raises the whole car. The header bolts (6) have been removed. The pitch mount bolt has been removed (1). The engine mount bolts. The one in the middle and the one on each side, left and right have been removed. What am I missing ?
Tranny mount maybe? And why are you selling your STI mounts? Can I have them.
obyone is offline   Reply With Quote
Old 09-08-2003, 12:42 AM   #5
EvasionOfTruth
Scooby Specialist
 
Member#: 13282
Join Date: Dec 2001
Chapter/Region: MAIC
Location: Richmond, VA
Vehicle:
2007 FXT
WRB SPB Edition

Default Re: Re: SOS: Help removing sti engine mount

Quote:
Originally posted by obyone


Tranny mount
EvasionOfTruth is offline   Reply With Quote
Old 09-08-2003, 10:11 AM   #6
cvalle-sd
Scooby Specialist
 
Member#: 420
Join Date: Oct 1999
Chapter/Region: SCIC
Location: The LBC, CA, USA
Vehicle:
2001 Cr-V
Silver

Default

The engine is connected to the tranny, the tranny is connected to the cha-ssis, the jack is pushing upward on the en-gine, and so the car goes up...
cvalle-sd is offline   Reply With Quote
Old 09-08-2003, 06:06 PM   #7
obyone
Scooby Specialist
 
Member#: 16523
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Inbetween Hesco's and T-walls
Vehicle:
JDM Maxxpro

Default

Quote:
Originally posted by cvalle-sd
The engine is connected to the tranny, the tranny is connected to the cha-ssis, the jack is pushing upward on the en-gine, and so the car goes up...
Cool, I was right!...Do I win anything?
obyone is offline   Reply With Quote
Old 09-08-2003, 07:52 PM   #8
vik
Scooby Newbie
 
Member#: 3160
Join Date: Dec 2000
Chapter/Region: MWSOC
Location: Cincinnati, OH
Vehicle:
05 9-2x
Artic Silver

Default

I enjoyed the sti mounts but I think the noise is starting to annoy me. That is why I am trying to go back to stock. Once I get back to stock they will be up for sale. This last weekend was my one free weekend in a while. So don't know when it will be up for sale. Sorry fellas.
vik is offline   Reply With Quote
Old 09-08-2003, 08:34 PM   #9
ciper
Scooby Guru
 
Member#: 15543
Join Date: Feb 2002
Location: san francisco, ca
Vehicle:
90BJ Legacy LS ABS
AWD 946 Rio Red Jpn built

Default

Hows that? The transmisison mount is soft as heck, dont see how you could lift the entire car from it.
ciper is offline   Reply With Quote
Old 09-09-2003, 11:49 AM   #10
cvalle-sd
Scooby Specialist
 
Member#: 420
Join Date: Oct 1999
Chapter/Region: SCIC
Location: The LBC, CA, USA
Vehicle:
2001 Cr-V
Silver

Default

Well it's bolted to a subframe-crossmembery-thingy, and if it weren't really stuck in there, it'd vibrate/torque itself right out of the car. Plus there's just limited upward travel - I'm sure it just hits the floorpan or something, and lifts the whole shootin match.
cvalle-sd is offline   Reply With Quote
Old 09-09-2003, 01:52 PM   #11
2Point5RS
Scooby Specialist
 
Member#: 3639
Join Date: Jan 2001
Chapter/Region: TXIC
Location: Bedford, TX
Default

Maybe I'm misunderstanding something, but it sounds like you didn't even unbolt the mounts.

Only thing you should have to do it unbolt the engine mounts, and the pitch stopper. You should be able to jack up the engine from the oil pan then. Just use a block of wood between the pan and jack.

You're not jacking the car up from the frame, are you?
2Point5RS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! 08+ STi Engine and Transmission mounts zietz01 Factory 2.5L Turbo Powertrain 2 02-09-2010 10:31 AM
Sti engine mount installation, need help SammyRex Factory 2.5L Turbo Powertrain 5 04-23-2006 10:36 AM
HELP! STi engine mounts and tranny mounts install jimtweet Tri-State Area Forum 11 04-22-2006 01:29 AM
Is it ok to do sti tranny mount without sti engine mounts? orvacian Transmission (AT/MT) & Driveline 6 12-03-2002 01:08 AM
Help with STi engine mounts... kaos200 Normally Aspirated Powertrain 12 09-09-2001 12:16 AM


All times are GMT -4. The time now is 12:34 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.