Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-07-2003, 06:11 PM   #1
outferno
Scooby Newbie
 
Member#: 27469
Join Date: Oct 2002
Location: Undetermined
Vehicle:
00 AW 2.5RS Coupe
04 AW Impreza WRX STi

Default 2 STi Stereo Questions

Dang, I'm so confused. Can someone help me out? I have a STi and I recently did a stereo install but I can't find the antenna input into my deck... Did I have to pull it through from the back and into the front or am I just missing it and not seeing it?

Secondly, can someone confirm that 6.5" speakers will fit the front and that 5.25" speakers will fit the back?

If anybody could shed any light on this, it would be much appreciated. Thanks.

Signed,
Outferno
* Registered users of the site do not see these ads.
outferno is offline   Reply With Quote
Old 09-07-2003, 07:53 PM   #2
dsmperformance
Scooby Specialist
 
Member#: 15059
Join Date: Feb 2002
Chapter/Region: MAIC
Location: Latrobe, PA
Vehicle:
2004 WRX STi
1991 TSi

Default

The STi antenna is amplified and there are 2 connections needed to work properly. 1st, you need to connect the big antenna plug(big and black). It might be hidden behind the harness, dig for it. 2nd, you need to connect power to the amplified antenna. Most decks have a power antenna lead coming out of the deck(most are solid blue). That needs to be connected to the STi harness(i believe its white).

If you happen to purchase a wire harness adapter, just follow the directions on the package about connecting the power antenna lead.

Yes, 6.5" woofers will fit with the proper spacer/adapter. For the rear, depending on the speaker, the 5.25" will work. You might have to enlarge the opening slightly.
dsmperformance is offline   Reply With Quote
Old 09-08-2003, 01:59 AM   #3
IA Performance
NASIOC Vendor
 
Member#: 25194
Join Date: Sep 2002
Chapter/Region: RMIC
Location: Boulder, CO
Vehicle:
2008 Forester XT 5mt
Dark Gray

Default

for the rears a 5.25" speaker with a max of 4.7" can fit with zero metal cutting. This is via use of a custom adapter plate.

ALso, for the rears, look for a set of coax that has a flush mounted tweeter to it. I.E. teh tweeter doesn't not extend past the speaker surrond. The space back there is very tight.
IA Performance is offline   Reply With Quote
Old 09-08-2003, 11:00 AM   #4
pushkasmd
Scooby Newbie
 
Member#: 40791
Join Date: Jul 2003
Location: Potomac, Maryland
Vehicle:
2004 WRX STi
silver

Default

Thanks, guys. I recently bought an Aiwa double DIN CD/cassette player from Crutchfield. (Excellent support services, by the way, for a little extra money). I have horrible reception on it and I was considering trashing it. Tonight I will look for the white wire and let you know if it helped. I may still have to use the thing as a paperweight - at $250 you gets what you pays for, I guess.
pushkasmd is offline   Reply With Quote
Old 09-08-2003, 03:00 PM   #5
G-force
Scooby Specialist
 
Member#: 14104
Join Date: Jan 2002
Location: Los Angeles, CA
Vehicle:
UBER ILikeItLongAndH
ardDeepandSmoothEverSoCoo

Default

if yours came with a supplied wiring harness from crutchfield (which I assume it did) there's no need to locate the white wire...just connect the blue antenna power lead from the radio's harness to the subaru blue wire harness adapter.
G-force is offline   Reply With Quote
Old 09-08-2003, 08:16 PM   #6
pushkasmd
Scooby Newbie
 
Member#: 40791
Join Date: Jul 2003
Location: Potomac, Maryland
Vehicle:
2004 WRX STi
silver

Default

Thanks, G-force and all of you. In 20 minutes I had the panel off and the blue wires connected - the radio works like a charm and I am in love again with the car.
pushkasmd is offline   Reply With Quote
Old 09-15-2003, 08:35 AM   #7
outferno
Scooby Newbie
 
Member#: 27469
Join Date: Oct 2002
Location: Undetermined
Vehicle:
00 AW 2.5RS Coupe
04 AW Impreza WRX STi

Default

Thanks for all the replies folks, but I haven't been on much recently via hours at work. I'm actually thinking of getting Polk DB's for my car now. 6.5 in the front and 5.25 in the rear. Zero cutting right?

I'm scared .

Signed,
Outferno
outferno is offline   Reply With Quote
Old 09-20-2003, 05:21 PM   #8
outferno
Scooby Newbie
 
Member#: 27469
Join Date: Oct 2002
Location: Undetermined
Vehicle:
00 AW 2.5RS Coupe
04 AW Impreza WRX STi

Default

Well, I got the 6.5" speakers in with no problem, had to do some minor drilling. Now for the 5.25" in the back, I had to do some sheet metal cutting, no harm done. However, I can't find the damn antenna plug. Anybody?

Signed,
Outferno

By the way, I got Infinity
outferno is offline   Reply With Quote
Old 09-20-2003, 06:22 PM   #9
marcus_gonzalez
Scooby Newbie
 
Member#: 41639
Join Date: Aug 2003
Location: north richland hills, TX
Vehicle:
2004 WRX STI
Blue

Default

I took my STI to earmark and they were able to put 6.5 component kenwoods in the front and 5.25 in the back with no problem.
marcus_gonzalez is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
07 Impreza wagon 2.5i upgrade stereo questions kaotik78 Car Audio, Video & Security 2 06-10-2009 05:33 AM
05 STi stereo question David03WRX General Community 3 05-08-2004 11:27 PM
STI Stereo Question for anyone WRC-STI Bay Area Impreza Club Forum -- BAIC 3 09-29-2003 02:10 PM
STI stereo question mazdman STi Forum Archive 10 07-16-2003 07:51 PM
STi Stereo Wiring Harness Question bcristea STi Forum Archive 2 07-14-2003 11:08 AM


All times are GMT -4. The time now is 11:22 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.