Welcome to the North American Subaru Impreza Owners Club Thursday October 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Bay Area Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Bay Area Impreza Club Forum -- BAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-08-2003, 07:41 PM   #1
Steppin Razor
Scooby Specialist
 
Member#: 24035
Join Date: Sep 2002
Chapter/Region: BAIC
Location: San Francisco
Vehicle:
2002 GGA 5MT
Seal Gray

Default Anyone got a heatshield bolt laying around?

So I start hearing this little buzz sound as my motor is coming down in revs at 2900 to 3000 rpm. I didn't really think much of it, it sounded like a loose heat sheild bolt or something, but after inspection, it sounds a bit more like the turbine or compressor wheel hitting the housing. Has anyone else had a similar experience?

Also, if you have a stocker laying around, I'd like to pick one up just incase it is the turbo, as the car is my daily driver and I need to get to work.

My only power mod is an uppipe, but I could see SOA pretty easily denying my warrantee work just due to that mod, especially because it's right next to the part that's broken even though it would be pretty difficult for an uppipe to cause a turbo to wear out quickly (I think). Doesn't the uppipe just allow a greater pressure differential over the turbo allowing it to be more efficient?

EDIT: I no longer need a turbo, it turned out to be a missing heat shield bolt.
* Registered users of the site do not see these ads.

Last edited by Steppin Razor; 09-08-2003 at 09:05 PM.
Steppin Razor is offline   Reply With Quote
Old 09-08-2003, 08:22 PM   #2
ron_c1
Scooby Newbie
 
Member#: 10299
Join Date: Sep 2001
Location: San Jose, CA
Vehicle:
2002 WRX
Sedona Red Pearl

Default

pm'd you.....
Ron
ron_c1 is offline   Reply With Quote
Old 09-08-2003, 08:58 PM   #3
JewPac42
Scooby Guru
 
Member#: 23260
Join Date: Aug 2002
Chapter/Region: BAIC
Location: -=3/1 Jew Crew=-
Vehicle:
Patr ick Willis
for Rookie of the year

Default

Why dont you just remove the uppipe if it is possible? That would probably be a lot cheaper then putting a new turbo in.
JewPac42 is offline   Reply With Quote
Old 09-08-2003, 09:03 PM   #4
Steppin Razor
Scooby Specialist
 
Member#: 24035
Join Date: Sep 2002
Chapter/Region: BAIC
Location: San Francisco
Vehicle:
2002 GGA 5MT
Seal Gray

Default

sorry for the spazz post, but once the thing cooled off enough for me to get my hands on it, i realized it was just a bolt missing on the passenger side of the downpipe heat shield...

anyone got a heat shield bolt laying around?
Steppin Razor is offline   Reply With Quote
Old 09-08-2003, 10:58 PM   #5
suby_dude
NASIOC Vendor
 
Member#: 17397
Join Date: Apr 2002
Chapter/Region: BAIC
Location: Fremont, CA
Vehicle:
many '02 Rex,'13 FRS
WRB, White

Default

Quote:
Originally posted by Steppin Razor
sorry for the spazz post, but once the thing cooled off enough for me to get my hands on it, i realized it was just a bolt missing on the passenger side of the downpipe heat shield...

anyone got a heat shield bolt laying around?
dork!
suby_dude is offline   Reply With Quote
Old 09-09-2003, 12:33 PM   #6
mexicanpizza
Scooby Specialist
 
Member#: 16779
Join Date: Mar 2002
Chapter/Region: SCIC
Location: Oceanside, CA
Vehicle:
2008 God's Gift to
Turbo Wagons (MS3)

Default

ANYONE GOT A SPARE ENGINE?!?!@?@!?


oh wait i just ran out of gas.
mexicanpizza is offline   Reply With Quote
Old 09-09-2003, 01:38 PM   #7
Steppin Razor
Scooby Specialist
 
Member#: 24035
Join Date: Sep 2002
Chapter/Region: BAIC
Location: San Francisco
Vehicle:
2002 GGA 5MT
Seal Gray

Default

anyone got a spare tackhammer?

oh wait even that would be too big to whack eric over the head with.
Steppin Razor is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone got a ej205 shortblock laying around ownnij TXIC Private Classifieds 4 05-01-2009 03:50 PM
Desparately need turbo water feed pipes... got an old turbo laying around? rlavalle North West Impreza Club Forum -- NWIC 7 09-04-2005 01:23 AM
Anyone have a broken turbo.......laying around.. WRX Jim Mid Atlantic Impreza Club -- MAIC 0 06-12-2005 02:34 PM
Anyone got a stock turbo lying around? PSMWRX Mid Atlantic Impreza Club -- MAIC 10 01-01-2004 11:25 AM
ANyone got two stock rims laying around?wreck results WR-REX Texas Impreza Club Forum -- TXIC 5 03-02-2002 10:40 PM


All times are GMT -4. The time now is 09:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.