Welcome to the North American Subaru Impreza Owners Club Monday September 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-09-2003, 11:24 AM   #1
Lowjack
Scooby Newbie
 
Member#: 36947
Join Date: May 2003
Location: Atlanta
Vehicle:
2004 350Z
Blue

Default 4at to a MT Wiring Questions!! I need some help please.

I have an 04 WRX that I recently swaped to a 5spd. The donor was from a MY02 WRX and everything is in but I am having a difficult time getting the wiring correct.

Problem is that the connectors from the wiring harness don;t match and I need to know what pins I need to take the following sensors to.

* Speed Sensor. (Supose to go into B134 pin #1 , but I have no pin in the harness going to it.)

* Neutrual Posiition sensor (Supose to go into B134 pin #8 , but I have no pin in the harness going to it.)

* Back-up Light sensor ( I have no idea where this goes)

* Starter Fake out (I connected the neutral and parking wires together. Big Yellow and Red/white wires on the line going into the AT Harness)

I am sorta in a crunch being that this is all that is stopping that me from getting back on the road. If anyone can help me asap I would be greatful.

Thanks,

Scott
404-512-9228
* Registered users of the site do not see these ads.
Lowjack is offline   Reply With Quote
Old 09-09-2003, 12:07 PM   #2
AKGC8
Scooby Specialist
 
Member#: 1305
Join Date: Apr 2000
Chapter/Region: AKIC
Vehicle:
2000 Impreza

Default

First, why didn't you just buy a manual in the first place?

Well I only have a wiring diagram for an 02 so I don't what's changed on the 04.

With the MT backup switch you'll have to tap into the wires that went to the AT inhibitor switch.

I don't know what you mean by starter fake out. The interrupt relay for the security system maybe?

For the speed sensor and NPS I don't know what to tell you. On the 02 diagram both AT and MT use B134 #1 and 8. Something must have changed.
AKGC8 is offline   Reply With Quote
Old 09-09-2003, 03:33 PM   #3
Lowjack
Scooby Newbie
 
Member#: 36947
Join Date: May 2003
Location: Atlanta
Vehicle:
2004 350Z
Blue

Thumbs up

Well I have confimed that I am a dumbass....... THe pins match between both years and that when looking at pinouts look at the ECM NOT the plug.... DOH!!!!

So I am forging forward with all the 2004 docs in hand as well as the 2002. Thanks to Porter for getting me some docs on the 04 so quickly.

More to come.

Thanks,

Scott
Lowjack is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
NEED Some Help Please!!! From A Pro Please!!! kamyar12 General Community 9 05-05-2010 04:28 AM
Need to get a smog check (won't pass), some help please? Cusson Southern California Impreza Club Forum -- SCIC 5 08-29-2009 08:01 PM
questions about downpipes. need some help, please Dfence410 Factory 2.0L Turbo Powertrain 3 10-17-2005 08:12 PM
looking to buy a used 2001 and up wrx...need some help please KillswitchEngage Impreza Forum 1 05-14-2004 01:21 PM
Gearset needed for 18g??? I need some help please!! eightballrj Factory 2.0L Turbo Powertrain 3 08-10-2003 01:37 AM


All times are GMT -4. The time now is 05:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.