Welcome to the North American Subaru Impreza Owners Club Monday November 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Outback Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 09-11-2003, 12:46 AM   #1
Scooby Specialist
Member#: 17315
Join Date: Apr 2002
Chapter/Region: International
Location: Date Line Denies F-22s
MY95 Impreza 207C
MY05 Forester 257X

Default Weird engine noise under acceleration

This is a MY98 Outback w/ 50k on the odo.

During cold runs (maybe 10-20 minutes are the the start), I hear a very subtle, repetitious clicking noise when accelerating. It's hard to describe it, but it's not a high pitched click you would normally hear. More of a mix of a muffled thumping/clicking noise. Dunno if it's normal or not.

It's not an occasional noise. It makes that noise in even intervals. Maybe 500 click per minute or something, just to give you an idea.

Thanks in advance.

-pak +1
* Registered users of the site do not see these ads.
Pakin is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-11-2003, 10:59 AM   #2
Scooby Newbie
Member#: 33302
Join Date: Feb 2003
Location: Calgary, Alberta
2005 Leggy GT Sedan
Brilliant Silver


Is it engine related (valve train) or maybe driveline related (CV joints). Anyone?
sooberoo is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ticking noise under acceleration Spore Normally Aspirated Powertrain 2 12-21-2008 01:39 PM
strange noise under acceleration r3xx Transmission (AT/MT) & Driveline 15 04-01-2008 04:52 PM
Help me ID this new weird new noise during acceleration. jay25RS Transmission (AT/MT) & Driveline 11 03-02-2008 10:19 PM
weird ''water'' noise while accelerating ricky05 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 01-29-2008 12:57 AM
Engine noise under heavy acceleration - any thoughts? ccmah Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 09-11-2006 07:01 PM

All times are GMT -4. The time now is 10:32 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.