Welcome to the North American Subaru Impreza Owners Club Monday August 3, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-12-2003, 03:47 PM   #1
Tomnel
Scooby Specialist
 
Member#: 12625
Join Date: Nov 2001
Chapter/Region: SCIC
Location: San Fernando Valley CA
Vehicle:
MY02 WRX Impreza
Silver

Default OEM Filter always leaks

I'm on my 9th change and wondering, do any of your oil filters leak after a few days?

Every oil change I get some oil down the side of the filter and I hand tighten it, put oil around the ring etc.

I used aftermarket purolator a few times and those would spray oil on the bottom of my engine so now I am back to OEM but it still leaks a little.
* Registered users of the site do not see these ads.
Tomnel is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-12-2003, 04:02 PM   #2
Karl
Scooby Specialist
 
Member#: 13110
Join Date: Dec 2001
Chapter/Region: NESIC
Location: Rhode Island
Default

Have you wiped down the surface where the filter contacts the oil cooler?
Karl is offline   Reply With Quote
Old 09-12-2003, 04:17 PM   #3
orndog
Scooby Specialist
 
Member#: 34670
Join Date: Mar 2003
Chapter/Region: South East
Location: Atlanta
Vehicle:
2013 No gears!
Saltine American

Default

Have you checked the stud that the filter spins onto? My guess is with the above (dirty mounting plate).
Also, how tight are you making it? Too tight will give you leaks too.
orndog is offline   Reply With Quote
Old 09-12-2003, 06:27 PM   #4
ciper
Scooby Guru
 
Member#: 15543
Join Date: Feb 2002
Location: san francisco, ca
Vehicle:
90BJ Legacy LS ABS
AWD 946 Rio Red Jpn built

Default

I bet its not the oil filter leaking. It could be the cam seal dripping down into the timing belt cover which sprays back against the filter in the wind!
ciper is offline   Reply With Quote
Old 09-13-2003, 04:07 AM   #5
Tomnel
Scooby Specialist
 
Member#: 12625
Join Date: Nov 2001
Chapter/Region: SCIC
Location: San Fernando Valley CA
Vehicle:
MY02 WRX Impreza
Silver

Default

Quote:
Originally posted by Karl
Have you wiped down the surface where the filter contacts the oil cooler?
Yep.
Quote:
Have you checked the stud that the filter spins onto? My guess is with the above (dirty mounting plate).
Check it for what exactly? It seems fine.
Quote:
I bet its not the oil filter leaking. It could be the cam seal dripping down into the timing belt cover which sprays back against the filter in the wind!
Cam seal? is this something I need to get checked?

Thanks guys.
Tomnel is offline   Reply With Quote
Old 09-13-2003, 05:21 PM   #6
armand1
Scooby Guru
 
Member#: 10309
Join Date: Sep 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
'02 OBS 2-tone!
'95 Montego Miata

Default

You need to have a mechanic look at it. Either there is a flaw in the threading that the filter is screwed onto, or there is a flaw in the flat plate that the filter's rubber gasket presses against, or there is a flaw in some part of the engine very nearby that area that is leaking oil *onto* the filter (not *from* the filter).
Life would be very bad if the something that's wrong suddenly gave way and dumped your oil out of the engine, so get it checked out soon.
armand1 is offline   Reply With Quote
Old 09-14-2003, 04:01 PM   #7
Frawl
Scooby Newbie
 
Member#: 19201
Join Date: May 2002
Location: Squamish
Vehicle:
2008 Legacy Wagon

Default

I had this happen with an entire six pack of OEM filters. I have an Impreza and a Legacy - happened on both. Thought the gasket was failing, or something was wrong with the seating surface. After the 4th one I got fed-up and tried a Napa Gold filter on one the Legacy and the problem went away. I'm now running an Amsoil filter on the other and the problem is gone on that one too.

A couple of months ago a mechanic told me that Subaru (at least in western Canada) had recalled a batch of filters. I asked a dealership and they just spaced - no surprise for a dealership I suppose. Anyway, I'm having no problem with the aftermarket filters I'm now using. Still have two new OEM filters that won't even work as doorstops because they're not heavy enough...

Jeff
Frawl is offline   Reply With Quote
Old 09-14-2003, 11:19 PM   #8
Yungimoto
Scooby Specialist
 
Member#: 14940
Join Date: Feb 2002
Chapter/Region: SWIC
Location: Wildwood, MO
Vehicle:
2002 WRX

Default

It seems odd that you'd have the problem every time. I could see getting a defective filter once, but 9 times? Something else has to be wrong.

Good luck!
Yungimoto is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY coolant overflow tank? The OEM sprung a leak. BigRed06 Service & Maintenance 12 12-18-2009 11:56 AM
2k2 ts, new filter=exhaust leak type sound? danfranklin6 Normally Aspirated Powertrain 4 10-02-2008 10:32 PM
FS:OEM Airbox w/ K&N Filter+NEW OEM filter obsti2 Engine/Power/Exhaust 21 09-15-2008 11:01 AM
No matter what I do oil filter still leaks Porkchop-WRX Service & Maintenance 18 05-07-2003 04:23 PM
filtration specs of oem filters gravel Service & Maintenance 1 06-27-2002 05:16 PM


All times are GMT -4. The time now is 10:49 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.