Welcome to the North American Subaru Impreza Owners Club Tuesday October 25, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > General Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 11-11-2000, 01:47 PM   #1
Scooby Newbie
Member#: 2740
Join Date: Oct 2000
Location: Schaumburg IL
Post CE light

Ok guys, I"ve seen many different reasons for the CE light coming on, let me explain my scenerio, installed intake, pulley, and exhaust, made a 3 hour drive up to wisconsin, next morning, today, CE is there staring me in the face. I've checked all hoses to intake, all seem to be fine. Must I take it to my dealer?
* Registered users of the site do not see these ads.
SnapperHead is offline  
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-11-2000, 01:57 PM   #2
Scooby Guru
Member#: 114
Join Date: Jul 1999
Chapter/Region: MWSOC
Location: Wichita, KS and Whoring, OT
'03 Evo, Rice White
'01 Erion CBR 929


No, you can do one of the following:

1. Get a generic OBDII scanner. Around $75-200 depending on features. Won't retrieve proprietary Subaru codes but the vast majority of them are standard ones.

2. Reset the ECU (do a search) and see if it comes back. If so go to the dealer or do #1.

3. Wonder what the hell is causing it and see if it goes out. After all, it could be a zillion things, including a loose gas cap. (That turn until it clicks stuff isn't just for the hell of it.)
ColinL is offline  
Old 11-11-2000, 02:15 PM   #3
Scooby Newbie
Member#: 2740
Join Date: Oct 2000
Location: Schaumburg IL

Thanks Colin, I'm going to try resetting ECU, seeing is I'm stuck up here in WI for the weekend. Well, not stuck, but anyway, I'll look in into the scanner for just something good to have. If all else fails, its to the dealer.

Moderator can close this thread. Thanks guys.
SnapperHead is offline  

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
('93-'01) 1500 miles and CE light comes on. Rubik Impreza Forum 9 06-09-2001 04:15 PM
('93-'01) CE light - crazy fuel gauge Captain Ding Impreza Forum 3 06-08-2001 08:15 AM
('93-'01) Aaaaahhhhh!!! CE light??!! GooseMan Impreza Forum 12 04-19-2001 08:39 PM
('93-'01) Green Plug...........CE light? XROLLER Impreza Forum 10 04-10-2001 12:57 AM
('93-'01) CE Light Fyxtion Impreza Forum 3 04-07-2001 07:10 PM

All times are GMT -4. The time now is 01:13 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.