Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-01-2003, 06:38 PM   #1
pat3
Scooby Newbie
 
Member#: 38154
Join Date: Jun 2003
Location: Redmond, WA
Vehicle:
2004 WRX Sedan
Silver

Default AC/Defrost Stinks...suggestions??

i have a 2004 WRX and I noticed a problem this morning heading in to work. I was running the defrost for a couple of minutes, which initiates the AC motor, to draw out the moisture to better aid the defrost process. I later parked the car and got back in about an hour later and smelled a funky mold like odor coming from the fresh air vent. I then turned the recirc with the fan on high on and the smell dissipated. Then turned recirc back off and the odor came back but not as bad, later disappearing all together. I heard that mold might be the cause from previous searches. Was wondering if that sounds about right and whether anybody else with an 04 wrx...or heck anybody with a wrx that uses the defrost with the AC has had similiar problems with a funky smell. It's not a gas or oil smell, but definitely more like a funky moldish smell...any suggestions on how to alleviate this problem would be most appreciated....thanx!

pat3
* Registered users of the site do not see these ads.
pat3 is offline   Reply With Quote
Old 10-02-2003, 06:02 AM   #2
Subie Nut
Scooby Newbie
 
Member#: 4821
Join Date: Mar 2001
Location: SoCal
Vehicle:
2004 STI
Blue on Gold

Default Lysol

Turn the vents on fan on high switch to fresh air. Go outside of the car and just below the wipers you should see some slats, those are the fresh air vents hit them with some Lysol and that should take care of yourproblem. To keep this form happening in the future turn off the compressor and switch on the heat five minutes before you get out of the car. This is what I have done with all of my cars and none of them have ever smelled.
Subie Nut is offline   Reply With Quote
Old 10-02-2003, 10:52 AM   #3
pat3
Scooby Newbie
 
Member#: 38154
Join Date: Jun 2003
Location: Redmond, WA
Vehicle:
2004 WRX Sedan
Silver

Default

thanx for the info...will try it out...
pat3 is offline   Reply With Quote
Old 10-03-2003, 11:40 AM   #4
impRSa
Scooby Newbie
 
Member#: 6521
Join Date: May 2001
Chapter/Region: MAIC
Default AC smell

impRSa is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
has anyone in the area done the AC/Defroster microswitch mod? alacrity024 New England Impreza Club Forum -- NESIC 32 02-13-2007 03:04 PM
How to disable AC when defroster is on DickWRX Interior & Exterior Modification 5 06-02-2004 06:54 AM
Sti - Kill the AC on defrost? WRX-72 Factory 2.5L Turbo Powertrain 12 10-22-2003 11:11 AM
AC/Defrost Mod from Scoobymods Schleppy Factory 2.0L Turbo Powertrain 24 04-19-2003 01:11 PM
AC on with defroster? Thats dumb! jasonmolinari Factory 2.0L Turbo Powertrain 25 01-16-2003 05:07 PM


All times are GMT -4. The time now is 06:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.