Welcome to the North American Subaru Impreza Owners Club Monday January 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-03-2003, 12:35 AM   #1
dwx
Scooby Guru
 
Member#: 8343
Join Date: Jul 2001
Chapter/Region: MWSOC
Location: Atlanta, GA
Vehicle:
2005 2012 Jeep
2013 DGM BRZ

Default Idle/starting problems on 95 LX (2.2)

Ok so I picked up this '95 LX with roughly 115k miles on it. It's a 2.2L. When I picked it up we noticed it idled a little high. High being somewhere in the 1000-1200 range. When I turned on the AC and the fans ran it would actually drop lower...

After driving the car about 1600 miles one of the timing belt idler pullies seperated itself from the block (snapped bolt). We fixed that problem today and I'm pretty sure everything is timed correctly again. The car pretty much does the same thing now that it did before that event. The idle almost seems a little higher though, around 1500 rpm. When the car is in gear it drops to around 1000. While the car is running it seems ok the car doesn't run rough or anything and when in gear the rpm seems normal.

Every once in awhile however it won't start. It seems to happen more often if I give it a half crank without starting and then try to crank it to get started. It won't start without giving it a lot of gas and then it stumbles quite a bit until it burns off the excess gas and then it happily goes back to idling at 1500+ rpm. Usually after one of these episodes, the car starts right back up with no problem.

I haven't really checked anything on the car sensor wise as of yet and figured I'd ask here first. The sparkplugs look relatively new as did the fuel filter.
* Registered users of the site do not see these ads.
dwx is offline   Reply With Quote
Old 10-03-2003, 12:42 AM   #2
zakats
Scooby Newbie
 
Member#: 41329
Join Date: Aug 2003
Chapter/Region: TXIC
Location: houston, texas
Default

Have you tried your
plugs
timing
throttle body(sounds stupid , but you never know)
ilde throttle position adjuster(whatever subaru calls it)
injectors
try running good gas(93 octane)

other than that...?
if i remember/think of n e thing ill write you again

hope this helps

--zak--

www.suby.tk
zakats is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with Remote Start problem on 2010 STI jvcjbl Car Audio, Video & Security 10 12-12-2009 12:13 AM
Help please - head problem on '98 Legacy GT 2.5L Duende Normally Aspirated Powertrain 2 03-14-2006 01:01 AM
idle/starting problem maxler3 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 02-02-2005 05:33 PM
Rubbing problem on 95 L wagon Aspen_2.5RS Brakes, Steering & Suspension 6 08-13-2003 08:34 PM
Anyone else know some more on 95 LX Wellhung Normally Aspirated Powertrain 2 07-31-2002 10:22 PM


All times are GMT -4. The time now is 05:12 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.