Welcome to the North American Subaru Impreza Owners Club Friday September 30, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-07-2003, 12:36 AM   #1
M32WRXin3seconds
Scooby Specialist
 
Member#: 36797
Join Date: May 2003
Chapter/Region: South East
Default those of you with a TXS TMIC, what BOV do you use? im having problems..

here is the deal. I have a brand new TXS V2 TMIC. I have a GFB Bov. at first i got some weird sounds. Now with the stock TMIC i never had a leak or anything like that. Im trying to determine whether it is the gasket or the bov itself not being flush with the aftermarket tmic. I tightened the bolts and the sound went away but it sounds like i might get a slight leak at about 3-4psi. how would this effect performance? it seems to pull like crazy and has no problem making boost etc. maybe its just how it sounds with an upgraded tmic? its a very quiet air sound. what would you suggest? its set to 50/50. i dont want to go back to stock + my stocker is broken from tightening. any solutions you can suggest?

thanks for your time
* Registered users of the site do not see these ads.
M32WRXin3seconds is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-07-2003, 03:24 AM   #2
Kwyjibo
Scooby Specialist
 
Member#: 17851
Join Date: Apr 2002
Vehicle:
2003 WRX
R.I.P. 7.27.2005

Default

i noticed a slight sound too when i put in my APS tmic, it holds boost, so i'm fairly certain it isnt a leak...maybe it is just the sound flowing through the larger ic?
Kwyjibo is offline   Reply With Quote
Old 10-07-2003, 04:33 AM   #3
M32WRXin3seconds
Scooby Specialist
 
Member#: 36797
Join Date: May 2003
Chapter/Region: South East
Default that is what i am thinking...

but i just wanted to be certain. i mean that bov is on there tight as a mofo...i have no boost problems. so i have no idea why its happening
M32WRXin3seconds is offline   Reply With Quote
Old 10-07-2003, 07:11 AM   #4
9o7wRx7o9
Scooby Specialist
 
Member#: 23140
Join Date: Aug 2002
Location: Alaska
Vehicle:
02 Subaru WRX
WRBlue

Default

Hmmm couple things...isnt our stock BOV 100% recirc? So changing the way it directs air might change some of the noises? Just guessing on that one...another guess might be you tightened the bolts so hard that you crunched the gasket?
9o7wRx7o9 is offline   Reply With Quote
Old 10-07-2003, 08:18 AM   #5
2.2gotboost
Scooby Newbie
 
Member#: 22860
Join Date: Aug 2002
Default

It is the GFB BOV. I had the same set up and the bov hits the manifold. I was later told the the GFB was the only bov that had issues with the TXS TMIC. I then went with a TurboXS RFL BOV. If your GFB is the old style (non adjustable) then this is your problem.
Iwas also told you can modify (file) the bov and make it work, but I did not do it. Hope this helps.
2.2gotboost is offline   Reply With Quote
Old 10-07-2003, 10:21 AM   #6
roybfr
Scooby Specialist
 
Member#: 14456
Join Date: Jan 2002
Chapter/Region: MWSOC
Location: WDM Iowa
Vehicle:
09 BMW 335i Sedan
69/72/01 Corvettes

Default

I have a V2 IC and bought a GFB Stealth BOV and there was no way it was going to fit. I am not sure it the 50/50 is overall the same size. The mounting flange on the GFB is really think and actaully some what would have prevented proper mating even if there was room. My guess is that one side of the BOV is not sealed and you a getting a slight leak.
roybfr is offline   Reply With Quote
Old 10-07-2003, 11:16 AM   #7
M32WRXin3seconds
Scooby Specialist
 
Member#: 36797
Join Date: May 2003
Chapter/Region: South East
Default yeah...

i'd say it has a leak. i dont think its because anyone overtightened anything. Because the leak was MUCH worse before it was tightened. so I guess I should just buy a TXS RFL bov.
M32WRXin3seconds is offline   Reply With Quote
Old 10-07-2003, 11:16 AM   #8
Chi
Scooby Newbie
 
Member#: 40311
Join Date: Jul 2003
Location: Taipei, Taiwan
Vehicle:
2004 WRX
White

Default

You might want to look for a leak where your BOV bolts to the TMIC. I use the Blitz BOV and encountered 2 problems.

- The bolts that I was using would not screw in completely. They were too long or the hole in the TMIC was too shallow. Either way, I used a 1/8" thick washer and solved this problem.

- The Blitz BOV base adaptor that I was using had clearance issues with the TMIC. Even after fixing the bolt issue, I realized that the adaptor would not fit flush with the TMIC. I ended up having a friend CNC machine me a new adaptor plate out of T7075 aluminum.

That quiet air sound that you are hearing is very likely a small leak. Don't forget to check all of your other IC hoses too.

Cheers!
Chi is offline   Reply With Quote
Old 10-07-2003, 11:24 AM   #9
nmyeti
Scooby Specialist
 
Member#: 4980
Join Date: Mar 2001
Location: Albuquerque, NM USA
Default Re: those of you with a TXS TMIC, what BOV do you use? im having problems..

Quote:
Originally posted by M32WRXin3seconds
here is the deal. I have a brand new TXS V2 TMIC. I have a GFB Bov. at first i got some weird sounds. Now with the stock TMIC i never had a leak or anything like that. Im trying to determine whether it is the gasket or the bov itself not being flush with the aftermarket tmic. I tightened the bolts and the sound went away but it sounds like i might get a slight leak at about 3-4psi. how would this effect performance? it seems to pull like crazy and has no problem making boost etc. maybe its just how it sounds with an upgraded tmic? its a very quiet air sound. what would you suggest? its set to 50/50. i dont want to go back to stock + my stocker is broken from tightening. any solutions you can suggest?

thanks for your time
Some of the GFB flanges Iíve seen are a little wide and don't properly seal with our TMIC. Check this because if you tighten the bolts and the flange is the wrong size either the TMIC or the flange can crack.

-Nathan
www.turboxs.com
nmyeti is offline   Reply With Quote
Old 10-07-2003, 11:43 AM   #10
M32WRXin3seconds
Scooby Specialist
 
Member#: 36797
Join Date: May 2003
Chapter/Region: South East
Default thanks

i didnt overkill tighten it. so i dont think i have to worry. I will be getting a txs BOV this week from nino. thanks again
M32WRXin3seconds is offline   Reply With Quote
Old 10-07-2003, 12:00 PM   #11
M32WRXin3seconds
Scooby Specialist
 
Member#: 36797
Join Date: May 2003
Chapter/Region: South East
Default ps...

should i just go back to stock for now?
M32WRXin3seconds is offline   Reply With Quote
Old 10-18-2003, 08:38 PM   #12
Onederer
I am NOT nice
Moderator
 
Member#: 7952
Join Date: Jun 2001
Chapter/Region: SCIC
Vehicle:
2014 Ford Fiesta ST
White

Default

I just put on my intercooler and had to go back to stock. My HKS was probably too big, but the base was to thin anyhow and the bolts would stick out like 1/4 inch and not seal.
Onederer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What BOV do you suggest elhockey3 Newbies & FAQs 15 08-15-2008 08:27 AM
Txs Fmic, What Map Do I Use?????? subbiedo04 UTEC 1 01-25-2007 12:17 AM
What BOV do you have??? subyguy04 General Community 3 10-02-2006 09:47 AM
what bov do you like godfather2112 Newbies & FAQs 29 04-29-2004 10:01 PM
What Bov Do You Recommend? stache Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 07-20-2002 02:53 PM

All times are GMT -4. The time now is 08:25 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.