Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-07-2003, 11:08 PM   #1
blackwagony
Scooby Newbie
 
Member#: 44910
Join Date: Oct 2003
Default my stupid car wont start!

I went to start my 2002 WRX today, and the stupid car wont start! I just turn the key, and nothing happens. A friend of mine told me it is the starter, but arent I the starter?

please help, i have volleyball practice tomorrow
* Registered users of the site do not see these ads.
blackwagony is offline   Reply With Quote
Old 10-07-2003, 11:11 PM   #2
billybob3
Scooby Newbie
 
Member#: 42727
Join Date: Sep 2003
Location: Earth
Vehicle:
2002 WRX
Silver

Default

It's probably not your starter. It's your battery, it's outta juice. It's dead. You need to either get a new battery, OR, jump start it off of a friend's car. THen, leave your car running for a while so that it can charge the battery back up.
billybob3 is offline   Reply With Quote
Old 10-07-2003, 11:13 PM   #3
blackwagony
Scooby Newbie
 
Member#: 44910
Join Date: Oct 2003
Default

but my radio turns on! it was turned up loud, too. it hurt my ears.
heeelp!
blackwagony is offline   Reply With Quote
Old 10-07-2003, 11:15 PM   #4
Brad Pittiful
Scooby Specialist
 
Member#: 34931
Join Date: Apr 2003
Chapter/Region: Tri-State
Location: A Town Called Malice
Vehicle:
. .
This ain't no picnic!

Default

your car is not stupid...it has a computer in it...duh
Brad Pittiful is offline   Reply With Quote
Old 10-07-2003, 11:17 PM   #5
blackwagony
Scooby Newbie
 
Member#: 44910
Join Date: Oct 2003
Default

what?!! it has a computer in it? how do i reboot it?
blackwagony is offline   Reply With Quote
Old 10-07-2003, 11:21 PM   #6
Akiata
Scooby Specialist
 
Member#: 297
Join Date: Sep 1999
Location: Wa
Default

Ctrl + Alt + Delete?
Akiata is offline   Reply With Quote
Old 10-07-2003, 11:23 PM   #7
blackwagony
Scooby Newbie
 
Member#: 44910
Join Date: Oct 2003
Default

alright, my dad came home, and he told me to check the carberator. where is it?
im not too sure if he knew what he was talking about, hes been drinking
blackwagony is offline   Reply With Quote
Old 10-07-2003, 11:52 PM   #8
Kean
Scooby Guru
 
Member#: 25187
Join Date: Sep 2002
Location: So. CA
Vehicle:
'08 Foz Prem TGM
'10 Challenger R/T Blk

Default

.....don't feed the trolls folks.
Kean is offline   Reply With Quote
Old 10-07-2003, 11:55 PM   #9
blackwagony
Scooby Newbie
 
Member#: 44910
Join Date: Oct 2003
Default

please, someone help me, i dont want to walk to practice
blackwagony is offline   Reply With Quote
Old 10-08-2003, 12:16 AM   #10
Kean
Scooby Guru
 
Member#: 25187
Join Date: Sep 2002
Location: So. CA
Vehicle:
'08 Foz Prem TGM
'10 Challenger R/T Blk

Default

Kean is offline   Reply With Quote
Old 10-08-2003, 12:17 AM   #11
pleasenoSTIckershock
*** Banned ***
 
Member#: 34997
Join Date: Apr 2003
Chapter/Region: Tri-State
Location: Broomall, PA
Vehicle:
99 Miata
10AE

Default

The carb is on your bong. Maybe you ought to think about taking your finger off it for a while....
pleasenoSTIckershock is offline   Reply With Quote
Old 10-08-2003, 12:43 AM   #12
TurismoLou
Scooby Specialist
 
Member#: 9480
Join Date: Aug 2001
Chapter/Region: International
Location: Man of Mystery
Vehicle:
2011 Wrangler Unlim.
Anti-hybrid

Default

Quote:
Originally posted by blackwagony
alright, my dad came home, and he told me to check the carberator. where is it?
im not too sure if he knew what he was talking about, hes been drinking
There's no carb on the car. Its probably the battery as was mentioned before. My battery died last winter and I needed to get it replaced. How about getting it jump started?
TurismoLou is offline   Reply With Quote
Old 10-08-2003, 01:53 AM   #13
z
Scooby Specialist
 
Member#: 41762
Join Date: Aug 2003
Chapter/Region: International
Location: House of Pancakes
Vehicle:
04 STi
CT-DE-FL rinse+repeat

Default

Why don't you try reading my reply on the other post you started.

http://forums.nasioc.com/forums/show...hreadid=433614


carbeurator
z is offline   Reply With Quote
Old 10-08-2003, 02:13 AM   #14
Kean
Scooby Guru
 
Member#: 25187
Join Date: Sep 2002
Location: So. CA
Vehicle:
'08 Foz Prem TGM
'10 Challenger R/T Blk

Default

Don't you folks know when someone is trying to pull your leg?
Kean is offline   Reply With Quote
Old 10-08-2003, 03:58 AM   #15
Spooled
Scooby Specialist
 
Member#: 14958
Join Date: Feb 2002
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
1991 318is
Silver

Default

I'll smoke whatever he's smoking
Spooled is offline   Reply With Quote
Old 10-08-2003, 05:23 PM   #16
blackwagony
Scooby Newbie
 
Member#: 44910
Join Date: Oct 2003
Default

argh, it still wont start. im gonna sell my car and buy a honda.
blackwagony is offline   Reply With Quote
Old 10-08-2003, 06:31 PM   #17
Cabal
Scooby Specialist
 
Member#: 31159
Join Date: Dec 2002
Chapter/Region: TXIC
Location: Austin, TX
Vehicle:
2006 WRX, 2008 2.5i
San Remo Red

Default

Cabal is offline   Reply With Quote
Old 10-08-2003, 06:43 PM   #18
Smelli Bugatti
Scooby Specialist
 
Member#: 34619
Join Date: Mar 2003
Chapter/Region: Tri-State
Location: Orange County
Vehicle:
555 WRX
World Rally Blue

Talking

That WRX is not your car
Smelli Bugatti is offline   Reply With Quote
Old 10-08-2003, 06:48 PM   #19
Mr. Fancypants
Scooby Newbie
 
Member#: 17626
Join Date: Apr 2002
Location: SCV, CA
Vehicle:
2005 STI

Default

ROTFL..this guy cannot be serious...unless...
Mr. Fancypants is offline   Reply With Quote
Old 10-08-2003, 06:55 PM   #20
blackwagony
Scooby Newbie
 
Member#: 44910
Join Date: Oct 2003
Default

the car is mine, my dad just bought it for me
blackwagony is offline   Reply With Quote
Old 10-08-2003, 08:48 PM   #21
Thumper23
Scooby Specialist
 
Member#: 11571
Join Date: Oct 2001
Chapter/Region: MAIC
Location: Virginia Beach, VA
Vehicle:
'08 BMW 135i
F/A-18C

Default

have you checked your boost fluid lately?
Thumper23 is online now   Reply With Quote
Old 10-08-2003, 09:15 PM   #22
Depeche
Scooby Newbie
 
Member#: 33650
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: Lake County
Vehicle:
3005 Ford
Thundercougarfalconbird

Default

youse might need to replace dat der kaneuter valve.

never know when one dem sumbiches might blow out
Depeche is offline   Reply With Quote
Old 10-09-2003, 10:15 AM   #23
T3/T4 WRX
Scooby Specialist
 
Member#: 25919
Join Date: Oct 2002
Chapter/Region: MWSOC
Location: St. Louis, MO
Vehicle:
12.8 second 1/4 mile
at 111mph

Default I had the same problem

I had the same problem about 5 weeks ago. It turns out I was jamming my bike lock key into the ignition. I ended up just hotwiring the car, going for a joyride, and then driving it into a tree. I left the scene and the dumb a** whose car it was never found out it was me

I love hotwiring

D
T3/T4 WRX is offline   Reply With Quote
Old 10-09-2003, 05:53 PM   #24
blackwagony
Scooby Newbie
 
Member#: 44910
Join Date: Oct 2003
Default

its still not starting............
blackwagony is offline   Reply With Quote
Old 10-09-2003, 08:44 PM   #25
Thug
Choke Artist
Moderator
 
Member#: 603
Join Date: Dec 1999
Chapter/Region: NESIC
Location: Nashua, NH
Default

Stop cross-posting.
Thug is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My swapped car wont start... parkes Subaru Conversions 70 09-28-2008 08:04 PM
help my car wont start DDImpreza New England Impreza Club Forum -- NESIC 2 05-27-2003 11:58 PM
help my car wont start DDImpreza Normally Aspirated Powertrain 2 05-27-2003 11:57 PM
my car wont start phestik Newbies & FAQs 8 07-22-2002 06:22 PM
my car wont start - need help phestik Southern California Impreza Club Forum -- SCIC 9 07-22-2002 11:41 AM


All times are GMT -4. The time now is 06:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.