Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-10-2003, 03:22 PM   #1
josh woodall
Scooby Newbie
 
Member#: 43006
Join Date: Sep 2003
Location: San Francisco Ca.
Vehicle:
04 wrx, sti
aspen white

Exclamation Emergency my car is dead!!!

I was installing a boost gauge and I tapped into my turbo timer constant on accident now my car does not have any ignition response at all. Help!!!
* Registered users of the site do not see these ads.
josh woodall is offline   Reply With Quote
Old 10-10-2003, 03:33 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
05 GTO/11 Sonata(!)

Default

Check the main fuses in the underhood fuse box, you may have blown one of those.
Mulder is offline   Reply With Quote
Old 10-10-2003, 04:13 PM   #3
josh woodall
Scooby Newbie
 
Member#: 43006
Join Date: Sep 2003
Location: San Francisco Ca.
Vehicle:
04 wrx, sti
aspen white

Default

Thanks thats it 50 amp
josh woodall is offline   Reply With Quote
Old 10-11-2003, 01:20 AM   #4
jcdeng
Scooby Newbie
 
Member#: 37161
Join Date: May 2003
Location: NYC
Vehicle:
02 WRX
Aspen White

Default

what will a blown fuse look like? cuz I car won't start also after I left my HID on for a few minutes without the engine running. I don't know if I have drained out the battery in just a few minutes or I have blown a fuse?

If I need to replace battery, which one is good? Optima? and where to get it? what part/model #?

Thanks a thousand guys.
jcdeng is offline   Reply With Quote
Old 10-11-2003, 07:48 AM   #5
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
05 GTO/11 Sonata(!)

Default

What are your no-start symptoms? If it won't crank, do the lights dim? Does it just click when you turn the key to start?
If all you did was leave the lights on and didn't mess with any wires chances are your battery is just dead or at least too weak to start the car. You can check it with a voltmeter, resting voltage with the car off and no accessories on should be about 12.5. During starting while the engine is cranking it should not drop much below 10V.
If you do need a battery the Optima is certainly a good way to go. Unless you have a high-power sound system and run it often with the engine off, your best bet for a drop-in direct replacement is a Group 35 Red-Top. Here is a link to a site that has them for an excellent price. Note the Group 35 model shown is truly a direct swap and doesn't require a longer starter cable as does the 35/75 Red-Top.
http://sites.eoi.com/folder14788/ind...568&product=11
Mulder is offline   Reply With Quote
Old 10-11-2003, 08:12 AM   #6
jcdeng
Scooby Newbie
 
Member#: 37161
Join Date: May 2003
Location: NYC
Vehicle:
02 WRX
Aspen White

Default

the lights go dim, and it just clicks when I turn the keys, (rapid click), so i guess my battery was drained, cuz I had similar symptoms wih another car...
jcdeng is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Emergency... my car is cosuming to much gas manuelmatias Subaru Conversions 7 08-04-2007 10:00 AM
Emergency... my car is cosuming to much gas manuelmatias Service & Maintenance 2 08-02-2007 06:16 PM
Emergency... my car is cosuming to much gas manuelmatias Engine Management & Tuning 1 08-02-2007 01:07 PM
my car is dead wrx_in_efx Texas Impreza Club Forum -- TXIC 8 11-16-2001 10:45 AM
My car is dead! help jjimpreza North West Impreza Club Forum -- NWIC 10 11-07-2001 10:10 PM


All times are GMT -4. The time now is 10:44 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.