Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-13-2003, 08:37 PM   #1
CRS9
Scooby Newbie
 
Member#: 7175
Join Date: Jun 2001
Location: Ft. Wayne, IN
Vehicle:
1999 Impreza 2.5RS
White

Question Question about front end link install

I just installed my Whiteline front end links tonight, and I got a quick question. On the lower bolts, I cannt seem to tighten them. It looks like they just keep spinning on the nut. I used all the all washers and everything went together fine. Is this normal behavior for these bolts?

Thanks for any info
* Registered users of the site do not see these ads.
CRS9 is offline   Reply With Quote
Old 10-14-2003, 06:10 PM   #2
CRS9
Scooby Newbie
 
Member#: 7175
Join Date: Jun 2001
Location: Ft. Wayne, IN
Vehicle:
1999 Impreza 2.5RS
White

Default ???

Anyone?
CRS9 is offline   Reply With Quote
Old 10-14-2003, 06:26 PM   #3
mav1c
Hoodbridge!
Moderator
 
Member#: 560
Join Date: Nov 1999
Chapter/Region: MAIC
Location: Woodbridge, VA
Vehicle:
2006 STi, '11 A4
Crystal Gray, Silver

Default

You mean the nut keeps spinning on the bolt? Sounds like you stripped it. Is this happenning on both sides?
mav1c is offline   Reply With Quote
Old 10-14-2003, 06:30 PM   #4
CRS9
Scooby Newbie
 
Member#: 7175
Join Date: Jun 2001
Location: Ft. Wayne, IN
Vehicle:
1999 Impreza 2.5RS
White

Default Ya

Ya, it's happening on both sides. I didnt even get to a point where they were that tight. That's why I didnt think I stripped them
CRS9 is offline   Reply With Quote
Old 10-14-2003, 06:37 PM   #5
ConeMasher
Scooby Specialist
 
Member#: 2135
Join Date: Aug 2000
Location: Chicagoland, IL, USA
Vehicle:
2002 WRX
Silver

Default

Forgive me if I'm stating the obvious, but the stock bolts require the use of an allen key to hold it in place while you work the other side with a wrench. Perhaps this is your problem.

-- Gary
ConeMasher is offline   Reply With Quote
Old 10-14-2003, 08:36 PM   #6
Arnie
Scooby Guru
 
Member#: 1725
Join Date: Jun 2000
Chapter/Region: International
Location: Germany
Vehicle:
99 Subaru Impreza
GF silver

Default

Quote:
Originally posted by ConeMasher
Forgive me if I'm stating the obvious, but the stock bolts require the use of an allen key to hold it in place while you work the other side with a wrench. Perhaps this is your problem.

-- Gary
Gary, he has an RS, GC8, no Allen bolts there.

CRS9- did you use the supplied washers? I can't remember, but are the bolts the same length? I know that the top one's use a larger head compared to the bottom bolt. You may have a longer one on the bottom, hence its not allowing you to tighten down all the way. Take a look.
Arnie is offline   Reply With Quote
Old 10-14-2003, 09:14 PM   #7
CRS9
Scooby Newbie
 
Member#: 7175
Join Date: Jun 2001
Location: Ft. Wayne, IN
Vehicle:
1999 Impreza 2.5RS
White

Unhappy Stripped

You were right the first time Gary...I stripped both of them. I had to Dremal them off and replace both bolts and nuts. Thanks for the help!!
CRS9 is offline   Reply With Quote
Old 10-15-2003, 03:48 AM   #8
Arnie
Scooby Guru
 
Member#: 1725
Join Date: Jun 2000
Chapter/Region: International
Location: Germany
Vehicle:
99 Subaru Impreza
GF silver

Default

Argh, what a bummer. but at least the hardware is relatively standard and can be replaced with another nut and bolt. did you cross thread them, or what?
Arnie is offline   Reply With Quote
Old 10-16-2003, 02:59 AM   #9
CRS9
Scooby Newbie
 
Member#: 7175
Join Date: Jun 2001
Location: Ft. Wayne, IN
Vehicle:
1999 Impreza 2.5RS
White

Default

I must have cross threaded them somehow. I tried backing them out with pressure to the end of the bolt and all it did was strip more thread. When I finally got them cut off, there was about 3/16" of thread stipped. I have no idea how I did it cause I never applied that much pressure to them. Oh well, I got the new ones in nice and tight.
CRS9 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kartboy end link install question gopsu Newbies & FAQs 0 06-07-2009 02:16 PM
FS - AZ: 06 STi f&r swaybars w/end links and BNIB Perrin front end links bObby Suspension/Brakes/Handling 7 05-19-2009 09:48 AM
Front end link installation gopsu Newbies & FAQs 8 05-08-2009 10:06 PM
FHi 20mm rear sway bar and Kartboy end links install question nuggetWRX Brakes, Steering & Suspension 11 08-11-2008 09:14 PM
tell me about your Kartboy front end links Darryl Brakes, Steering & Suspension 15 05-31-2007 12:57 AM


All times are GMT -4. The time now is 09:49 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.