Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > General Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Old 01-15-2001, 04:58 PM   #1
Kachukaa
Scooby Newbie
 
Member#: 2527
Join Date: Sep 2000
Location: Richmond, VA
Vehicle:
1997 Legacy 2.5GT
Quicksilver Metallic

Post Recent loss of power

About two months ago I installed a Weapon R intake. Instantly I could feel the difference. Lately the car doesn't seem to be generating the power it used to. I thought about an ECU reset, but was wondering if that could make me more likely to blow my MAF. Additionally I wasn't sure if the battery method or the one on the MRT site is better. Any other other suggestions on what might be wrong would be appreciated.

Pete Weir 97 2.5GT
* Registered users of the site do not see these ads.
Kachukaa is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
loss of power within 3 weeks of purchase KckAsX South East Region Forum 13 05-01-2002 05:13 PM
Loss of power scottlee Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 03-09-2002 10:36 PM
Loss of power with Unorthodox pulley fellfrosch7 Car Audio, Video & Security 11 12-24-2000 11:09 PM
Engine shudder/loss of power SSLegacyGT Normally Aspirated Powertrain 6 11-25-2000 10:56 PM
Loss of power and engine shudder SSLegacyGT Legacy Forum 12 11-23-2000 10:25 AM


All times are GMT -4. The time now is 05:22 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.