Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-17-2003, 02:43 PM   #1
staticx313
Scooby Newbie
 
Member#: 41193
Join Date: Aug 2003
Location: Huntsville, AL
Vehicle:
2004 WRX STI
Blue\Silver

Default help with sbc-id spec 3 install... urgent.

No response on imprezawrxsti.com so Im hoping maybe someone here can shed some light. Here are all my posts:

http://www.imprezawrxsti.com/postnuk...6b44bfc1#35909

So i dont have to c&p 5 posts

Robert~
* Registered users of the site do not see these ads.
staticx313 is offline   Reply With Quote
Old 10-20-2003, 08:17 PM   #2
staticx313
Scooby Newbie
 
Member#: 41193
Join Date: Aug 2003
Location: Huntsville, AL
Vehicle:
2004 WRX STI
Blue\Silver

Default

OK I got everything hooked up with the new hoses and it seemed to be working pretty nicely. My first setting was auto mode, 16 psi@ 15 gain. Warning at 17. I go and its like magic and is running awsomely. Now Im in 6th and I floor it to pass a guy on the interstate... CEL... so I think, ok ok no big deal, turn it down a little. Now im 15psi @ 15 gain... 4th gear im hitting boost cut... CEL... 15psi @14 gain... 4th gear im hitting boost cut... CEL (this is both at 14.X PSI!!!! - on the graph) I cant even run stock boost. Does anyone have any idea what to do? I have it set to 15 or 16 psi right now at 5 gain... and I can barely hit 14.5 in 3rd or 4th. I have the warning set at 14.5 so I know when Im going past stock. (also will it cut boost once it goes past warning ?? as it felt like it was throttling... I'd floor it and it'd be like pulling throttle as it was going up I guess to keep a stead psi under 14.5). So does anyone have any idea? This is really pissing me off... I cant even run stock psi with a $500 EBC... My HPBC worked better then this and took 5 seconds to instal... does aynone know what I can do?

Robert~
staticx313 is offline   Reply With Quote
Old 10-21-2003, 07:07 AM   #3
909
Scooby Newbie
 
Member#: 18776
Join Date: May 2002
Default

bad link

Last edited by 909; 10-27-2003 at 06:39 PM.
909 is offline   Reply With Quote
Old 10-21-2003, 02:37 PM   #4
HD-sw20
Gone But Not Forgotten
 
Member#: 37056
Join Date: May 2003
Chapter/Region: MWSOC
Location: 04 2.5 RS
Default

where did you guys mount the controller in the cabin? Do you have pics?
HD-sw20 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need blitz sbc id boost controller install help burke25 Electrical & Lighting 6 07-14-2009 03:02 PM
Help with sbc id III tuning Ricewagon Vancouver Impreza Club Forum -- VIC 3 08-20-2004 08:47 PM
need a blitz sbc-id spec r j-speedracer Private 'Wanted' Classifieds 0 02-23-2004 01:13 PM
SBC-ID Spec 3 EBC for sale staticx313 Private 'For Sale' Classifieds 0 11-01-2003 09:44 AM
Anyone with SBC-id and PM-id use the RPM Boost function?? Need Help!! smiles Factory 2.0L Turbo Powertrain 2 01-16-2002 10:20 AM


All times are GMT -4. The time now is 10:32 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.