Welcome to the North American Subaru Impreza Owners Club Thursday July 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-21-2003, 12:16 PM   #1
grknss
Scooby Specialist
 
Member#: 44592
Join Date: Oct 2003
Chapter/Region: South East
Location: Red Banks, MS
Vehicle:
2004 WRX STI
Platinum Silver Metallic

Question OEM Boost gauge question

Anyone know how to get to the bulb on the OEM single boost gauge on the column for the STI?

The rubberized cover needs to come off and from some diagrams I have seen it is hard to see if the bulb comes out from the rear, any ideas or hints would be great,

Thanks
* Registered users of the site do not see these ads.
grknss is offline   Reply With Quote
Old 10-24-2003, 11:47 AM   #2
ludecrous
Scooby Specialist
 
Member#: 19376
Join Date: May 2002
Chapter/Region: MWSOC
Location: chi town
Vehicle:
2003 03 WRX Wagon
silver

Default

I think it's the same guage as the one on the non STi, here goes.
Bulb is in the back, on the circuit board on the back of the gauge, you have to first remove the gauge from the rubber housing, get small flatblade screwdriver, wrap end in electrical tape to stop from stratching, get some lube spray like Tri Flow or WD40... yes you need this or it will be a bi*tch. Use the screwdriver to pry and add lube (makes it much easier)
Bulb is on back, on mine it's a small black rectangle that you twist to pull the bulb from the circuit board.

Hope this helps.
ludecrous is offline   Reply With Quote
Old 10-24-2003, 12:21 PM   #3
grknss
Scooby Specialist
 
Member#: 44592
Join Date: Oct 2003
Chapter/Region: South East
Location: Red Banks, MS
Vehicle:
2004 WRX STI
Platinum Silver Metallic

Default Thanks

That's what I had figured, I am going to tackle that tonight or tomorrow, I'll let you know and post some pics if you'd like

Thanks
grknss is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OEM Boost Gauge Question fkarkvan Electrical & Lighting 0 08-15-2009 01:38 PM
FS: OEM boost gauge AND dynotune digital boost gauge AaronWRX Mid Atlantic Impreza Club -- MAIC 3 07-14-2005 11:22 PM
Question On OEM Boost Gauge Bumsarama Electrical & Lighting 10 08-10-2004 02:14 AM
OEM boost gauge install - question WRXVII Service & Maintenance 6 12-08-2002 03:51 PM
Question about OEM boost gauge CWasko36 Factory 2.0L Turbo Powertrain 1 09-19-2002 09:55 AM


All times are GMT -4. The time now is 02:03 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.