Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-23-2003, 02:48 AM   #1
Benjamin Tang
Scooby Guru
 
Member#: 4496
Join Date: Feb 2001
Location: British Columbia Canada
Vehicle:
2009 Forester
red

Default problems with jdm hid projector install

fuse keeps blowing

jdm hid headlights on friend's 02 wrx. ballasts fire up and the lights go on, but then the fuse blows and everything dies. change fuse and restart... fuse blows again. everything is checked against my install (works fine with stock fuse) and can't find fault. even bought a second set of ballasts with same results.

what is going wrong?
* Registered users of the site do not see these ads.
Benjamin Tang is offline   Reply With Quote
Old 10-23-2003, 06:48 AM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
05 GTO/11 Sonata(!)

Default

Are your installations identical, same ballasts and all? Some ballasts will draw enough current on startup to blow the stock 15A fuse, some won't. If you have an ammeter that can measure that much current hook it up and see how much the ballast is drawing.
It is generally safe to replace the fuses with 20A ones if this is happening, although if the ballasts are actually drawing that much current it would be even better to install relays to get power directly from the battery.
Mulder is offline   Reply With Quote
Old 10-23-2003, 11:03 AM   #3
Benjamin Tang
Scooby Guru
 
Member#: 4496
Join Date: Feb 2001
Location: British Columbia Canada
Vehicle:
2009 Forester
red

Default

i spoke to my friend last night and he's basically given up. he has sold the headlights themselves separately, and would like to know what is the going rate for used sti hid ballasts?
Benjamin Tang is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP WITH JDM HID projectors sp99ling Private 'Wanted' Classifieds 7 04-14-2009 04:38 AM
Problem with JDM HID... txl146 Electrical & Lighting 17 11-10-2008 11:33 AM
post jdm hid projector install help Gr8wall Electrical & Lighting 6 09-26-2005 10:07 AM
Problem with JDM Hids, help!! Cerum Interior & Exterior Modification 1 03-02-2003 03:00 PM
JDM/EDM Projector install with HID kit...Please help Yungimoto Interior & Exterior Modification 4 01-04-2003 05:50 PM


All times are GMT -4. The time now is 02:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.