Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-24-2003, 02:46 AM   #1
pilfflip
Scooby Specialist
 
Member#: 40484
Join Date: Jul 2003
Chapter/Region: NWIC
Location: Salem, OR
Vehicle:
'02 Murdered WRX
'02 Silver Legacy

Default Brake light

I got in my car this morning to go to work and as I back out of the drive way i notice my E-brake light is on in my dash, and that the E-brake is not. I tried pulling it and letting it down again. Pressing it down a little more firmly. Nothing. The light is still there. Does anyone have any ideas?
* Registered users of the site do not see these ads.
pilfflip is offline   Reply With Quote
Old 10-24-2003, 04:37 AM   #2
fastenova
Scooby Specialist
 
Member#: 38829
Join Date: Jun 2003
Chapter/Region: NWIC
Location: Tigard, OR
Vehicle:
Not your usual 1997
Legacy GT

Default

pilfflip,

I had the same issue with mine shortly after I did my brakes. I noticed the owner's manual says that the light is activated if the e-brake is on OR if you are low on fluid... It seems that there is a sensor of some sort in the master cylinder reservoir. Since my brake fluid level was down some, I topped it off, and voila! the light went away. I haven't seen it since.

Funny, the first time I noticed it was when I was driving home in the wee hours of the morning after spending a nice night at the bars. Made me question my sobriety!

Cheers,
-A
fastenova is offline   Reply With Quote
Old 10-24-2003, 09:22 AM   #3
Legacy777
Scooby Guru
 
Member#: 4800
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
1990 Legacy & 97 OBS
AWD 5MT EJ22T AWIC Swap

Default

yup, the MC has a nice little sensor to warn of low brake fluid.

Also if you bleed your brakes and the level get's a little low, that float can sometimes stick at the bottom, even if your fluid level is fine. So you just need to reach in there and unstick it.
Legacy777 is offline   Reply With Quote
Old 10-24-2003, 01:05 PM   #4
pilfflip
Scooby Specialist
 
Member#: 40484
Join Date: Jul 2003
Chapter/Region: NWIC
Location: Salem, OR
Vehicle:
'02 Murdered WRX
'02 Silver Legacy

Default Thanks

Thanks guys i didn't know that My E-brake ran on the same idea. Put the fliud in and it was gone.

Last edited by pilfflip; 10-24-2003 at 03:18 PM.
pilfflip is offline   Reply With Quote
Old 10-25-2003, 04:59 AM   #5
biggreen96
Scooby Specialist
 
Member#: 12535
Join Date: Nov 2001
Chapter/Region: NWIC
Location: Idaho slash Washington
Vehicle:
vf39 93 Legacy Wagon
92 Legacy Rally EG33'd

Default

was it particulary cold that morning? Mine does than when really cold, and the fuild level is perfect.
biggreen96 is offline   Reply With Quote
Old 10-25-2003, 08:16 AM   #6
HomeSlice
Scooby Specialist
 
Member#: 6081
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: new york
Vehicle:
MY93 Legacy
Sonora Sand ej22t

Default

cold weather messes with the sensor sometimes.
HomeSlice is offline   Reply With Quote
Old 10-25-2003, 11:36 AM   #7
pilfflip
Scooby Specialist
 
Member#: 40484
Join Date: Jul 2003
Chapter/Region: NWIC
Location: Salem, OR
Vehicle:
'02 Murdered WRX
'02 Silver Legacy

Post Cold

Yes it was way cold yesterday morning. The brake fluid wasn't even below te half mark in the resevior either. but I filled it and the brake light went away.
pilfflip is offline   Reply With Quote
Old 10-25-2003, 12:24 PM   #8
Speedwagon
Scooby Specialist
 
Member#: 19681
Join Date: Jun 2002
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
1998 Legacy Wagon GT
Green

Default

Can't say I've read this section of my Legacy manual yet, but many cars also have the brake light come on when there is a disconnect in the brake light circuit... in other words, when a brake light is out. Just something to remember.
Speedwagon is offline   Reply With Quote
Old 10-25-2003, 10:08 PM   #9
Legacy777
Scooby Guru
 
Member#: 4800
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
1990 Legacy & 97 OBS
AWD 5MT EJ22T AWIC Swap

Default

Quote:
Originally posted by Speedwagon
Can't say I've read this section of my Legacy manual yet, but many cars also have the brake light come on when there is a disconnect in the brake light circuit... in other words, when a brake light is out. Just something to remember.
Yup I think that's true.....not sure if there's a separte lamp for that though......
Legacy777 is offline   Reply With Quote
Old 10-27-2003, 08:40 AM   #10
KD7000
Scooby Specialist
 
Member#: 16653
Join Date: Mar 2002
Chapter/Region: NESIC
Location: Central MA
Vehicle:
2012 Mazda 3
2004 Honda Pilot

Default Re: Cold

Quote:
Originally posted by pilfflip
Yes it was way cold yesterday morning. The brake fluid wasn't even below the half mark in the resevior either. but I filled it and the brake light went away.
I'm not sure how sensitive the sensor on the Legacy is, but on a couple other cars I've worked on, anything a bit below "Full" would trigger the warning light.

The reservoir has indicated full and low lines, but the sensor is somewhere in the middle. Perhaps they don't want you getting all the way down to the low point, as that is potentially approaching minimum working fluid capacity for the system.

-Brian
KD7000 is offline   Reply With Quote
Old 10-27-2003, 08:48 AM   #11
Legacy777
Scooby Guru
 
Member#: 4800
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
1990 Legacy & 97 OBS
AWD 5MT EJ22T AWIC Swap

Default

Quote:
Originally posted by legacy777
Yup I think that's true.....not sure if there's a separte lamp for that though......
I checked mine yesterday....there is a separate warning lamp to indicate if there is a brake light out. it says "stop lamp"
Legacy777 is offline   Reply With Quote
Old 10-27-2003, 12:18 PM   #12
pilfflip
Scooby Specialist
 
Member#: 40484
Join Date: Jul 2003
Chapter/Region: NWIC
Location: Salem, OR
Vehicle:
'02 Murdered WRX
'02 Silver Legacy

Post

I'm not trying to undermine anyone but i've had a brake light out in my '95 legacy for about a month and it doesn't have any kind of warning about that. But then again it's not my whole brake light, it's only one of the two lights on my left side. So technically i stilll have brake lights.
pilfflip is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB: 3rd brake light for coupe wing(GC) or coupe wing with 3rd brake light ghostmike Vancouver Impreza Club Forum -- VIC 1 11-30-2005 11:06 AM
Want to trade 05 Sti Brake lights for 06 WRX or STI Brake Lights Sti"izzle" Private 'Wanted' Classifieds 1 11-26-2005 11:12 PM
FT: 3rd brake light cover for your 3rd brake LIGHT! jimtweet Tri-State Area Forum 13 07-14-2005 04:15 PM
FT: 3rd brake light cover for your 3rd brake light jimtweet Private 'For Sale' Classifieds 1 06-06-2005 08:10 AM
Question: brake light on, clock light out, daytime running light out PhoKingWRX Electrical & Lighting 2 05-22-2005 07:29 AM


All times are GMT -4. The time now is 10:46 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.