Welcome to the North American Subaru Impreza Owners Club Thursday November 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-27-2003, 12:06 PM   #1
jslegacy
Scooby Specialist
 
Member#: 17034
Join Date: Mar 2002
Chapter/Region: MAIC
Location: fair lakes,va
Vehicle:
2005 Lotus Elise
Mercedes C230 6spd

Default has anyone ever tried taking a control off?

About a month and half ago i was in an accident, I swerved to avoid some depris, I went up an enbankment and back down into a ditch. It all happened so quick.

Well after I got the car towed out of the ditch the tow man pointed out that the control was on the front drivers side was bent. With me haveing no experience with control arms but alot with struts, brakes and other suspension stuff I thought this wouldnt be to hard.

I had the car towed back to my house a few days later I washed it off and went under to take a look, damn it sure was bent, the wheel was up against the fender and the sway bar endlink was busted. I removed the endlink and then the bolts that bolt the control arm to the frame, those werent to hard, just long threads so it took awhile. The next problem was the getting it off the ball joint. I tried sliding it off, then the hammer by hitting the control arm, still no luck. A friend told me i need a pickle fork, so i went to sears bought a set and used it. Now how this works you put it between the ball point boot and the control arm and just hammer this will eventually seperate them. It took about two minutes of trying before it just poped off. The ball joint boot was not damaged as we inspected it.

I still dont have the new control arm I should be getting it by the end of the week along with a replacement endlink for my polyeurothane ones and an ALK.

So hopefully I will be able to drive my car in about a week and a half. I have been pretty down about this because I put so much work into her and to see her just sit there for a month every day just makes me sad.


jeremy
* Registered users of the site do not see these ads.
jslegacy is offline   Reply With Quote
Old 10-27-2003, 01:55 PM   #2
etam
Scooby Specialist
 
Member#: 439
Join Date: Oct 1999
Chapter/Region: E. Canada
Location: yyz
Vehicle:
www

Default

take some pictures if possible?
etam is offline   Reply With Quote
Old 10-27-2003, 02:20 PM   #3
jslegacy
Scooby Specialist
 
Member#: 17034
Join Date: Mar 2002
Chapter/Region: MAIC
Location: fair lakes,va
Vehicle:
2005 Lotus Elise
Mercedes C230 6spd

Default

i have some at home that i can post later tonight of what the damage looked liked. and then when the weather clears up i will get underneath it again to take some more pics of where i removed the bolts.

also i will take some of the installation process when that comes around.

jeremy
jslegacy is offline   Reply With Quote
Old 10-29-2003, 05:36 AM   #4
STIwish
Scooby Newbie
 
Member#: 36298
Join Date: May 2003
Vehicle:
03 WRX
WR Blue

Default

Man, I feel your pain, I wrecked my car last night thanks to a deer in the road, i ended up flying sideways through a reflector pole and bouncing off a giant boulder... My control arm bent as well, so my WRX is down for the count till the parts come in.
STIwish is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Exhaust O2 fix - has anyone ever tried...?? brianbot5000 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 08-14-2004 10:10 AM
Has anyone ever tried accutane? wix Off-Topic 21 08-26-2003 07:35 PM
has anyone ever tried Griots products? imprezzed Interior & Exterior Modification 5 07-14-2003 12:14 PM
Has anyone ever tried..... Omis Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 0 10-21-2002 05:08 PM
Has anyone ever tried Sumitomo HTR Z II tires? Robmat Brakes, Steering & Suspension 8 04-24-2001 09:23 AM


All times are GMT -4. The time now is 08:49 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.