Welcome to the North American Subaru Impreza Owners Club Saturday April 25, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-03-2003, 04:54 PM   #1
eightballrj
Scooby Specialist
 
Member#: 18520
Join Date: May 2002
Chapter/Region: South East
Location: MS
Vehicle:
2005 L GT Limited
Black

Default Anyone had to replace their front O2 sensor?

I was just wondering if anyone has had to do this. Also, what tipped you off that you needed to change it if you have done this??

RJ
* Registered users of the site do not see these ads.
eightballrj is offline   Reply With Quote
Old 11-03-2003, 06:01 PM   #2
Thumper23
Scooby Specialist
 
Member#: 11571
Join Date: Oct 2001
Chapter/Region: MAIC
Location: Virginia Beach, VA
Default

sometimes, a misfire CEL will be a good indication
Thumper23 is online now   Reply With Quote
Old 11-03-2003, 07:39 PM   #3
1wickedwrx
Scooby Newbie
 
Member#: 45134
Join Date: Oct 2003
Location: Santa Cruz, Ca
Vehicle:
2002 WRX
Blue

Default

I have to replace my front O2 sensor. It is largely due to the fact that I run it on C12 (110 octane, leaded) which pretty much toasted it. After I replace it, I am going to try 105 unleaded and see what happens.

If I may go off topic here, I noticed in your profile you have a 6speed in your '02. If I may ask you, what was the cost in the conversion/labor in addition to the tranny? I've been considering this, since I have had to rebuild mine. The 5spd just can't handle 400 ponies.

Jeromey
1wickedwrx is offline   Reply With Quote
Old 11-03-2003, 08:12 PM   #4
Big Turkey
Scooby Specialist
 
Member#: 32118
Join Date: Jan 2003
Location: Houston, TX
Default

I run C16 every now and then. So I think i'm going to have to replace the o2 sensor sometime in the future. They retail for $180 at the dealer

1wickedwrx, what were the symptoms to let you knw you had to get the sensor replaced?
Big Turkey is offline   Reply With Quote
Old 11-03-2003, 08:31 PM   #5
eightballrj
Scooby Specialist
 
Member#: 18520
Join Date: May 2002
Chapter/Region: South East
Location: MS
Vehicle:
2005 L GT Limited
Black

Default

Well,
It is just that throttle response is kinda slow now and I was wondering if maybe I just needed a new O2 sensor maybe.

RJ
eightballrj is offline   Reply With Quote
Old 11-04-2003, 01:22 PM   #6
1wickedwrx
Scooby Newbie
 
Member#: 45134
Join Date: Oct 2003
Location: Santa Cruz, Ca
Vehicle:
2002 WRX
Blue

Default

Hey Big Turkey!

How long you been running C16? Is is leaded or unleaded? I ran C12 for about 6 months or so. The CEL light would come on and it always was code P1131, Front O2 sensor failure. I was able to erase the code, but it would eventually come back. Now it just stays on and refuses to be erased. So I pulled the sensor and it is pretty coated. Lead fuel will do that. That's why it's not good to run that type of fuel if you have any cats. It will destroy them. So I am gonna replace the sensor and try running unleaded racing fuel. I should only loose about 5 hp switching to unleaded. We'll see how it goes.

Jeromey
1wickedwrx is offline   Reply With Quote
Old 11-04-2003, 03:09 PM   #7
Big Turkey
Scooby Specialist
 
Member#: 32118
Join Date: Jan 2003
Location: Houston, TX
Default

C16 is 117 leaded fuel. I can't switch to unleaded because that's what I'm tuned for. I've been running it for about 2 months now, maybe 5 times total. How often did you run it? All the time? Or just every weekend?
Big Turkey is offline   Reply With Quote
Old 11-04-2003, 07:42 PM   #8
1wickedwrx
Scooby Newbie
 
Member#: 45134
Join Date: Oct 2003
Location: Santa Cruz, Ca
Vehicle:
2002 WRX
Blue

Default

I run 110 almost every weekend. The WRX is driven pretty much on the weekends only at the track, or whenever I need an adrenaline rush! It's probably been about 6 or 7 months now running on C12. I mainly use it so I can run safely on nitrous without any knock. But thinking lately about switching to auto-cross or rally. So I'll be taking off the nitrous soon.

Jeromey
1wickedwrx is offline   Reply With Quote
Old 11-06-2003, 04:26 PM   #9
04EJ20
Scooby Newbie
 
Member#: 44057
Join Date: Sep 2003
Location: Old Bridge, NJ
Vehicle:
2004 WRX STi
WR Blue Pearl

Default

My last 2 cars were VW's and the O2 sensors would go like crazy! I never could figure out why, but I always had a CEL on. Knock on wood, no problems so far w/ my Rex...

04EJ20 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Time to replace my front o2 sensor... BlkTS02 Normally Aspirated Powertrain 13 07-30-2011 11:36 PM
Can I use my LC-1 Narrowband Signal to replace my factory O2 Sensor? nicholam Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 9 03-21-2008 10:44 PM
Place to get a front O2 sensor? Texas25RS Texas Impreza Club Forum -- TXIC 27 01-28-2004 03:14 PM
Has anyone had to rebuild their front 2-piston calipers? Patrick Olsen Brakes, Steering & Suspension 1 05-02-2002 01:14 AM
how important is it to get the front o2 sensor replaced? inpreza kid Canada Region Forum 1 08-02-2001 02:35 PM


All times are GMT -4. The time now is 04:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.