Welcome to the North American Subaru Impreza Owners Club Friday October 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > 'Old School' Subaru Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-08-2003, 06:36 PM   #1
starbuckjunkee
Scooby Newbie
 
Member#: 48046
Join Date: Nov 2003
Vehicle:
85 suburu
baby blue

Default Fix my heater.....please it's getting cold

I have a 1985 suburu that I'm sure is dyslexic! In the summer the air blows out hot and in the winter the air blows cold. What's my problem? I can't go through another winter with my kids freezing. The thermostat is new, the radiator is filled and the water pump is new. I've ran out of ideas to fix! When I turn on the defrost the fan blows but it blows cold air. Thank you for any help, my kids and I are very grateful.

Elise
* Registered users of the site do not see these ads.
starbuckjunkee is offline   Reply With Quote
Old 11-08-2003, 07:34 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

If you're sure the thermostat is working properly and you still don't have heat, it's possible the heater core is clogged. Has the antifreeze been changed regularly and is the system clean inside? It's possible a flush would help, or the core might have to be removed to be checked and blown out. It might also just need to be replaced if it can't be fully cleaned.
It's also possible there is a problem with the HVAC controls for temperature and air blending. Check the cables and make sure they are operating properly.
Mulder is offline   Reply With Quote
Old 11-08-2003, 09:42 PM   #3
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default

In older cars, it's pretty common for the cabling to snap/come loose for the HVAC system - there is usually a cable actuated valve which diverts coolant to the heater core - check to see that it's operating properly.
DrD is offline   Reply With Quote
Old 11-08-2003, 10:07 PM   #4
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

That's true, I haven't had to work on one in so long I forgot, but if there is a heater control valve it may well be the problem. The valve could be frozen or as mentioned the control cable or mechanism might be broken. I'm not familiar enough with older Subies to know for sure if your car has such a valve.
Newer cars generally have full-time coolant flow through the heater core and no longer use these valves.
Mulder is offline   Reply With Quote
Old 11-09-2003, 04:46 PM   #5
starbuckjunkee
Scooby Newbie
 
Member#: 48046
Join Date: Nov 2003
Vehicle:
85 suburu
baby blue

Default

Thanks! You guys are super!
I'll let ya know what happens after I try these.

Elise
starbuckjunkee is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater gets cold when at a stop MikalsWRX Newbies & FAQs 2 03-25-2008 07:20 PM
It's so cold my nipples tore a hole in my shirt MGXsport Off-Topic 15 09-16-2006 08:15 PM
FS: Stuff so I can fix my car! please look! 96Imprezadent Private 'For Sale' Classifieds 0 11-30-2004 09:56 PM
it's getting cold. Akirasoft Off-Topic 22 11-20-2004 03:42 AM
It's getting cold in here, So put on some more clothes Fish Off-Topic 36 12-10-2002 11:42 PM


All times are GMT -4. The time now is 05:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.