Welcome to the North American Subaru Impreza Owners Club Tuesday May 3, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > General Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Old 06-15-2000, 01:04 PM   #1
Sean McElderry
Scooby Specialist
 
Member#: 526
Join Date: Nov 1999
Location: Beaverton, OR, USA
Vehicle:
1995 Supra Turbo
Red

Question Minnam Turbo Owners - What psi are you running?


I've got five questions for all Minnam turbo owners:

1) What stage (I, II) are you running?
2) What psi are you running at?
3) How many miles have you been running at that psi?
4) What year is your car?
5) Have you noticed any detrimental effects?

My stage II goes in Monday (in my MY00 RS) and I'm wondering if I should consider 10psi. Thanks!

Sean
* Registered users of the site do not see these ads.
Sean McElderry is offline  
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-15-2000, 01:16 PM   #2
MattC
Scooby Specialist
 
Member#: 158
Join Date: Aug 1999
Chapter/Region: NESIC
Location: CT
Vehicle:
2011 STi
PBP 1999 2.5RS RBP

Cool

When I got the kit I couldn't run less than 7psi. As it broke in that went up to 8psi. You cannot run anymore than that safely, without raising fuel pressures. I will be installing a 20002 bel FPR along with a Paxton FPR next week. At that time I will raise the boost to 10psi. Oh, I have had the kit for 3 months, and have put 3k miles on it. No real problems with it yet. You won't believe the difference it makes! Night and Day, I'm telling you.

MattC
MattC is offline  
Old 06-15-2000, 01:49 PM   #3
Sean McElderry
Scooby Specialist
 
Member#: 526
Join Date: Nov 1999
Location: Beaverton, OR, USA
Vehicle:
1995 Supra Turbo
Red

Question


And what year is your car? Thanks!

Sean
Sean McElderry is offline  
Old 06-15-2000, 02:20 PM   #4
adam99rs
Scooby Specialist
 
Member#: 20
Join Date: Jun 1999
Location: New York
Post

a tick under 17 psi (1.1 bar), but with substantial mods to fuel and also timing manipulations via the A'pex ITC.
Matt - why are you getting a Paxton AND a Bell FPR? I do run around with the car at this level for much of the time, but also turn it down to .75 bar when I am just not in the mood for speed. Mine is a 99 BTW, with 38k total, and about 29k of that turbo'd.
adam99rs is offline  
Old 06-15-2000, 03:29 PM   #5
Wreckleford
Scooby Newbie
 
Member#: 887
Join Date: Feb 2000
Post

Hey Adam, correct me if I am wrong, but I thought 1 bar = 14.7 psi.
Wreckleford is offline  
Old 06-15-2000, 05:27 PM   #6
Molez93
Scooby Newbie
 
Member#: 585
Join Date: Dec 1999
Location: Rochester, NY
Vehicle:
02 WRX
WR Blue

Angry

1) Stage 2
2) 3 psi [Not that I'm happy with that fact]
3) All 2k since March
4) 98
5) From the Kit? No. From the install? Yes- Too many issues to list.
6) Misc stuff- The exhaust piping required a reweld so it would fit in two different places. Asside from that, all the shop needed was a decent set of directions (which didn't come with the kit) to complete the job.
My best guess at this point is that the Turbonetics wastegate had a 3 psi spring in it from the 'factory.' I've produced as much as 10 psi by bypassing the wastegate. I'm still working through the remdies so maybe I'm wrong.
-Scott
Harrisburg Pro Solo bound in 14 hours...
Molez93 is offline  
Old 06-15-2000, 08:34 PM   #7
MattC
Scooby Specialist
 
Member#: 158
Join Date: Aug 1999
Chapter/Region: NESIC
Location: CT
Vehicle:
2011 STi
PBP 1999 2.5RS RBP

Post

The bell unit becomes active above 7psi, the paxton regulates normally. I want to run 10psi, and liked this configuration. BTW, my car is a 99.

MattC
MattC is offline  
Old 06-16-2000, 05:01 AM   #8
SteveS
Scooby Specialist
 
Member#: 6
Join Date: Jun 1999
Location: South Jersey
Vehicle:
2007 BMW Z4 M Coupe
Interlagos Blue

Post

1) Stage II
2) Have been running about 5.5psi, but working to up that to 8-10psi.
3) 16K miles (1 year this month)
4) MY98
5) No detrimental effects.

The Bell FPR (20005) was just installed last night. Accidently running my car at 12+psi while tuning caused no ill side effects (other than a huge grin on my face). I had to remove the Hallman MBC I recently installed because I could not get it to regulate my boost UNDER 12psi, and I'm not sure where it would have maxed out.

SteveS
http://www.lagging.com
SteveS is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Whats psi are you running on stock turbo killichnakropf Newbies & FAQs 7 05-27-2010 01:13 PM
what psi are you running on stage 2 wrx the real suby dude AccessPort 14 05-21-2007 02:59 PM
RS owners, what speakers are you running in the rear deck.. munkis Tri-State Area Forum 17 05-30-2004 08:54 PM
Wagon Owners What Coilovers Are You Running? nathanellis Brakes, Steering & Suspension 12 05-17-2004 03:18 AM
What psi are you running in your RE92s? Enkidu Tire & Wheel 21 11-12-2003 05:59 AM

All times are GMT -4. The time now is 04:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.