Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-16-2003, 10:13 PM   #1
StewedSquirrel
Scooby Newbie
 
Member#: 48509
Join Date: Nov 2003
Vehicle:
1998 Impreza OBS
Red/Grey

Default I killed it! help!

I was just replacing the spark plugs...

now when I start it, it sounds ok for about 10 seconds and then boggs and quickly dies...

ack!! what did I do?

I checked all the rubber boots to make sure they were firmly pressed into the hole and I'm sure all 4 plugs are firmly screwed in...

ack, it took a very long time to replace those, mostly because I don't have a flexible neck on my socket... my back hurts and I just want to take a drive....

*sighs*

help...

Eric
* Registered users of the site do not see these ads.
StewedSquirrel is offline   Reply With Quote
Old 11-16-2003, 10:46 PM   #2
SubeTek
Scooby Specialist
 
Member#: 1714
Join Date: Jun 2000
Chapter/Region: RMIC
Location: Arvada,Co
Vehicle:
1999 RS-T COUPE
Black

Default

Check the large hose going to the air intake next to the filter-it probably got knocked off. Let me know if there's anything else i can do.

Bret Carter
Mike Shaw Subaru/Flat4Engineering
SubeTek is offline   Reply With Quote
Old 11-16-2003, 11:07 PM   #3
StewedSquirrel
Scooby Newbie
 
Member#: 48509
Join Date: Nov 2003
Vehicle:
1998 Impreza OBS
Red/Grey

Default

Do you mean in the main intake hose? Or something smaller than that?

I did lift the intake over the filter to reach #3, but I put it back. There is just one electrical wire coming out of the box just above the filter.

Thanks for trying to help. If that's not it, would there be anything else?

Eric
StewedSquirrel is offline   Reply With Quote
Old 11-16-2003, 11:16 PM   #4
SubeTek
Scooby Specialist
 
Member#: 1714
Join Date: Jun 2000
Chapter/Region: RMIC
Location: Arvada,Co
Vehicle:
1999 RS-T COUPE
Black

Default

I PM'd you. Let me know if there's more i can do.

Bret Carter
Mike Shaw Subaru/Flat4Engineering
SubeTek is offline   Reply With Quote
Old 11-16-2003, 11:46 PM   #5
ImprezaRS dot com
over boosted again
Moderator
 
Member#: 1458
Join Date: May 2000
Chapter/Region: RMIC
Location: Colorado Springs CO USA
Vehicle:
2013 B9 Tribeca LTD
2005 Impreza 2.5 RS

Default

It is your idle control valve vacuum hose (about 7/8" rubber hose), which should run from the throttle body to the intake just behind the MAF. When you lifted the intake you unplugged it I bet.
ImprezaRS dot com is offline   Reply With Quote
Old 11-16-2003, 11:52 PM   #6
StewedSquirrel
Scooby Newbie
 
Member#: 48509
Join Date: Nov 2003
Vehicle:
1998 Impreza OBS
Red/Grey

Default

The most excellent and gracious "SubeTek" solved the problem. Props to Impreza RS for having the solution also.

Idle control vacuum hose it is!! :-)

Lo and behold, it had come loose and I hadn't seen it, being under the main intake hose.

Many thanks to Bret AKA SubeTek and the rest.

My new halogen driving lights (with fancy blue LED trim) also work quite nice and the dash-mounted switch looks almost factory. :-)

I was going to go out and adjust the lights earlier (don't want to blind anyone), but now I'm all tired out. :-D

I think I'll go take it for a spin. Thanks again.

Eric
StewedSquirrel is offline   Reply With Quote
Old 11-17-2003, 12:35 AM   #7
hoodwho
Scooby Specialist
 
Member#: 1986
Join Date: Jul 2000
Chapter/Region: RMIC
Location: 05 swap... finally
Vehicle:
1998 WRX Coupe
Black Diamond Pearl

Default

thats what i was gonna say too...

haha I did that once.... scared the sh...poo outta me...

hoodwho is offline   Reply With Quote
Old 11-17-2003, 02:40 AM   #8
ImprezaRS dot com
over boosted again
Moderator
 
Member#: 1458
Join Date: May 2000
Chapter/Region: RMIC
Location: Colorado Springs CO USA
Vehicle:
2013 B9 Tribeca LTD
2005 Impreza 2.5 RS

Default

Yeah, except Bret said it was next to your air filtter, and I had to tell you it was running from the TB to behind the MAF
ImprezaRS dot com is offline   Reply With Quote
Old 11-17-2003, 03:16 AM   #9
StewedSquirrel
Scooby Newbie
 
Member#: 48509
Join Date: Nov 2003
Vehicle:
1998 Impreza OBS
Red/Grey

Default

Well, Bret told me that in a PM. But you were only a few minutes behind him. :-)

heh

Not to uhhh steal your thunder or anything. :-)

Thanks,
Eric
StewedSquirrel is offline   Reply With Quote
Old 11-17-2003, 11:29 AM   #10
hoodwho
Scooby Specialist
 
Member#: 1986
Join Date: Jul 2000
Chapter/Region: RMIC
Location: 05 swap... finally
Vehicle:
1998 WRX Coupe
Black Diamond Pearl

Default

Quote:
Originally posted by ImprezaRS dot com
Yeah, except Bret said it was next to your air filtter, and I had to tell you it was running from the TB to behind the MAF
way to go bret. you were a few inches off... pssshh.



hoodwho is offline   Reply With Quote
Old 11-18-2003, 12:41 AM   #11
ImprezaRS dot com
over boosted again
Moderator
 
Member#: 1458
Join Date: May 2000
Chapter/Region: RMIC
Location: Colorado Springs CO USA
Vehicle:
2013 B9 Tribeca LTD
2005 Impreza 2.5 RS

Default

Quote:
That's what she said the other night
ImprezaRS dot com is offline   Reply With Quote
Old 11-18-2003, 12:46 AM   #12
bbbwrx
Scooby Specialist
 
Member#: 32734
Join Date: Feb 2003
Chapter/Region: RMIC
Default

Quote:
Originally posted by hoodwho
thats what i was gonna say too...

haha I did that once.... scared the sh...poo outta me...

Yeah me to

BEN
bbbwrx is offline   Reply With Quote
Old 11-18-2003, 12:29 PM   #13
hoodwho
Scooby Specialist
 
Member#: 1986
Join Date: Jul 2000
Chapter/Region: RMIC
Location: 05 swap... finally
Vehicle:
1998 WRX Coupe
Black Diamond Pearl

Default

Quote:
Originally posted by bbbwrx
Yeah me to

BEN
haha

worst part is you cant even see it... unless you pick up the plenum.. sucked.

nice one larry... haha
hoodwho is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OMG kill it kill it!!!! rage557 Off-Topic 16 07-15-2009 12:18 AM
Chad killed it... and it wasn't my fault MK19_ South East Region Forum 10 04-03-2006 09:56 PM
I will kill the next application that steals my focus. Kill it DEAD. gongzero Off-Topic 24 09-10-2003 03:43 PM
Washed my car and thought I killed it YeeHa Factory 2.0L Turbo Powertrain 8 08-09-2001 10:48 AM


All times are GMT -4. The time now is 05:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.