Welcome to the North American Subaru Impreza Owners Club Saturday December 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-09-2003, 12:26 AM   #1
98LegacyGT
Scooby Newbie
 
Member#: 37354
Join Date: May 2003
Location: Calgary, AB, Great White North
Vehicle:
1998 Legacy GT
Silver

Default HVAC Problem

Hey guys,

I just changed the HVAC bulbs in my 98 Legacy GT . . . it's nice to be able to see the HVAC controls at night!

Unfortunately, after I put everything back together, I am no longer getting any hot air from the vents when I set the temp control in the "red zone" of the gauge (ie. hot temp). Can anyone help me out and let me know what may be causing this?? Thanks.
* Registered users of the site do not see these ads.
98LegacyGT is offline   Reply With Quote
Old 12-09-2003, 02:37 PM   #2
MikeKlacy
Scooby Newbie
 
Member#: 47775
Join Date: Nov 2003
Chapter/Region: NWIC
Location: Magnolia, Seattle
Vehicle:
2005 LGT Wagon
Regal Blue Pearl

Default

whats the part number for the HVAC bulb? I too need to fix em'.
MikeKlacy is offline   Reply With Quote
Old 12-10-2003, 03:38 PM   #3
Charlie-III
Scooby Specialist
 
Member#: 30669
Join Date: Dec 2002
Chapter/Region: Tri-State
Location: 07456, North NJ
Vehicle:
1998 Legacy 2.5GT
Silver Sleeper Wagon

Default

I would guess a control rod is no longer connected, or a vaccuum line is crimped.

Probably the best thing is to pull it apart again.
Charlie-III is offline   Reply With Quote
Old 12-10-2003, 05:16 PM   #4
richeich
Scooby Specialist
 
Member#: 1353
Join Date: Apr 2000
Vehicle:
2001 Impreza 2.5RS
Silver

Default

Did you get the steel cable re-attached. It's connected to the temp control lever, and goes down to the right of the console up under the dash a bit. It controls the temperature, and if it's loose at one end or the other, it won't control squat! I've done a couple of different HVAC's now, and have discovered that it's easier to disconnect that cable down at the bottom end, under the dash. It's just easier to reach.

Hey Mike, for instructions and maybe even pictures, check www.scoobymods.com and see if you can find it there. It shouldn't be too hard. I'll check around over there and give you a direct link.

Rich
richeich is offline   Reply With Quote
Old 12-10-2003, 05:19 PM   #5
richeich
Scooby Specialist
 
Member#: 1353
Join Date: Apr 2000
Vehicle:
2001 Impreza 2.5RS
Silver

Default

Here it is... link
richeich is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HVAC problem sum0325 Electrical & Lighting 8 02-15-2009 07:33 PM
HVAC problems Matt Mid Atlantic Impreza Club -- MAIC 0 02-23-2008 10:44 PM
HVAC problems qoncept Service & Maintenance 2 12-19-2005 04:58 PM
HVAC problems! SubaruImpreza_power Service & Maintenance 6 01-29-2004 01:28 AM
HVAC Problem 98LegacyGT Electrical & Lighting 2 12-10-2003 12:17 PM


All times are GMT -4. The time now is 12:53 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.