Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > UTEC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-05-2004, 05:19 PM   #26
Desolate One
Scooby Newbie
 
Member#: 22797
Join Date: Aug 2002
Location: Las Vegas
Vehicle:
2003 WRX Wagon
Silver

Default

Quote:
Originally posted by Desolate One
I was thinking along the same lines as far as the ABC is concerned. Now when you say "all the way" do you mean counter-clockwise? I was going to give it a go that way this weekend that way, unless otherwise it should be turned all the way clockwise!
I'm sorry guys, I should have looked at the thing! There's an arrow on it w/ a + and - sign.

Well the UTEC is in and I'm running the base stage 1 map. I haven't been able to take her out and give it full throttle to adjust the ABC, but I do notice that boost builds much faster! The few short times I've been able to give it WOT I've noticed my boost gauge only goes up to .05-.07 Mpa. I've adjusted the ABC 4 full turns up and .07 Mpa is the highest I've gotten. Is there any way to check the accuracy of my boost gauge?

Thanks again for all the help.
* Registered users of the site do not see these ads.
Desolate One is offline   Reply With Quote
Old 05-08-2004, 03:26 PM   #27
SGOSWRX
Scooby Specialist
 
Member#: 10921
Join Date: Oct 2001
Location: S.W. Florida
Vehicle:
04 04 STi
12.8 @ 105 mph

Default

Quote:
Originally posted by Desolate One
I'm sorry guys, I should have looked at the thing! There's an arrow on it w/ a + and - sign.

Well the UTEC is in and I'm running the base stage 1 map. I haven't been able to take her out and give it full throttle to adjust the ABC, but I do notice that boost builds much faster! The few short times I've been able to give it WOT I've noticed my boost gauge only goes up to .05-.07 Mpa. I've adjusted the ABC 4 full turns up and .07 Mpa is the highest I've gotten. Is there any way to check the accuracy of my boost gauge?

Thanks again for all the help.

Can you turn it up anymore? Usually you need to crank it several turns before it will start to make more boost than stock. All the sudden it will get to a point where it starts to increase boost.
SGOSWRX is offline   Reply With Quote
Old 07-09-2004, 10:13 PM   #28
fatray
Scooby Specialist
 
Member#: 18150
Join Date: Apr 2002
Chapter/Region: MAIC
Location: Baltimore MD
Vehicle:
2002 WRX Wagon EJ207
Velocity Red, Liberal kit

Default

You do not have your 3/16" resistor in your boost control line. It says right in the directions for the UTEC, you must have it or you wont boost past 7psi. Even shows a diagram on were it should be installed.
fatray is offline   Reply With Quote
Old 07-26-2004, 02:16 PM   #29
Desolate One
Scooby Newbie
 
Member#: 22797
Join Date: Aug 2002
Location: Las Vegas
Vehicle:
2003 WRX Wagon
Silver

Default

SGOSWRX- After some time boost did get up there. Had to bring it back down though (to about 2 turns).

fatray- Indeed, I removed the 3/16" resistor as per the instructions. Everything ran fine until one day it wouldn't start. Well it would start but would die right away as if I wasn't holding compression. I removed the UTEC (thus my inactivity on this forum, sorry) and has since been fine. I'm planning on finishing up my physical mods then have the UTEC tuned by a pro.

Thanks for the concern and interest. I'll let you guys know how it all pans out.
Desolate One is offline   Reply With Quote
Old 08-23-2004, 11:13 PM   #30
kettsupp
Scooby Specialist
 
Member#: 68891
Join Date: Aug 2004
Location: socal carson
Default

is utec reliable?
kettsupp is offline   Reply With Quote
Old 09-24-2004, 09:41 AM   #31
ImprezivEJ20
Scooby Newbie
 
Member#: 50520
Join Date: Dec 2003
Chapter/Region: MAIC
Vehicle:
2002 WRX

Default

if you use it wisley and correctly
ImprezivEJ20 is offline   Reply With Quote
Old 10-09-2004, 03:35 AM   #32
STI DUDE
Scooby Newbie
 
Member#: 49274
Join Date: Nov 2003
Vehicle:
2004 STI
SILVER

Default Help

Sorry if this has been brought up before but I would like to know what the best thing is to do if you do mods that include bigger turbo, bigger fuel pump, rails and basically anything that alters the a/f ratio. Are there maps out there for the UTEC (STI) that you could just load up or is professional tuning essential in this case?
Thanx.
STI DUDE is offline   Reply With Quote
Old 10-11-2004, 12:22 AM   #33
Desolate One
Scooby Newbie
 
Member#: 22797
Join Date: Aug 2002
Location: Las Vegas
Vehicle:
2003 WRX Wagon
Silver

Default

Quote:
Originally Posted by STI DUDE
Sorry if this has been brought up before but I would like to know what the best thing is to do if you do mods that include bigger turbo, bigger fuel pump, rails and basically anything that alters the a/f ratio. Are there maps out there for the UTEC (STI) that you could just load up or is professional tuning essential in this case?
Thanx.
No base maps for those mods. The best (read: reliable) way of handling this scenario would be a professional tune.
Desolate One is offline   Reply With Quote
Old 10-22-2004, 07:44 PM   #34
D_Block
Scooby Guru
 
Member#: 64127
Join Date: Jun 2004
Chapter/Region: MAIC
Location: www.niketalk.com
Vehicle:
2001 PY ITR, 2012 X5
on order

Default

Got a UTEC n00b ?. I just got my map selector switch. It says it is plug and play, however there are two wires coming off the switch. Do I need to put these to a fuse or are these accesorry wires for a launch control unit, etc? Can I just plug it up and into my blank without having to ground the wires? Thanks for helping a n00b!
D
D_Block is offline   Reply With Quote
Old 10-22-2004, 10:04 PM   #35
fatray
Scooby Specialist
 
Member#: 18150
Join Date: Apr 2002
Chapter/Region: MAIC
Location: Baltimore MD
Vehicle:
2002 WRX Wagon EJ207
Velocity Red, Liberal kit

Default

Those are Launch Control wires you need to hook up to your clutch. Let me follow the link below and read the directions and I will let you know for sure.

Read The Directions LINK

Last edited by fatray; 10-22-2004 at 10:13 PM.
fatray is offline   Reply With Quote
Old 10-30-2004, 06:45 PM   #36
jayblizzo
Scooby Newbie
 
Member#: 58957
Join Date: Apr 2004
Chapter/Region: Tri-State
Location: New York, NY
Vehicle:
2010 WRX STI
SSM

Default

Quote:
Originally Posted by mick_the_ginge
UTEC Quick Tune Guide

The above is the basics of tuning your UTEC.

To load maps you don't have to take up the carpet, just leave the serial cable accessable.

To swap between maps you will need the TurboXS remote map selector switch which is an additional item.

To load firmware you will have to lift the carpet. New Firmware releases come out about every 6-9 months.

Currently the UTEC only takes control of the fueling and timing over 60% TPS. The Boost can be controlled by the UTEC at any TPS position. The reason that the UTEC waits until 60% TPS is that before this the ECU is running closed loop fuel control. You car will run better with the ECU running this section.
i keep trying to get into this.. i can log into the forums but cant log into the downloads... anyone have it? can you send it to jayblizzo@aol.com? or can anyone tell me how to get to it thanks
jayblizzo is offline   Reply With Quote
Old 12-16-2004, 01:21 AM   #37
mick_the_ginge
Citizen Mick
 
Member#: 27646
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Portland, Oregon
Vehicle:
2003 Sleeved 2.5
Oil Dry Sump Goodness

Default

I had a little spare time so I updated the UTEC Quick Tune Guide.

Minor updates and some additional information on open loop fueling.

Slides only
http://www.pdxtuning.com/utec_tune_g...12_02_2004.pdf

Slides and Mick's notes pages
http://www.pdxtuning.com/utec_tune_g...2004-notes.pdf

Thanks to PDXTuning for hosting the updated Quick Tune Guide

Last edited by mick_the_ginge; 01-05-2005 at 09:54 AM.
mick_the_ginge is offline   Reply With Quote
Old 01-24-2005, 11:09 PM   #38
sqc151
Scooby Specialist
 
Member#: 51432
Join Date: Dec 2003
Chapter/Region: Tri-State
Default

i cant get any of these dl...
sqc151 is offline   Reply With Quote
Old 01-25-2005, 11:40 AM   #39
mick_the_ginge
Citizen Mick
 
Member#: 27646
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Portland, Oregon
Vehicle:
2003 Sleeved 2.5
Oil Dry Sump Goodness

Default

Well they are their... they are in PDF format, you will need the free Acrobat PDF reader.
mick_the_ginge is offline   Reply With Quote
Old 01-25-2005, 03:07 PM   #40
AaronWRX
Scooby Specialist
 
Member#: 7194
Join Date: Jun 2001
Chapter/Region: MAIC
Location: NoVa
Vehicle:
2011 997.2 Turbo
Black

Default

proposed addendum:

If you don't have a laptop, or easy access to one, don't buy a Utec.
AaronWRX is offline   Reply With Quote
Old 01-25-2005, 03:12 PM   #41
bunot
Scooby Specialist
 
Member#: 21641
Join Date: Jul 2002
Chapter/Region: International
Vehicle:
4EAT 12.185@110.34
Now a 6MT! beyatch!

Default

just wanna thank mick for writing the utec tuning guide....it's a godsend.
bunot is offline   Reply With Quote
Old 01-26-2005, 09:04 AM   #42
sqc151
Scooby Specialist
 
Member#: 51432
Join Date: Dec 2003
Chapter/Region: Tri-State
Default

Quote:
Originally Posted by mick_the_ginge
Well they are their... they are in PDF format, you will need the free Acrobat PDF reader.
and how do i do that...
sqc151 is offline   Reply With Quote
Old 01-28-2005, 04:15 PM   #43
dl337j00
Scooby Specialist
 
Member#: 58049
Join Date: Mar 2004
Location: Winnipeg, Canada
Vehicle:
1990 Skyline GTR
Gunmetal Grey

Default

you smack your computer until a team of elves scurries out behind your computer, and types www.adobe.com into your web browser... they will then click on the free-acrobat-reader...
dl337j00 is offline   Reply With Quote
Old 02-04-2005, 08:30 PM   #44
Pomorski
Scooby Newbie
 
Member#: 60313
Join Date: Apr 2004
Chapter/Region: South East
Location: Apartment 5F
Vehicle:
2011 Impreza WRX STi
SWP

Default

right click link, then select "Save Link Target As..." and this will download the pdf.
Pomorski is offline   Reply With Quote
Old 02-11-2005, 08:26 PM   #45
Hoss1
Scooby Newbie
 
Member#: 81202
Join Date: Feb 2005
Default Hazard lts no longer flash after mods??

I just installed a turbo back (and a CEL fix), K&N intake, and utec turbo XS. First I had the CEL & flashing cruise light problem, and the hazard lights stopped flashing when I arm and disarm the car. The CEL fix worked for the criuse light, but the hazard lights still dont flash. Any ideas?
Hoss1 is offline   Reply With Quote
Old 02-15-2005, 10:53 PM   #46
black05wrx23
Scooby Newbie
 
Member#: 68642
Join Date: Aug 2004
Chapter/Region: South East
Location: Miami
Vehicle:
05 wrx
black

Default

I have a problem guys my utec starts up and log ok and everything but when I go to download a map from lets say turboxs it tells me error map corrupt. I dont know why ive tried different maps and still nothing I dont know whats going on can anyone help.
black05wrx23 is offline   Reply With Quote
Old 02-16-2005, 12:53 AM   #47
TurboXS (Pete)
Scooby Newbie
 
Member#: 16704
Join Date: Mar 2002
Location: Sydney (Australia)
Default

Make sure you are using "Send Text File" and not "Send File" in Hyperterminal.

Otherwise try another computer, preferably one with a serial port.

regards
Pete
(TurboXS)
TurboXS (Pete) is offline   Reply With Quote
Old 02-16-2005, 09:35 AM   #48
black05wrx23
Scooby Newbie
 
Member#: 68642
Join Date: Aug 2004
Chapter/Region: South East
Location: Miami
Vehicle:
05 wrx
black

Default

I am using "Send Text file" in the hyperterminal. I will try another comp with a serial port as soon as possible. Could the utec have a problem? I bought it used and am kinda worried. The utec seems to be ok just the part about not being able to load a map.
black05wrx23 is offline   Reply With Quote
Old 03-03-2005, 01:54 PM   #49
YourMother'sLover
Scooby Guru
 
Member#: 76565
Join Date: Dec 2004
Chapter/Region: International
Location: Ask me about POWDERCOATING!!!
Vehicle:
CLXX Stricta Parata
Neci!

Default

With all of this talk I think I'm just going to drive up to FIS and have them install and tune it on the dyno.....hopefully it won't take more than a run or two (dyno time is expensive).
YourMother'sLover is offline   Reply With Quote
Old 03-27-2005, 08:04 PM   #50
04 Rex in DE
Scooby Newbie
 
Member#: 68305
Join Date: Aug 2004
Location: Delaware
Vehicle:
2004 WRX
Silver

Default

Just a quick question. I just bought a utec from turboxs and i put base stage map 2 on the order form because that is what i am at. can i just install it and go?
04 Rex in DE is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: (HR) Subaru STi and WRX parts - exhaust, dp, uppipe, FMIC, UTEC, CAI, etc. azrakain MAIC Private Classifieds 71 06-02-2011 08:21 PM
Really Basic UTEC stuff. A little Help Please. Aarondost08 UTEC 2 06-14-2009 01:00 PM
Basic UTEC vs UTEC Delta Unlikely Hero Newbies & FAQs 3 04-25-2008 08:59 PM
Basic UTEC Maps JackClark Engine Management & Tuning 3 09-10-2005 09:44 PM
Sumb Basic UTEC Stage4 Map question Brian Broz Engine Management & Tuning 3 05-06-2004 01:58 AM


All times are GMT -4. The time now is 02:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.