Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-12-2003, 11:04 PM   #1
just_dave
Scooby Newbie
 
Member#: 50466
Join Date: Dec 2003
Location: maine
Vehicle:
1993 impreza
red

Default hard starting impreza

i have a 1993 subaru impreza manual transmission fuil injected the problem i have is the check engine light stays on and when it sits over night its realy hard to start then when it does start it runs ruff for few min then runs fine rest day recently i descoverd if i take the battery wire of over night when i put it back on the light goes out and the car starts right up but after a few miles the light comes back on i have to take the battery wire of every night any suggestions????? bad computer maybe??
* Registered users of the site do not see these ads.
just_dave is offline   Reply With Quote
Old 12-13-2003, 10:40 AM   #2
orndog
Scooby Specialist
 
Member#: 34670
Join Date: Mar 2003
Chapter/Region: South East
Location: Atlanta
Vehicle:
2013 No gears!
Saltine American

Default

Taking the cable off resets your computer, so the light goes away for a while. Sounds like you may either have a bad battery or an electrical drain causing the hard starting.
orndog is online now   Reply With Quote
Old 12-13-2003, 10:43 PM   #3
just_dave
Scooby Newbie
 
Member#: 50466
Join Date: Dec 2003
Location: maine
Vehicle:
1993 impreza
red

Default

i put a new battery in it new battery terminals still does the same lately even when the light is out its gettin so that it floods out when i go to start it after its bein drivin for awhile i have to hold the throttle wide open and turn it over for a long time it could have a short sometimes it makes a clicking sound when the check engine light comes on or goes out and the light dim as it clicks i realy hate to take it a garage and put more money into it i plan to trade it in for a outback this summer if i can keep it runnin that long so any suggestions would be helpfull ///also when you let it idle the check engine light clicks on and off constant sometimes it will idle 3000 rps u have to shut it off and start it back up to get it idling right thanks dave
just_dave is offline   Reply With Quote
Old 12-21-2003, 06:41 PM   #4
joubtt
Scooby Specialist
 
Member#: 33901
Join Date: Mar 2003
Location: San Diego
Vehicle:
04 04 STI
No AWD, Not interested

Default

Have you checked the alternator, starter, plugs and fuses? Also, check your service manual.
joubtt is offline   Reply With Quote
Old 12-21-2003, 11:49 PM   #5
Borgus
Scooby Newbie
 
Member#: 49375
Join Date: Nov 2003
Location: Columbus, OH
Default

Quote:
Originally posted by joubtt
Have you checked the alternator, starter, plugs and fuses? Also, check your service manual.
Definitly sounds like one of these to me. Also, check your distributer cap. Spark plugs have been known to do this as well...
Borgus is offline   Reply With Quote
Old 12-22-2003, 02:25 PM   #6
just_dave
Scooby Newbie
 
Member#: 50466
Join Date: Dec 2003
Location: maine
Vehicle:
1993 impreza
red

Default

it has new plugs and wires i just had a tune up done about a month ago it may be a starter or alt but the starter dont drag and it seems to charge good just starts hard in mornins if the check engine light is on. if the lights of when i shut down the car at night it will start right up the next day. if not i gotta take battery wire of for about 30 min then it will start i cant find my service manual its bein a tuff car got almost 2 hundred thousand on it dont burn oil still goes like a new car when it starts iv deff got my moneys worth from it thanks for your suggestions ill look into it and hopefully it is one of those that are bad
just_dave is offline   Reply With Quote
Old 12-28-2003, 10:06 PM   #7
kevinsUBARU
Scooby Specialist
 
Member#: 2263
Join Date: Sep 2000
Chapter/Region: Tri-State
Location: Funky Kingston, NY
Vehicle:
2012 Impreza Sport

Default

Quote:
Originally posted by Borgus
Definitly sounds like one of these to me. Also, check your distributer cap. Spark plugs have been known to do this as well...
There is not a distributor cap since we have coil packs. Could be cam/crank sensor or the coil pack. Mine did the same thing, and would go away when the battery was unpluged to reset the computer, but then come back.
kevinsUBARU is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard starting 2002 Impreza Puffie40 Normally Aspirated Powertrain 8 11-18-2008 08:04 PM
95 impreza 1.8L--randomly hard starting, stalls occassionally scoobysteve95 Normally Aspirated Powertrain 5 01-09-2005 10:07 PM
cel ,dtc codes -p0115,p0505, and occasional hard starting impreza subaru6 Engine Management & Tuning 1 03-10-2004 11:16 PM


All times are GMT -4. The time now is 09:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.