Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-15-2003, 03:40 PM   #1
beethoven
Scooby Newbie
 
Member#: 6654
Join Date: May 2001
Chapter/Region: MWSOC
Location: Wis-Con-sin
Vehicle:
2006 Odyssey
2006 Prius

Default Failing Keyless Entry

On my '98 RS, my keyless entry has been doing some weird things lately. When coming to a stop, the car doors lock-unlock-lock and the hazards flash (very annoying). A couple times, after getting out of the car and locking it, the hazards kept flashing until I hit the lock button on my remote.

Now, my remotes aren't working (yes, I changed the batteries). I assume all of this means my keyless entry unit is toast, right?

If so, what does it take to replace it? I haven't really taken a look at the hardware yet....is it easy to remove? Should I replace it with an OEM unit or aftermarket?

Thanks for you input....
* Registered users of the site do not see these ads.
beethoven is offline   Reply With Quote
Old 12-15-2003, 05:24 PM   #2
atmosphere
Scooby Newbie
 
Member#: 37641
Join Date: May 2003
Chapter/Region: SCIC
Location: San Diego
Vehicle:
98 Impreza 2.5 RS

Default

Has your battery been disconnected for a long period of time and recently just reconnected?
atmosphere is offline   Reply With Quote
Old 12-15-2003, 05:40 PM   #3
grimlock
Scooby Specialist
 
Member#: 2683
Join Date: Oct 2000
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
2011 STi 5-Door
White

Default

It does sound to me like the unit might be toast, although the problem also sounds like it might be faulty relays.

I don't know what the OEM alarm was in '98, but my '01 was a CodeAlarm.

If you do decide to replace it, I'd recommend going aftermarket. People who really wanted your car would still be able to steal it, but amateurs who only knew how to disable the OEM might be turned away.

Ross N.
grimlock is offline   Reply With Quote
Old 12-15-2003, 05:46 PM   #4
beethoven
Scooby Newbie
 
Member#: 6654
Join Date: May 2001
Chapter/Region: MWSOC
Location: Wis-Con-sin
Vehicle:
2006 Odyssey
2006 Prius

Default

Quote:
Originally posted by atmosphere
Has your battery been disconnected for a long period of time and recently just reconnected?
A few months ago, but the problems had already started by that time. What's odd is that one remote stopped working several weeks ago, but the other stopped working yesterday.
beethoven is offline   Reply With Quote
Old 12-16-2003, 02:21 AM   #5
sweetsuby
Scooby Specialist
 
Member#: 14043
Join Date: Jan 2002
Chapter/Region: MWSOC
Location: mi
Vehicle:
2002 WRX, ForesterXT

Default

hmm.. same thing is happening to my RS...
sweetsuby is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tried programming 2nd keyless entry, but epic fail instead. watergun Car Audio, Video & Security 6 08-24-2009 12:09 AM
Stock Keyless Entry Remote is failing...WHY? EricIsAPanicFreak Car Audio, Video & Security 4 11-07-2008 01:40 PM
('93-'01) Stock Subaru Keyless entry Future Subaru Driver1 Impreza Forum 5 05-01-2001 11:45 PM
FS/TRADE: Factory alarm and keyless entry omahasubaru Mid West Subaru Owners Club Forum -- MWSOC 0 01-29-2001 01:51 PM
Powdercoating & keyless entry installation in Calgary ... Keenan Canada Region Forum 2 11-10-2000 10:03 AM


All times are GMT -4. The time now is 07:38 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.