Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-15-2003, 05:39 PM   #1
Thtwudbeme
Scooby Newbie
 
Member#: 50493
Join Date: Dec 2003
Location: NC
Vehicle:
1998 Outback
Blue

Default Steam from under hood

I posted this in the Outback forum, but didn't get much attention

I have a 98 Legacy Outback with 85,000 miles, automatic transmission. It runs great except for the lifter clicking noises-

After the car is parked in a steady rain, after it gets good and warm (really warm--5 miles of city driving) it starts pouring steam from under the hood. It is not running hot, and there is no loss of coolant. All other fluid levels are normal.

The underside of the hood, under the heat shield is wet too-

Thoughts?

Stephanie
* Registered users of the site do not see these ads.
Thtwudbeme is offline   Reply With Quote
Old 12-15-2003, 06:47 PM   #2
Subie Gal
GC84Ever
Super Moderator
 
Member#: 301
Join Date: Sep 1999
Chapter/Region: NWIC
Location: WA
Vehicle:
1970 FF-1 & '70 Van
02 WRX/01 RS

Default

water burning off.

look at your hood scoop shield...
there is a small hole for drainage of water...

in heavy rain, it's quite normal to see steam rising off the hood of the car... it's just burning off excess water.

this will not damage your car.

water damage comes from sucking too much water IN through the intake/air system of your car.... often this type of thing occurs in deep puddles or even floods.

i wouldnt worry about your car, it's fine

Jamie
www.subiegal.com
Subie Gal is offline   Reply With Quote
Old 12-15-2003, 06:57 PM   #3
Thtwudbeme
Scooby Newbie
 
Member#: 50493
Join Date: Dec 2003
Location: NC
Vehicle:
1998 Outback
Blue

Cool That's so funny that you answered my post

I was telling my husband about your website, and how cool I thought you seemed!

The steam is coming from under the hood, though....and it's clouds of it....lasts for about 5 or 10 minutes after I have driven for 4 or 5 miles after it sat parked in steady rain.

I have seen front wheel drives steam like hell after going through puddles...but, this steam is like "Old Faithful" size...it's alot-

Do you still think it's not a problem? It's running great-
Thtwudbeme is offline   Reply With Quote
Old 12-15-2003, 07:22 PM   #4
Karl
Scooby Specialist
 
Member#: 13110
Join Date: Dec 2001
Chapter/Region: NESIC
Location: Rhode Island
Default

No steam in dry weather?
If so, I wouldn't worry about it.
Just make sure the coolant level is fine, and the radiator cap is alright.
Karl is offline   Reply With Quote
Old 12-15-2003, 07:27 PM   #5
Thtwudbeme
Scooby Newbie
 
Member#: 50493
Join Date: Dec 2003
Location: NC
Vehicle:
1998 Outback
Blue

Default Nope, no steam in dry weather at all

Thank you both for your answers-

Stephanie
Thtwudbeme is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
steam from under hood geogolf Outback Forum 6 03-25-2005 12:04 PM
Steam from under hood Thtwudbeme Outback Forum 0 12-14-2003 11:21 PM
Steam from under hood, and excess coolant consumption ErikAnderson Normally Aspirated with bolt-on Forced Induction Powertrain 4 11-15-2003 11:36 AM
Showoff Q: Mist/Steam from under hood when revving? Brian Broz Factory 2.0L Turbo Powertrain 10 06-25-2003 06:43 PM
Odd smell from under hood, steam. Equinox Factory 2.0L Turbo Powertrain 7 11-28-2002 07:49 PM


All times are GMT -4. The time now is 06:51 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.