Welcome to the North American Subaru Impreza Owners Club Sunday September 25, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Tri-State Area Club
Go Back   NASIOC > NASIOC Regional Areas > Tri-State Area Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-15-2003, 10:02 PM   #1
wgknestrick
Scooby Specialist
 
Member#: 32576
Join Date: Feb 2003
Location: Stevens, PA
Vehicle:
04 STI

Default My FMIC pics 56K beware







I know pics suck because my car has been salted and this is in my weathered garage. I'll post again once I have a chance to clean it.

Sooooo much work between porting the VF39 and installing FMIC. IC water spray also works too All I need now is my mbc / boost gauge to get here so I get the 1psi I lost to the FMIC and the 1.5psi I need.
* Registered users of the site do not see these ads.
wgknestrick is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-15-2003, 10:12 PM   #2
MikeWRX-NJ
Scooby Specialist
 
Member#: 33410
Join Date: Feb 2003
Chapter/Region: Tri-State
Location: wishing i was somewhere else
Vehicle:
08 wrx
dgm

Default

that's one biiiiig fmic . very nice. modding an sti to that extent = balls. when the hell are they gonna bring out the engine management?
MikeWRX-NJ is offline   Reply With Quote
Old 12-15-2003, 10:29 PM   #3
wgknestrick
Scooby Specialist
 
Member#: 32576
Join Date: Feb 2003
Location: Stevens, PA
Vehicle:
04 STI

Default

Not soon enough. I hope to break 11s by the end of 2004 and not anything else. All I have left to buy (hopefully) is Forced Performance Green turbo (aiming high for now), injectors (when they come out), Utec (when it comes out), WI kit, and Walburo fuel pump.
wgknestrick is offline   Reply With Quote
Old 12-15-2003, 10:42 PM   #4
InfamousDX
Scooby Guru
 
Member#: 25413
Join Date: Sep 2002
Chapter/Region: Tri-State
Location: North NJ
Default

How did you paint your IC??? When you posted those pics it was still silver right?? As I hear, unless it's anondized a color, it degrades performance... just wondering.

Oh and it's Walbro
InfamousDX is offline   Reply With Quote
Old 12-15-2003, 10:56 PM   #5
wgknestrick
Scooby Specialist
 
Member#: 32576
Join Date: Feb 2003
Location: Stevens, PA
Vehicle:
04 STI

Default

I just painted it with flat black high temp. Only 2 very thin coats on the front. Pics show a spot I need to touch up too. I can't imagine how much effect the paint is going to do because almost all of the cooling occurs inside the IC and that has no paint on it. You can't even feel a conduction difference between the painted an unpainted sides.
wgknestrick is offline   Reply With Quote
Old 12-15-2003, 10:58 PM   #6
Pinochle
Scooby Guru
 
Member#: 638
Join Date: Dec 1999
Chapter/Region: Tri-State
Location: http://www.djforums.com
Vehicle:
93 L, 00 RS, 04 TS
pat + nat

Default

STEALTH = HHOTTTTTTTTTTTTTTTTTTTTTT!!!
Pinochle is offline   Reply With Quote
Old 12-16-2003, 02:24 AM   #7
InfamousDX
Scooby Guru
 
Member#: 25413
Join Date: Sep 2002
Chapter/Region: Tri-State
Location: North NJ
Default

Yea I figure if anything, it would make a neglible difference anyway. I had a stealth black IC on my old civic.. they are PIMP.
InfamousDX is offline   Reply With Quote
Old 12-16-2003, 03:06 AM   #8
WRX_02_227
Scooby Specialist
 
Member#: 12434
Join Date: Nov 2001
Chapter/Region: Tri-State
Location: PA
Vehicle:
2002 WRX #332
2011 BMW 135i

Default

Now that is SWEET!!!!!!!!

Also, love your headlights
WRX_02_227 is offline   Reply With Quote
Old 12-16-2003, 07:27 AM   #9
YaZahX
Scooby Specialist
 
Member#: 11932
Join Date: Nov 2001
Chapter/Region: Tri-State
Location: NY
Vehicle:
1998 CW ITR
2006 NBP SI

Default

whys the BOV on the wrong side??
YaZahX is offline   Reply With Quote
Old 12-16-2003, 07:53 AM   #10
wgknestrick
Scooby Specialist
 
Member#: 32576
Join Date: Feb 2003
Location: Stevens, PA
Vehicle:
04 STI

Default

Quote:
whys the BOV on the wrong side??
Compared to what? It is in the exact same place as it is with the stock TMIC
wgknestrick is offline   Reply With Quote
Old 12-16-2003, 08:19 AM   #11
subimatt
Scooby Specialist
 
Member#: 43680
Join Date: Sep 2003
Chapter/Region: NESIC
Location: Boston, MA
Vehicle:
BMW 335xi,x3,e30

Default

are you going to replace the hood as well?
subimatt is offline   Reply With Quote
Old 12-16-2003, 08:44 AM   #12
atf78
Scooby Specialist
 
Member#: 9017
Join Date: Aug 2001
Chapter/Region: Tri-State
Location: Sewell, NJ
Vehicle:
2011 WRX 5dr
405whp 385wtq

Default

Nice setup!

Quote:
Originally posted by wgknestrick
Compared to what? It is in the exact same place as it is with the stock TMIC
He means where it's connected to the IC piping. I always found it strange that Perrin mounted the BOV right after the turbo instead of right before the throttle body. It's the only setup I've seen like that for any turbo'd car.

-Anthony
atf78 is offline   Reply With Quote
Old 12-16-2003, 12:57 PM   #13
wgknestrick
Scooby Specialist
 
Member#: 32576
Join Date: Feb 2003
Location: Stevens, PA
Vehicle:
04 STI

Default

I'm not sure. It will still vent the pressure whether in front of the IC or behind it. It might be why the car is runing slightly rougher or it could just be that any FMIC makes the car run slightly rougher without EM. My car is getting to be well modified over stock and the ECU does some crazy things sometime. I think I am leaving at least 40HP on the table without a tune. Thank god boost creep is gone now though because I almost forgot how far down the pedal would go. Fuel cut is very violent and scary when it happens, almost like a blown engine.
wgknestrick is offline   Reply With Quote
Old 12-16-2003, 02:27 PM   #14
YaZahX
Scooby Specialist
 
Member#: 11932
Join Date: Nov 2001
Chapter/Region: Tri-State
Location: NY
Vehicle:
1998 CW ITR
2006 NBP SI

Default

Quote:
Originally posted by atf78
Nice setup!



He means where it's connected to the IC piping. I always found it strange that Perrin mounted the BOV right after the turbo instead of right before the throttle body. It's the only setup I've seen like that for any turbo'd car.

-Anthony
i think they did it so teh stock bov and piping would bolt right up... but i always though the BOV should be next to the TB... perrin makes really good stuff, i just dont understand why they did it...
YaZahX is offline   Reply With Quote
Old 12-16-2003, 02:51 PM   #15
2sour4u
Scooby Specialist
 
Member#: 13733
Join Date: Dec 2001
Location: Allentown PA.
Vehicle:
05' Saabaru
Black YO!

Default

Bill is the man! Your car is starting to really look amazing. I love the stealthy black look. I think I would have sone the same thing. Heres a silly noob question for you. What is that red soda can looking thingy in the bottom right of the pics in front of the battery? Is that your balast for the HID's? Just curious. Anywho, PM me or give a call whenever your not busy. We need to double date again.

Jon
2sour4u is offline   Reply With Quote
Old 12-16-2003, 02:53 PM   #16
InfamousDX
Scooby Guru
 
Member#: 25413
Join Date: Sep 2002
Chapter/Region: Tri-State
Location: North NJ
Default

^^ Oil catch can?
InfamousDX is offline   Reply With Quote
Old 12-16-2003, 03:14 PM   #17
wgknestrick
Scooby Specialist
 
Member#: 32576
Join Date: Feb 2003
Location: Stevens, PA
Vehicle:
04 STI

Default

That is just the coolant overflow tank. The piping runs right where the stock one is and they provide you with that "trick" canister. It is hard to see the level of the coolant though and it is just Samco hose with billet Al endcaps, but at least it looks nice. My car is either leaking coolant now or I have another problem, but I have had to fill that tank 2 times already. Car isn't running hot though and I bled all the air out of the coolant system.
wgknestrick is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[Bugeye n M3] Few pics with my new XTi [56k beware] kirkeemonster Member's Car Gallery 15 11-23-2007 08:15 AM
My Mt. Hood Pics!!! 56K BEWARE!!! stiguy21 North West Impreza Club Forum -- NWIC 13 08-14-2007 04:02 PM
Pics of my MBP wrx *56k beware* dirtyhartland Member's Car Gallery 20 03-02-2005 12:31 AM
BORED pics of my 05 sti - 56k beware big pics wrxtremeWGN Member's Car Gallery 8 02-12-2005 07:12 PM

All times are GMT -4. The time now is 08:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.