Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-17-2003, 04:26 AM   #1
cybin
Scooby Newbie
 
Member#: 48667
Join Date: Nov 2003
Location: GB, WI
Default SRS Airbag light came on. How do I reset?

I've got a 1997 Outback sport. I just installed a new steering wheel out of a 2.5RS. I reused the original airbag that came with the car and installed it into the new steering wheel. I must have tripped a sensor as when I hooked up the battery and started the car the light stays on.

I'm wondering how to reset the light.

I tried pulling the airbag fuses. Maybe I didn't do it right?

I tried resetting the ECU. No effect.

I'm wondering if there is a way though the computer to clear the codes.

Thanks,
-Cybin
* Registered users of the site do not see these ads.
cybin is offline   Reply With Quote
Old 12-17-2003, 05:08 AM   #2
nate49509
Scooby Guru
 
Member#: 22452
Join Date: Aug 2002
Chapter/Region: MWSOC
Location: Not Flint.
Vehicle:
'04 WRX
witty comment goes here

Default

Are you sure that you plugged the airbag connector in. Also you may want to double check all your fuses.
nate49509 is offline   Reply With Quote
Old 12-17-2003, 11:22 AM   #3
cybin
Scooby Newbie
 
Member#: 48667
Join Date: Nov 2003
Location: GB, WI
Default

I'm going to have to double check the connector. Although it did give a positive click, at least I thought.

-Cybin
cybin is offline   Reply With Quote
Old 12-17-2003, 02:20 PM   #4
Robin2
NASIOC Supporter
 
Member#: 390
Join Date: Oct 1999
Chapter/Region: E. Canada
Location: Ottawa, Ontario, Canada
Vehicle:
2011 WRX sedan
Plasma Blue

Default

It may not accept it... I remember that one of our local dealers, the owner bought a crashed 99RS to rebuild for his own use...

He was going to use the 98RS airbags (which were never used) cause the 98RS was a rally car... but they wouldn't plug in properly...

I'm not sure what was the problem or not..... I guess Subaru switched the design a bit...

He was pissed cause now he had to buy 99 airbags to have the car pass safety.....

I'll look in the 99 manual.. to see if they say anything from the standpoint of the airbags...

Robin
Robin2 is offline   Reply With Quote
Old 12-17-2003, 03:21 PM   #5
cybin
Scooby Newbie
 
Member#: 48667
Join Date: Nov 2003
Location: GB, WI
Default

I'm actually using the original air bag that came with the car.

I read at the site listed below that in 1998 they switched to a de-powered airbag system. Thats why I didn't use the one that came with the steering wheel.

http://www.cars101.com/impreza_archive97_98.html
cybin is offline   Reply With Quote
Old 12-18-2003, 10:43 AM   #6
SubyTechMaster
Scooby Specialist
 
Member#: 4423
Join Date: Feb 2001
Location: Placerville, CA USA
Vehicle:
'04 08 Tribeca, SVX
Gold, Maroon

Default

The driver side SRS module is the same, only the passenger side is differant.

Did you push in the green tab on the connector? That is a double lock that will set a code if not depressed. It will not stay in memory if you fix the problem so you do not need to clear the computer afterward.
SubyTechMaster is offline   Reply With Quote
Old 12-18-2003, 01:20 PM   #7
evo2rex
Scooby Specialist
 
Member#: 40843
Join Date: Jul 2003
Chapter/Region: Tri-State
Location: Biking in nyc
Vehicle:
2002 WRX
w/ 07 6mt DCCD Pro

Default

If your only worried about the inspection, just pull the airbag bulb in the dash, but thats only a temporary solution that needs to be fixed sooner or later. Sooner would be better since later may be too late....
evo2rex is offline   Reply With Quote
Old 12-20-2003, 11:40 PM   #8
cybin
Scooby Newbie
 
Member#: 48667
Join Date: Nov 2003
Location: GB, WI
Default

SubyTechMaster wins. Green tab was not pressed in. Airbag light went off right away.


Thank you very much.

-Cybin
cybin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed Aftermarket Seats, airbag light is on, how do i fix it? 1FSTREX Interior & Exterior Modification 15 07-06-2011 03:35 PM
SRS Airbag Light stays on during prolonged cold starts. da-chaz Service & Maintenance 4 01-31-2008 01:08 PM
airbag light came on attitude Service & Maintenance 5 12-16-2006 03:09 PM
AirBag light came on after this, need help guys! orwrx Electrical & Lighting 4 05-06-2006 10:05 PM
airbag light came on???? I am b Factory 2.0L Turbo Powertrain 2 11-16-2001 05:05 PM


All times are GMT -4. The time now is 06:26 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.