Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-22-2003, 08:52 PM   #1
tr3
Scooby Newbie
 
Member#: 51116
Join Date: Dec 2003
Location: WA
Default Strange BOV behaviors and strange noises from turbo

I have a GFB Stealth FX BOV adjusted to 100% atmospheric. It works fine in 1st and 2nd gear at all throttle positions and boost levels. In 3rd through 5th gears at higher boost levels, the BOV sounds as if it barely opens up when I let off the throttle. Sometimes it doesn't even make any venting sound at all. 50% of the time it would vent just fine at full boost. The other 50% of the time it would barely hear the BOV venting air and I would hear a weird sound coming from the turbo area, a very quick "pft...pft...pft...pft...pft", lasting 1 second at the most. It's very hard to hear that strange noise as it's very low and deep, however. I would only hear it when the windows are up and radio off. Sometimes the BOV would vent very quickly and then stops venting right away. I lift my foot very quickly to ensure a strong vacuum signal to the BOV, but it doesn't seem to help.

The BOV's spring is set at a rather loose setting. So loose that the BOV would leak out some air at idle. I've heard that setting the BOV spring too loose is better than too tight. Is this true?

What is going on? Am I just hearing wastegate noises or am I hearing pressure surge from not setting the BOV correctly?
* Registered users of the site do not see these ads.
tr3 is offline   Reply With Quote
Old 01-09-2004, 04:38 AM   #2
UGotBoost?
Scooby Specialist
 
Member#: 45735
Join Date: Oct 2003
Location: ANYWHERE BUT Newport News
Vehicle:
2002 Impreza WRX
Blue

Default

It sounds like you've got a nasty case of compressor surge. I had the same thing on my HKS SSQV on 100% atmos.

Compressor Surge occurs when your BOV isn't venting enough air out of the IC system and the pressure left in the IC is slowing down your spinning turbine VERY quickly, making that "bark" sound you were talking about.

Technically, a loose spring would mean the BOV opens easily (like you said). I suspect a poor vacuum line connection, or a FUBAR BOV (like mine!) Try putting your stocker back on to check the Vacuum line, or try setting your BOV to another setting (recirc can help push the turbo to keep it from slowing down.)

BTW, you posted EXACTLY 19 years, 12 hours after I was born (12/22/84, 8:52 AM)
UGotBoost? is offline   Reply With Quote
Old 01-09-2004, 07:06 AM   #3
1DOWNCLOWN
Scooby Specialist
 
Member#: 50287
Join Date: Dec 2003
Location: Franklin IN
Vehicle:
02 WRX
silver

Default

i just like the fact of you posted about your b-day
1DOWNCLOWN is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clunking Noise and Knocking Noise from rear. AWD_Drift Brakes, Steering & Suspension 16 02-14-2011 02:56 AM
Strange clicking noise...from turbo? th1rd3y3 Factory 2.5L Turbo Powertrain 5 01-25-2009 10:56 PM
clicking noise from turbo??? ScuubyT Factory 2.0L Turbo Powertrain 2 09-16-2003 09:26 AM
Odd Noise from turbo area! MissWRX Factory 2.0L Turbo Powertrain 12 03-05-2003 09:37 PM
Weird Rattle noise from Turbo on WRX ? Impreza777 Factory 2.0L Turbo Powertrain 15 06-25-2002 07:53 PM


All times are GMT -4. The time now is 02:47 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.