Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-23-2003, 11:32 AM   #1
jmaiken
Scooby Newbie
 
Member#: 8506
Join Date: Jul 2001
Location: Richmond, VA
Vehicle:
04 Forester XT
Black -VF39, STi tmic etc

Default what else can cause the evap. emissions leak CEL?

I threw this code, took it to the dealer and they replaced the gas cap. I got it again and am trying to figure out what it could be.

I have recently brought my car back to stock (from a stg. 4). I wonder if I damaged the gasket to the gas tank access panel when I swapped my OEM fuel pump back in.

Anything else to look for?
* Registered users of the site do not see these ads.
jmaiken is offline   Reply With Quote
Old 12-23-2003, 11:56 AM   #2
wickedwrx
Scooby Newbie
 
Member#: 23826
Join Date: Sep 2002
Location: Buffalo Grove
Vehicle:
2002 impreza
No color it is invisible.

Default

I think the gasket would be a good place to look at first if you had the gas cap replaced and you are still throughing that code.
wickedwrx is offline   Reply With Quote
Old 12-23-2003, 12:04 PM   #3
Full_Clip
Scooby Specialist
 
Member#: 22218
Join Date: Jul 2002
Chapter/Region: South East
Location: University of Florida
Default

Might as well go for it. But if the fuel pump gasket went bad or got damaged, shouldn't there be an odor of gasoline in the interior?


Full_Clip sniffs the carpet.
Full_Clip is offline   Reply With Quote
Old 12-23-2003, 12:10 PM   #4
SpeedracerX
Visiting NASIOC Timeout
 
Member#: 51110
Join Date: Dec 2003
Location: Anaheim, CA
Vehicle:
2003 WRX
Turquiose Blue/Primer Gra

Default

I threw the code, and the dealer had to replace a valve in the gas tank, after first telling me that I didn't twist the gas cap enough.

Have the dealer check the evap system in the tank. It's a pain, but it stopped the problem.

SRX
SpeedracerX is offline   Reply With Quote
Old 12-23-2003, 12:11 PM   #5
jmaiken
Scooby Newbie
 
Member#: 8506
Join Date: Jul 2001
Location: Richmond, VA
Vehicle:
04 Forester XT
Black -VF39, STi tmic etc

Default

When I remove the gas cap I get the whoosh sound as the air pressure equalizes. Because of this I think the gas tank assembly might be okay.

I talked to a subbie guru today and he said it might be that the injectors need to be cleaned. He told me that he has seen this code after someone swapped back to OEM like I did. I guess the stock injectors can gum up after sitting unused for a while. He suggested a fuel injector cleaning service.

Any other ideas?
jmaiken is offline   Reply With Quote
Old 12-26-2003, 06:51 PM   #6
jmaiken
Scooby Newbie
 
Member#: 8506
Join Date: Jul 2001
Location: Richmond, VA
Vehicle:
04 Forester XT
Black -VF39, STi tmic etc

Default

Code came back, but then went away on it's own. Code is p0442.

Any other ideas?
jmaiken is offline   Reply With Quote
Old 12-27-2003, 12:48 AM   #7
BADWRX
Scooby Specialist
 
Member#: 3792
Join Date: Jan 2001
Vehicle:
2002 6MT almost GDB

Default

Fuel pump assembly gasket? I am getting the same code, and I am pretty positive that is what mine is.
BADWRX is offline   Reply With Quote
Old 12-27-2003, 10:55 AM   #8
jmaiken
Scooby Newbie
 
Member#: 8506
Join Date: Jul 2001
Location: Richmond, VA
Vehicle:
04 Forester XT
Black -VF39, STi tmic etc

Default

what do you mean by the fuel pump assembly gasket? I don't remember there being a gasket on the pump.

thanks
jmaiken is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
what can cause the right bank to go lean??? STiGuy23 Factory 2.5L Turbo Powertrain 7 09-01-2009 05:21 PM
The interview process, applying for a new job, what else can I do? Mud Pig Off-Topic 18 11-27-2007 02:41 PM
evap emissions leak gsteclipse33 Factory 2.0L Turbo Powertrain 4 02-02-2005 12:07 PM
what can cause the stock ECu to pull timing? Homemade WRX Factory 2.0L Turbo Powertrain 10 09-13-2004 08:47 AM
CEl after up pipe, did resistor what else can it be? bad resistor? fedrex Factory 2.0L Turbo Powertrain 4 03-30-2004 04:57 PM


All times are GMT -4. The time now is 11:32 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.