Welcome to the North American Subaru Impreza Owners Club Sunday April 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-25-2003, 10:42 PM   #1
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default 2.2 legacy turbo>1.8 impreza swap runs lean, please help

i just bought a project car with a 2.2 legacy tubo block into a 1.8 impreza 93, with a MT, it runs and drives fine, but it i can't floor at all because ity runs too lean, it still runs on the 1.8 computer and the 1.8 top end. the guy who did the swap says he used the legacy's pressure regulator

oh, and the speedo cable is broke but i have a new one and will put in tomoorrow
* Registered users of the site do not see these ads.
bobturismo is offline   Reply With Quote
Old 12-26-2003, 11:45 AM   #2
Jaxx
NASIOC Supporter
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Boise,Idaho,USA
Vehicle:
The 93 Imp W/EJ20K
flat black

Default

consider an S-afc or an emanage

scoobyslack ran this way for almost a year until he went stand alone
Jaxx is offline   Reply With Quote
Old 01-01-2004, 06:22 PM   #3
scubydrew
Scooby Specialist
 
Member#: 32609
Join Date: Feb 2003
Vehicle:
2005 saab 9-2x
rhd ej20tt sold...

Default

i have the same problem right now with the same setup 2.2 bottom end with the 1.8 manifold and ecu. from what i know i have a check engine light on and by having your check engine light on your car runs a different fuel map. i'm guessing thats my problem. drew
scubydrew is offline   Reply With Quote
Old 01-01-2004, 09:21 PM   #4
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

what parts does the motor have? which parts came from what motor? is your speedo workin?
bobturismo is offline   Reply With Quote
Old 01-01-2004, 09:29 PM   #5
wac
Scooby Specialist
 
Member#: 689
Join Date: Dec 1999
Chapter/Region: NESIC
Location: Lebanon, NH, USA
Vehicle:
2005 Outback 2.5 XT
Champagne Gold Opal

Default Re: 2.2 legacy turbo>1.8 impreza swap runs lean, please help

Quote:
Originally posted by bobturismo
i just bought a project car with a 2.2 legacy tubo block into a 1.8 impreza 93, with a MT, it runs and drives fine, but it i can't floor at all because ity runs too lean, it still runs on the 1.8 computer and the 1.8 top end. the guy who did the swap says he used the legacy's pressure regulator
Is it turboed? Do you know what fuel pressure you're getting at various manifold pressures?

If you don't have a turbo, my first inclination will be to try EJ22 injectors with an EJ22 or EJ18 pressure regulator.

-WaC
Wayne
wac is offline   Reply With Quote
Old 01-02-2004, 01:12 AM   #6
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

Quote:
Originally posted by wac
Is it turboed? Do you know what fuel pressure you're getting at various manifold pressures?

If you don't have a turbo, my first inclination will be to try EJ22 injectors with an EJ22 or EJ18 pressure regulator.

-WaC
Wayne
yes it's turbo, wouldn't i want to use the 2.2 injectors? i haven't done any testing yet, but i do have a air fuel gauge (auto meter ) and at 1/2 throtttle under acceleration it runs rich but as i give it more throttle it leans out, i have to hook up the speedometer cable, but the tranny is a 96 legacy 5mt with electrical speed sensor and the dash cluster is an auto with a speedo cable, so right now the comp doesn't know how fast i'm going

i think i'm gonna put the 2.2 legacy computer (belongs with the motor) and the 2.2 intake manifold and elminate all of the 1.8 parts that i can, i woulda done it that way in the first place but i didn't do the conversion, but the guy i bought the car off of, said that the legacy needs one more plug than the impreza, but i don't know what that would be, i'm gonna get the wiring diagrams for the cars at the dealer when i look at the mechanical speed sensor to see if it will fit in the tranny
bobturismo is offline   Reply With Quote
Old 01-02-2004, 03:49 PM   #7
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

by george i think i got it !!! i just changed the injectors to the 2.2 and it runs awesome, it has a rough idle right not but will see how it goes
bobturismo is offline   Reply With Quote
Old 01-02-2004, 08:43 PM   #8
scubydrew
Scooby Specialist
 
Member#: 32609
Join Date: Feb 2003
Vehicle:
2005 saab 9-2x
rhd ej20tt sold...

Default

bobturismo i have the legacy 2.2t bottom end sorry forgot to put the t in there. i also have an adjustable fuel pressure regulator that runs 58psi at idle and plus 1psi per pound of boost. i'm using an autometer a/f gauge but mine says i'm rich but after going to the dyno come to find out i'm always running lean. i plan on going with a link plus to fix my fuel problem and help with some soon to come mods. drew
scubydrew is offline   Reply With Quote
Old 01-02-2004, 10:45 PM   #9
subiekid
Scooby Guru
 
Member#: 25516
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Send help, stuck in internet!
Vehicle:
1995 Legacy TURBO!!!
EJ22T/TEC3 & '12 Civic

Default

I would swap over the ej22T intake manifold. It has specific items on it that are best to have on the manifold.

eg. bypass valve, also all of the plumbing for the coolant return is on there.

manfiold swap is not that bad. you can even swap the 1.8 harness onto the turbo manifold so that you dont have to wire up things differently.
subiekid is offline   Reply With Quote
Old 01-02-2004, 11:50 PM   #10
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

Quote:
Originally posted by scubydrew
bobturismo i have the legacy 2.2t ... link plus to fix my fuel problem and help with some soon to come mods. drew
hmm...what are you running for fuel pump? try to get as much fuel system stuff from the 2.2 legacy that the motor and turbo came out of, in my impreza i have the 2.2 injectors plus the small section of rail that they sit in (fits 1.8 injector electrical plug upside down ), the stock little vacuum actuated fuel pressure regulator on the passenger side fuel rail, and the legacy fuel pump swapped into the fuel tank sender assembly (the impreza was converted to awd and the gas tank had 3 hoses going to it and the legacy had 2, so i simply swapped the parts)

the previous owner might have swapped other parts too, i'll talk too him tomorrow or the next day

he might have swapped :
coil, throttle position sensor (has butt connectors on wires)

if the stock legacy fuel items don't get you to run richer than either the dyno place was wrong or you need to get a add on fuel management system for your mods

how much boost are you running? if you can find out whats wrong with the a/f meter (try using a digital multi meter on the wire to see if your getting the voltages that the gauge should read) try turning down your boost, that might bring you into the normal range (if thats the case than you need to upgrade your fuel system to run higher boost), make sure your blow off is working too.

how does the car drive? when i was running lean i really couldn't put load on the motor (more load demands more fuel), i couldn't go past quarter throttle untill 4k rpms (motor has less load at higher r's), it would pop and misfire like crazy and surge, but now that it runs normal, it runs rich at idle, normal at any other condition, if you were running rich than it would bog more than pop and it might stall on decel (is it stick or auto?)

p.s. i have my check engine light on (haven't checked for cels) and my speedo isn't hooked in yet (might explain stalling from too much fuel on decel), run thr engine diagnostic codes to see if you might have a prob not related to the swap. i might throw a list together of what i have done for the swap, i really couldn't find anything from searching, it was always about 2.5's or somethin else. i don't know yet, i don't know if i want people buying all the legacy turbos 2.2 in my area

Last edited by bobturismo; 01-02-2004 at 11:57 PM.
bobturismo is offline   Reply With Quote
Old 01-03-2004, 02:23 AM   #11
scubydrew
Scooby Specialist
 
Member#: 32609
Join Date: Feb 2003
Vehicle:
2005 saab 9-2x
rhd ej20tt sold...

Default

it's weird because my car drives fine. tomorrow i'm going to get new plugs and try that because it doesn't like to cold start. i'm using an hks afr for fuel an apexi itc for timing and a knock link. btw my car is a 96 5 speed. i reset my battery today and the light hasn't came on yet. i know i used to throw maf code, map code and positive manifold pressure code. also i have a wrx fuel pump and legacy turbo rails and injectors. drew
scubydrew is offline   Reply With Quote
Old 01-03-2004, 04:46 AM   #12
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

Quote:
Originally posted by scubydrew
it's weird because my car drives fine. tomorrow i'm going to get new plugs and .....tive manifold pressure code. also i have a wrx fuel pump and legacy turbo rails and injectors. drew
drives fine huh? do ever smell any strong odors, and check your plugs the'll tell you if your lean or rich, white or black, and i think if they are black around the edge and the electrode is white, then i think that means rich at idle or low r's and lean at high r's, don't member for sure though see if you can look at the piston while the plugs are out too. if it pulls alot of different codes and nothing has changed than there is a slight chance that the computer is bad, i'm not sure how reliable subaru comps are, specially with spliced wiring. in the salvage yard business it's real easy to learn what cars are junk and what cars are good cars, when people call for a 3.3liter for a chrysler concorde 3 times a day than you know that motor is junk.

another thing too, if you live in Massachussets right, near like springfield or somthin'? well, check your battery wires, if they feel stiff than replace them, wires corrode easy in moist climates, that might explain the hard starts, does it sound like the starter is spinning fast enough, get a ohm meter or a volt meter with one built in, and check the resistance of all your grounds, one probe on the neg terminal than put the other probe to a ground spot and see how many ohms of resistance it takes for the current to travel back to the battery. that will wreack havoc on a fuel injection system because all the readings for the sensors are off, because alot of sensors are measured by their resistance to ground i.e. 02 sensor

other than that one other thing is check your intake plumbing for leaks, make sure all your hose clamps are tight, maybe even take everything off and give it a good cleaning and once over

oh by the way, at the dyno place, how did they know that you were running lean? did they hook anything up to your exhaust? like at emissions testing. if they didn't, they wouldn't now for sure whats going on, some shops have a gas analyzer, i think it'd called a scope. it has a sensor that thay stick in the tail pipe, it will tell you a lot about hoe the car is running, but they usually charge 50- 80 bucks to do this, and half the time nobody there knows how to use it properly. do they have pep boys out there? i can't remember, they usually have a scope
bobturismo is offline   Reply With Quote
Old 01-03-2004, 01:25 PM   #13
scubydrew
Scooby Specialist
 
Member#: 32609
Join Date: Feb 2003
Vehicle:
2005 saab 9-2x
rhd ej20tt sold...

Default

at the dyno they used a pipe after my exhaust with a wideband o2 in it. drew
scubydrew is offline   Reply With Quote
Old 01-03-2004, 02:38 PM   #14
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

howd your plugs look?
bobturismo is offline   Reply With Quote
Old 01-04-2004, 01:14 PM   #15
RSmatt
Scooby Newbie
 
Member#: 8039
Join Date: Jul 2001
Chapter/Region: NESIC
Location: Feeding Hills, MA
Vehicle:
94 v2 STi RA - RHD

Default

black with a touch of brown. i think i might try getting another pair of ej22t injectors and see if they make a difference. i'm thinking i might have a bad injector. drew
RSmatt is offline   Reply With Quote
Old 01-04-2004, 04:50 PM   #16
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

Quote:
Originally posted by RSmatt
black with a touch of brown. i think i might try getting another pair of ej22t injectors and see if they make a difference. i'm thinking i might have a bad injector. drew
let me know how that pans out. were all the plugs the same color?
bobturismo is offline   Reply With Quote
Old 01-04-2004, 05:05 PM   #17
scubydrew
Scooby Specialist
 
Member#: 32609
Join Date: Feb 2003
Vehicle:
2005 saab 9-2x
rhd ej20tt sold...

Default

yea all 4 were black with a brown spot on the tip of the (L part) don't know the name of the metal part. hopefully i'll get ahold of the injectors this week. drew
scubydrew is offline   Reply With Quote
Old 01-04-2004, 05:12 PM   #18
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

Quote:
Originally posted by scubydrew
yea all 4 were black with a brown spot on the tip of the (L part) don't know the name of the metal part. hopefully i'll get ahold of the injectors this week. drew

if you were running lean than they would have been whiter than the preachers sheets
bobturismo is offline   Reply With Quote
Old 01-07-2004, 02:00 PM   #19
scubydrew
Scooby Specialist
 
Member#: 32609
Join Date: Feb 2003
Vehicle:
2005 saab 9-2x
rhd ej20tt sold...

Default

are you using any type of fuel management such as apexi afc. if so what are you settings? drew
scubydrew is offline   Reply With Quote
Old 01-08-2004, 05:47 AM   #20
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

Quote:
Originally posted by scubydrew
are you using any type of fuel management such as apexi afc. if so what are you settings? drew
nope right now i'm in the process of trying to trick the computer, just working out the bugs, i'll end up buying one though when i sell my other impreza (L) or i may just swap the2.2 computer in (i am very good at wiring)
bobturismo is offline   Reply With Quote
Old 01-09-2004, 06:03 PM   #21
scubydrew
Scooby Specialist
 
Member#: 32609
Join Date: Feb 2003
Vehicle:
2005 saab 9-2x
rhd ej20tt sold...

Default

if your looking for an ecu i can get you a legacy turbo one. i also have a couple 2.2.t intake manifolds if you need anything.
scubydrew is offline   Reply With Quote
Old 01-10-2004, 01:38 PM   #22
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default

Scubydrew: do you have a picture of the ECU pinout? I'm wondering if it's the 3 plug or the 2 plug. I'm also wondering if I can just swap it with my 93 ECU.

Chad
93 2.2T
subachad is offline   Reply With Quote
Old 01-10-2004, 03:25 PM   #23
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

Quote:
Originally posted by scubydrew
if your looking for an ecu i can get you a legacy turbo one. i also have a couple 2.2.t intake manifolds if you need anything.
really i don't know what i want to do, i can go get the legacy comp from the guy i bought the car, but i would have to pull the harness out of the legacy, what is the difference between the manifolds, they look the same, i ended up swapping most of the 2.2 parts on to it any way
bobturismo is offline   Reply With Quote
Old 01-11-2004, 02:37 PM   #24
scubydrew
Scooby Specialist
 
Member#: 32609
Join Date: Feb 2003
Vehicle:
2005 saab 9-2x
rhd ej20tt sold...

Default

subachad: i have a one peice blue plug but has two sperated parts. i have a printed out page of the ecu pinout but will have to look around for it. if your cars a 93 you most likely have the green plug. if thats not the case and you do have the same plug as me i'll get that for ya. drew
scubydrew is offline   Reply With Quote
Old 01-11-2004, 02:58 PM   #25
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

drew: i think i'm gonna get the wiring harness and he computer from the legacy and convert it over, did you get your car dialed in ?
bobturismo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1.8 => 2.2 swap, car runs strange, please help Toahk Subaru Conversions 2 01-18-2008 01:08 PM
EJ25 swap running lean, no CEL, ECU skipping logs zanderspeed Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 6 11-24-2007 02:19 PM
running lean, need help bxracer69 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 03-31-2005 12:25 PM
00 RS running super lean, please help! wistful Normally Aspirated Powertrain 12 09-11-2002 10:17 PM
Intake+exaust=lean..please help.. SiLu Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 08-22-2002 12:33 PM


All times are GMT -4. The time now is 03:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.